DOOM 3 > General Discussions > Topic Details
Vergeltungsführer Jan 5, 2013 @ 11:57am
Sikkmod destroys my graphic, why?
i can't use sikkmod because it totally destroys my graphics. does anyone have same problems or advice?

just little screenshot for example:
http://i.imgur.com/J2ANx.jpg

when i turn on any option it zooms in, everything is blurry but in very weird way, when i turn on ssao, i have completly white screen with crosshair. even when i don't turn on any graphic option, graphic is broken for example where picture shoud be disorted behind lost souls or any fire, like exhaust from spaceship, or around bfg projectile is strange mirrored picture. see here:
http://i.imgur.com/euOb4.jpg
http://i.imgur.com/Ds4xd.jpg

btw i don't have any problem when i run doom 3 without sikkmod.
Last edited by Vergeltungsführer; Jan 5, 2013 @ 12:05pm
Showing 1-15 of 21 comments
< >
❤ Jay ❤ Jan 5, 2013 @ 12:21pm 
You need a Cfg file with everything you want enabled on the mod. check youtuve videos on sikkmod.
Vergeltungsführer Jan 5, 2013 @ 12:47pm 
i found answer on moddb. i should to disable catalyst ai in catalyst control center. now works fine!
Pvt Jkr 88 Jan 10, 2013 @ 6:45am 
how did you disable catalyst ai please? I have been having the same issues with my hd7850.
Vergeltungsführer Jan 10, 2013 @ 7:58am 
open catalyst control center, select gaming > 3d application settings, scroll down and find catalyst ai. check "disable catalyst ai"
Pvt Jkr 88 Jan 10, 2013 @ 4:59pm 
Lol if only, That option does not exist on CCC anymore. I'm assuming you must have really old drivers installed?
Sanjuaro Jan 10, 2013 @ 7:24pm 
I've got a 7850 with the latest CCC and the option is still present for me. Are you sure you're not overlooking it Pvt Jkr 88?
Pvt Jkr 88 Jan 11, 2013 @ 10:08am 
Catalyst AI is there, but you cannot de-activate it. You can only set it to 'high quality' or 'performance'
Vergeltungsführer Jan 12, 2013 @ 7:57am 
there are alternative ways to disable it that i can't and don't have time to explain. use google. or install older drivers. every game works fine with older drivers
Last edited by Vergeltungsführer; Jan 12, 2013 @ 7:58am
Pvt Jkr 88 Jan 12, 2013 @ 1:53pm 
Do you know which drivers specifically have the option to deactivate it?
Hauzer Jan 13, 2013 @ 1:26am 
There should be a checkbox beside it that disables it if you check it
Vergeltungsführer Jan 13, 2013 @ 4:40am 
i have 9.2.0.0. version. but i have laptop, so i'm not sure if there is same version for desktop computers (in other words, do they use same numbers)
Pvt Jkr 88 Jan 13, 2013 @ 7:54am 
Originally posted by Hauzer:
There should be a checkbox beside it that disables it if you check it
It really doesn't.
Major Havoc Jan 14, 2013 @ 12:28am 
Originally posted by Bloodbather:
i have 9.2.0.0. version. but i have laptop, so i'm not sure if there is same version for desktop computers (in other words, do they use same numbers)
The laptop version of the AMD Vision Control center does. Just launch it and click Gaming then 3D appilication Settings. Then just scroll down to Catalyst AI and check the box that says Disable Catalyst AI.
SirMarth01 Jan 16, 2013 @ 7:27pm 
To disable Catalyst AI:
Method 1:
- Open up AMD Vision Engine Control Center
- Click on Preferences, then Advanced
- Select Gaming on the left, then 3D Application Settings
- Scroll down to Catalyst A.I.
- Set Texture Filtering Quality to "Quality", and uncheck "Enable Surface Format Optimization"

Method 2:
- Open up Windows Explorer
- Type in "%APPDATA%" without quotation marks into the address bar, then replace "roaming" with "Local\ATI\ACE", without quotation marks
- Open up Profiles.xml
- Search for <Feature name="CatalystAI">
- The next line should be something like the following:
<Property name="CatalystAI" value="Enable2"/>
Change "Enable2" or whatever is there to "Disable", making sure to keep it in quotation marks like how "Enable2" is above.

Method 1 has fixed the problems I'd had with another game that uses OpenGL. I've not tried Method 2, but I see no reason why it shouldn't work.
OuchOfDeath Feb 28, 2013 @ 1:20pm 
There's a much easier solution to this problem. Simply rename doom3.exe to something else. Catalyst Control Center AI applies its optimizations to games (which can cause bugs such as this one) based on the exe name only.
Showing 1-15 of 21 comments
< >
Per page: 15 30 50