DOOM 3 > 一般討論 > 主題細節
Roachy-D 2013 年 04 月 28 日 @ 下午 5 時 23 分
Resolution not changing?
I went to change the resolution to the highest one available. Then it says you need to restart Doom 3, so I do that, but when I start it up it goes back to 640x480. Any fix?
顯示 1-15,共 22 則回應
< >
SwagHunter 2013 年 05 月 2 日 @ 上午 1 時 29 分 
same problem... i sent them a support ticket to let them know and tried this http://www.youtube.com/watch?v=m8MsbasgAgE
without success.
最後修改者:SwagHunter; 2013 年 05 月 2 日 @ 上午 1 時 29 分
Roachy-D 2013 年 05 月 2 日 @ 上午 3 時 31 分 
I guess I buy Doom 3 BFG Edition.
SwagHunter 2013 年 05 月 2 日 @ 上午 9 時 51 分 
I found the solution ! Here it is:

"There are tons of threads on this but try this,

Launch game, open console (~ key) and type these commands one at at time:

r_mode -1

r_aspectRatio 2

Exit the game and open your DoomConfig.cfg file located in your Doom 3/base folder. Alt+F and type custom in the searchbox. You should see a couple commands that say customHeight and customWidth. Manually input your monitor's resolution where the xxxx's should be. So if you have a 1920x1200 monitor, customWidth should be 1920 and customHeight should be 1200. Double check and make sure r_mode is -1 and r_aspectRatio is 2 in your config file.

Launch your game and it should be the proper resolution. Your in-game menu will still say 640x480 but just ignore that because it's a display menu bug."

It's not from me, but it worked perfectly !! Now the game is awesome :D
Roachy-D 2013 年 05 月 2 日 @ 上午 11 時 42 分 
Yeah I saw that. That's why I created this because that doesn't help I don't even have a customWidth or customHeight. I'm just going to buy the BFG Edition I heard it's better.
SwagHunter 2013 年 05 月 2 日 @ 下午 12 時 25 分 
Trust me this is the solution of your problem. Be sure you entered your screen settings (1600*900 for me) correctly, it should work properly.
Roachy-D 2013 年 05 月 2 日 @ 下午 12 時 31 分 
Did you not see what I typed? I said I don't have a customHeight and customWidth. Besides getting BFG Edition is beter since it contains every single Doom game in the world.
SwagHunter 2013 年 05 月 4 日 @ 上午 7 時 51 分 
if you have steam's doom 3, you cannot not have this: "DoomConfig.cfg file located in your Doom 3/base " :P.
Anyway, BFG edition contains every single Doom, which is awesome :D.
Roachy-D 2013 年 05 月 4 日 @ 上午 8 時 20 分 
I do have that, but when I open it there's no customHeight or customWidth.
SwagHunter 2013 年 05 月 4 日 @ 上午 8 時 43 分 
seta r_customHeight "900"
seta r_customWidth "1600"
seta r_fullscreen "1"
seta r_mode "-1"

and farther

seta r_aspectRatio "2"

Trust me you DO have it ^^. It took me long to find them, too.
Jagdpanzer 2013 年 05 月 4 日 @ 上午 9 時 10 分 
You may also have a "autoexec.cfg" in your "doom3/base" directory; if you do, try looking in there for the custom width and height that Julius mentions.
Roachy-D 2013 年 05 月 4 日 @ 上午 11 時 59 分 
Oh! I thought it started with customHeigh and cutomWidth.
Zünd den Knaller 2013 年 05 月 30 日 @ 下午 1 時 39 分 
Julius 發表:
seta r_customHeight "900"
seta r_customWidth "1600"
seta r_fullscreen "1"
seta r_mode "-1"

and farther

seta r_aspectRatio "2"

Trust me you DO have it ^^. It took me long to find them, too.

create a autoexec.cfg which inclued this content and type in your resolution.
in "seta r_aspectRatio change the "2" into a 1 if you got a 16:9 screen
SwagHunter 2013 年 05 月 31 日 @ 上午 2 時 33 分 
@Zun nonono !! you don't have to create this file (autoexec.cfg) ! It's already there: "DoomConfig.cfg file located in your Doom 3/base folder".
Roachy-D 2013 年 05 月 31 日 @ 上午 11 時 41 分 
This discussion is dead I have Doom 3 uninstalled and plan on Getting the BFG edition instead.
Sigmund Faust 2013 年 06 月 1 日 @ 下午 7 時 36 分 
Thanks for the tips, I came across the same problem. A couple bits missing for me, like

-- Setting AA and AF which I won't link to because it reverted the resolution changes.

-- How to enable the console (ctrl alt ~ wasn't cutting it):
right click Doom 3 in steam, click set launch options, paste this in, without quotes: " +set com_allowConsole 1" .
最後修改者:Sigmund Faust; 2013 年 06 月 1 日 @ 下午 8 時 06 分
顯示 1-15,共 22 則回應
< >
每頁: 15 30 50
張貼日期: 2013 年 04 月 28 日 @ 下午 5 時 23 分
回覆: 22