DOOM 3 > Genel Başlıklar > Konu Detayları
The Freak Philosopher 30 Ara 2013 @ 4:33am
Resolution Settings Aren't Saving.
I'm trying to max out the resolution in the settings but when i run the game again, it just reverts it 600x400. is there a settigs file i need to delete or something? also, is there an HD patch?
17 yorumdan 1 ile 15 arası gösteriliyor
< >
i570k 30 Ara 2013 @ 6:06am 
I had the same problem. I ended up having to change them through the console, after which they stayed right.

Set your desired graphics settings (antialiasing, texture detail, etc through the menu)

launch the console by hitting ~ or ctrl, alth, and ~

Enter the following commands:
r_mode -1
r_aspectRatio 2
r_customHeight XXXX (where XXXX = your computer's Y resolution)
r_customWidth XXXX (where XXXX = your computer's X resolution)
vid_restart

worked for me
The Freak Philosopher 30 Ara 2013 @ 5:54pm 
thanks, but for some reason it just went back to 600x400 when i putin vid_restart
if there's a mod for the original fallout, i bet there's one for this too. i'll look around when i have time.
[XI] WarAndPeace 30 Ara 2013 @ 6:10pm 
I'm dealing with the same problem, the resolution justs resets itself back to its default mode.
i570k 31 Ara 2013 @ 12:46am 
hmm. have you tried creating a new text file, rename it to "AutoExec.cfg" (without quotes) and placing it in your \Doom 3\base\ directory. you can put all the commands in there and it will laod them automatically so try the above console comands without the vid_restart maybe?
i570k 31 Ara 2013 @ 12:49am 
Actually just put the following into your autoexec, except for the comments (ie the bits after the //), and substituate your screen resolution accordingly.

seta r_mode -1
seta r_aspectRatio 1 //(0 = 4:3, 1 = 16:9, 2 = 16:10)
seta r_customHeight 768 //(Your screen height)
seta r_customWidth 1360 //(Your screen width)
com_allowconsole 1
The Freak Philosopher 31 Ara 2013 @ 9:32pm 
i really tried, but i honestly could not get this to work... i even tried the most popular HD patch but when i tried to run the exe instal for it, it would just cause my windows explorer to go idle on me (meaing it's just try to load but never load anything) and the only way to cansel the operation was the retart the whole system as canceling widows explorer in task manager is obviously pointless.
iwasbornalegend 1 Oca @ 3:18pm 
This all nice and whatever. But the fact that I have to enter consoles commands to get a game to work properly is ♥♥♥♥♥♥♥♥.
i570k 2 Oca @ 1:10am 
iwasbornalegend tarafından gönderilen ileti:
This all nice and whatever. But the fact that I have to enter consoles commands to get a game to work properly is ♥♥♥♥♥♥♥♥.

Agreed. I had similar problems with Quake IV too. But having said that, bear in mind the game is a bit dated, and there is the BFG version available too, which from what I've heard doesn't have the same issues.
The Freak Philosopher 2 Oca @ 8:51am 
i think it's a matter of your graphics hardware. i have a mbile AMD A8 in this laptop i'm using and i think the software's engine is having a fit with the hardware. most people don't have any problem running this at high res so the original Doom 3 was recommended for PC over the BFG edition for that reason. Also, Doom 3 has a robust mod community (no where near as much as that of doom's classic engine though) and it cost less. oh well, this gpu isn't much but it's 100x more than powerful enough to run this game, so i'll figure something out. thanks for the advice. i might just reinstall it and see if i can't edit the settings again regularly and seeif they stick this time.
a.k.a. Dead 10 Oca @ 5:32pm 
Try as I might, the settings won't stick once starting the game, and the aspect ratio command line disappears entirely from the edited .cfg. The .cfg is not set to read only or hidden, and my Steam folder is installed to C:\Steam, so there shouldn't be any write permission issues.
The Freak Philosopher 10 Oca @ 6:07pm 
i uninstalled then renstalled it and run the game on ultra now and that setting saves. still not 16:9, but it's further than i've gotten before so i'll quit while i'm ahead. no big deal.
En son The Freak Philosopher tarafından düzenlendi; 10 Oca @ 6:08pm
a.k.a. Dead 10 Oca @ 6:12pm 
The Freak Philosopher tarafından gönderilen ileti:
i uninstalled then renstalled it and run the game on ultra now and that setting saves. still not 16:9, but it's further than i've gotten before so i'll quit while i'm ahead. no big deal.

With a bit of searching, I found a fix. Not only can you now set 16:9 resolutions from the menu, but the main and options menu have been given a facelift.

http://www.gamefront.com/files/files/9867709/6thvenomhqmainmenu1.00b.zip

Just uzip the file where you saved it, and the install instructions are in the read-me. It's a really simple install, it just requires copying one file to two locations.

Cheers. :)


Thanks to Venom, the author of the mod. The game looks even better than I remembered, and the options menu now has an af setting (only 8x, but you can force more through your cp) and some other goodies.
En son a.k.a. Dead tarafından düzenlendi; 10 Oca @ 6:18pm
The Freak Philosopher 10 Oca @ 6:47pm 
Hot damn! worked perfectly! in the words of the Heavy, "MANY TANKS!!!!"
a.k.a. Dead 10 Oca @ 7:20pm 
The Freak Philosopher tarafından gönderilen ileti:
Hot damn! worked perfectly! in the words of the Heavy, "MANY TANKS!!!!"

'Tank' the gaming 'G*ds' for modders.

There is a bug, unfortunately, when in game and you use esc. to save (or using esc. in general - I think), any other menu such as options will not be on top - for some reason the save menu will get stuck in focus (on top).

So make sure you get everything set up when you start the game (before loading or starting a new game), if you don't, you may have to quit the game and restart it to be able to have other option menus in focus (on top).

If I find a work-around for this I'll post back, but it isn't that big of a deal once you get your settings to your liking.



May your Friday night be full of, well - DOOM!! (and Grace - I read your profile).

:)
En son a.k.a. Dead tarafından düzenlendi; 11 Oca @ 7:14am
The Freak Philosopher 11 Oca @ 6:55pm 
yeah i notced. i'll add you back. felt good playing this game again.
17 yorumdan 1 ile 15 arası gösteriliyor
< >
Sayfa başına: 15 30 50