DOOM 3
DOOM 3 > General Discussions > Topic Details
FIXING RESOLUTION RESET (WORKS)
does your resolution reset everytime you load the game?
i just spent the past hour or two trying to find the solution for this. there's a lot of suggestions out there, most of which revolve around changing the doomconfig.cfg or making a autoexec.cfg. these suggestions didn't work for me and they didn't seem to work for a lot of other people. it seams the steam release (or re-release) screwed those fixes up. however, i did find one solution that worked and i figured i'd share it in case anyone else needed it.

go into /base whereever doom 3 is installed and make a notepad doc. put in the following as you need it, not including the parentheticals:
r_mode -1 (means putting into custom mode)
r_aspectratio 1 (this changes the aspect ratio 0 is for a 4:3 display, 1 a 16:9 display (widescreen) and 2 a 16:10 display)
r_customHeight 768 (means custom resolution height)
r_customWidth 1366 (means custom resolution width)
r_multiSamples "0" (anti-aliasing)
vid_restart

save the doc as res.cfg.
DO NOT MAKE DOOMCONFIG.CFG READONLY
run doom 3 and bring up the console (ctrl+alt+~ for us keyboard)
put in the command: exec res.cfg

at which point the video should restart into whatever resolution you put in. unfortunately, you have to put in the console command everytime you run the game. there are some other command lines you can put into res.cfg to make the game run better. google them if you want them. hope this helps anyone with this problem.
Last edited by johnpaulthesecond; Apr 10, 2014 @ 3:44pm
< >
Showing 1-8 of 8 comments
GA:DonaldDumb Apr 21, 2014 @ 8:28am 
do not know on which atari your console is, but on mine...exec res.cfg is an unknown command in opened console :-(((
johnpaulthesecond Apr 21, 2014 @ 8:56am 
do you have a res.cfg? exec X is definitely a command.
GA:DonaldDumb Apr 21, 2014 @ 9:02am 
sure, named and saved it like this, but wrote paramaters in the game given config in the base folder to have full hd now
johnpaulthesecond Apr 21, 2014 @ 9:05am 
*shrug*
well if that stuck then i guess you don't have the bug. so you won't need the workaround.
GA:DonaldDumb Apr 21, 2014 @ 9:42am 
had the res threetimes after apply and restart resetted, so i wrote ethe resolution in that config in base folder^^
fuzion Apr 22, 2014 @ 9:10am 
hey guys i been trying every method out there to fix my resolution, but it keeps resetting everytime i start doom3, execing res.cfg with those parameters doesnt seem to work for me.. i even tried edditing the doomconfig.cfg and still no luck how do i force this game to play at max res!!! somone plz help
fuzion Apr 22, 2014 @ 9:48am 
alright guys i finally found a solution that worked for me ... what you need to do is edit how doom3.exe starts, you can do it through steam since starts through steam. goto Your game library--> doom3--> right click- goto properties then goto "set launch options" Here you can put in parameters to force doom3 to run. heres what i put in there and the res stayed.

"+disconnect +set com_allowconsole 1 +set r_mode -1 +set r_customWidth 1920 +set r_customHeight 1080 +set r_aspectratio 1"

after doing this start doom and you will notice your res changed to what you wish.
DiogoSN Apr 22, 2014 @ 5:12pm 
Originally posted by fuzion:
alright guys i finally found a solution that worked for me ... what you need to do is edit how doom3.exe starts, you can do it through steam since starts through steam. goto Your game library--> doom3--> right click- goto properties then goto "set launch options" Here you can put in parameters to force doom3 to run. heres what i put in there and the res stayed.

"+disconnect +set com_allowconsole 1 +set r_mode -1 +set r_customWidth 1920 +set r_customHeight 1080 +set r_aspectratio 1"

after doing this start doom and you will notice your res changed to what you wish.

Thanks mate!
< >
Showing 1-8 of 8 comments
Per page: 15 30 50

DOOM 3 > General Discussions > Topic Details
Date Posted: Apr 10, 2014 @ 3:37pm
Posts: 8