DOOM 3 > General Discussions > Topic Details
Agmat Jul 29 @ 11:18pm
Catalyst ai troubles
Ok, so I've got the sikkmod installed and the hi res texture pack. I know in order to get it to work properly on Radeon cards you have to disable catalyst ai, either through a registry edit or .ini file change. Well Every time I disable Catalyst ai and start the game, the graphic are still glitched. I go out of the game and catalyst ai is turned back on! No matter how I turn it off, as soon as I load up Doom it gets turned back on. Anyone heard of this before? Know how to get around it? I also tried the rename doom3.exe trick but that doesn't work, steam just gives me an error and won't load the game. Any help would be much appreciated.
Showing 1-2 of 2 comments
< >
Xue Jul 31 @ 1:04am 
Have you tried the Profiles.xml editing method? I've just done this barely 5 minutes ago to fix the same problem for myself.

  1. Go to C:/Users/<Your username>/AppData/Local/ATI/ACE/Profiles.xml
  2. Right-click and open with Notepad or something.
  3. Find the CatalystAI entry and replace Enable with Disable, then save and close.
  4. Right-click Profiles.xml, go to Properties and set it to Read-only. This part is probably fairly important, it would not work for me until I set this to Read-only after editing it.
  5. Go to C:\Program Files (x86)\ATI Technologies\ATI.ACE\Core-Static\ and run MOM.exe
  6. It will probably look like nothing happens. Don't worry about that, just wait a few seconds and then restart your PC.

This fixed it for me, hopefully it'll fix it for you.
griggo Jul 31 @ 5:26pm 
I couldn't get catalyst ai disable either but I was able to rename my doom3.exe to doom_3.exe. You will have to go to 'add a non-steam game to my library' and pick the renamed exe. Runs fine now.
Last edited by griggo; Aug 1 @ 3:48pm
Showing 1-2 of 2 comments
< >
Per page: 15 30 50