SEAMEN Dikbut-kiss Dec 28, 2013 @ 8:45am
Lag, stuttering, etc, on a pretty good system.
ATI 8xxx series, 2gb dedicated
I5 quad core, at 3.3ghz per core
16gb ram

-Lags like bloody balls on the specs above. Not always, but when facing a certain direction it occurs. Turned that GL thing off, no difference. Not a hardware issue as BF4, Rome II etc work like charms.

Plz help, this game is a classic and i'd love to reply it.

Cheers.
Showing 1-15 of 20 comments
< >
SEAMEN Dikbut-kiss Dec 28, 2013 @ 2:53pm 
Downloaded the 1.42c patch for RtCW (the one that didnt specify 32 bit, since im running 64). Will check it out tmrw.
Checked the steam forums for this earlier, weird I missed it.
Thanks for the prompt help m8, hope u have a good day.
Last edited by SEAMEN Dikbut-kiss; Dec 28, 2013 @ 2:53pm
SEAMEN Dikbut-kiss Dec 29, 2013 @ 9:59am 
Thanks, but no luck im afraid. Tried several other "solutions", with no luck.
It is not the 1st time Steam has delivered a old/classic game poorly.
I got a non Steam version, and it works absolutely fine.
I'll just make sure I dont buy old games from Steam anymore.
Thanks for your time, and apprecitate the help.
>M@tEo$< Dec 29, 2013 @ 10:06am 
I never had issues with any old games released through Steam, it's the same as the CD, modified EXEs so no CD required ^^' It's not Valve/Steam fault in any way, it's the publisher over the developers imho.

Doom and others are fine :)
SEAMEN Dikbut-kiss Dec 29, 2013 @ 11:11am 
Yeah, your probably right, Im no expert.
I'll just play it safe and buy retail versions for these games.
Equation™ Dec 29, 2013 @ 11:19am 
Originally posted by SEAMEN:
Yeah, your probably right, Im no expert.
I'll just play it safe and buy retail versions for these games.

You'll probably find more problmems with the disc version as they usually install old versions of DX not compatible with modern OS.

I rebought a few old games on Steam as the Disc versions I owned were playing up on my OS.

Have you tried setting this game as administrator or running it under "compatible with"
SEAMEN Dikbut-kiss Dec 29, 2013 @ 11:30am 
Yeah, tried those. Compatability with Wn 7, as an admin. No luck. Any other suggestions would be much appreciated.
Normally I would be inclined to agree that the retail versions could only be more unstable than Steam versions (as Steam would update the game's compatability with new operating systems), but in my experience System Shock 2 and RtCW do not run well on Steam, whereas the retail versions have given me no problems.
But who knows, could be something I am ♥♥♥♥ing up.
>M@tEo$< Dec 29, 2013 @ 11:43am 
Maybe this:
http://forums.warchest.com/showthread.php/38843-Game-LAgging-problem

WolfET was supposed to be an add-on for RtCW; Lucky or not, it's been released for free. Same engine, so I think this cvar exists already in RtCW. You can check the wolfconfig.cfg or type the command without a value in the console to check.
rockman Dec 31, 2013 @ 12:22am 
>M@tEo$< - thx, but that did not solve the low FPS / framerates issues I am experiencing either.
SEAMEN - Have you found a resolution yet?
SEAMEN Dikbut-kiss Dec 31, 2013 @ 4:34am 
-Mateos, I tried your solution, I might be doing something wrong, cause it doesnt work for me :(

-Mateos & pjs, I never fixed the Steam version, tried a bunch of things. One recommendation was to run it off Windows virtual machine which would run Win XP instead of 7. But thats a bit of a fuss, to say the least. Pjs, I can link it to you should you feel the energy to try it out.
Otherwise, I never resolved the issue, I just used a old physical CD copy that I had to reinstall Wolfenstein. Now it works ♥♥♥♥ing great.

-So pjs, if you feel like shelling out a few more euros/dollars or whatever, try finding various sites online to buy RtCW (without Steam) Like Amazon. Dont try Greenman gaming, as it sells it with Steam unfortunately :( and gog.com doesnt sell RtCW at alll.
I am UNSURE if this suggestion will work for you, but non Steam versions of Hitman 47, RtCW and System Shock 2 all worked WAY better without Steam, (for me atleast).
Last edited by SEAMEN Dikbut-kiss; Dec 31, 2013 @ 4:35am
>M@tEo$< Dec 31, 2013 @ 4:48am 
Have you checked that the values are permanently modified? With either reading the wolfconfig.cfg or typing in the console /cvarname?

If ingame you just did /cvarname value it isn't saved, you need to do /seta cvarname value, and sometimes /vid_restart (or /vidrestart, not sure).
Last edited by >M@tEo$<; Dec 31, 2013 @ 7:04am
SEAMEN Dikbut-kiss Dec 31, 2013 @ 5:55am 
Big fat thanks to you Mateos, your link which recommended: change Steam launch values to +set r_primitives 2 worked perfectly, everything is as it should be. The setting stuck this time, unlike before, when I only did it in game.
Thanks again!
>M@tEo$< Dec 31, 2013 @ 7:04am 
Glad it works now ^^
rockman Jan 5, 2014 @ 4:15pm 
I've also confirmed changing Steam launch values for the RTCW to "+set r_primitives 2" works on my system with a Radeon HD 7770 and with max settings, we're flying again. Cheers!
Showing 1-15 of 20 comments
< >
Per page: 15 30 50
Date Posted: Dec 28, 2013 @ 8:45am
Posts: 20