Sid Meier's Civilization V

Sid Meier's Civilization V

View Stats:
jazztickets Jun 10, 2014 @ 1:10pm
Linux audio problems
The intro videos play fine, but when the main game loads the music/voice audio is stuttering. Anyone else getting this?

Arch Linux 64-bit w/ PulseAudio
< >
Showing 46-60 of 61 comments
bitterologist Jun 24, 2014 @ 8:08am 
Not working for me either (Arch linux 64bit). Or rather, the sound plays just fine during the intro cinematic. After that, I get crackling sound from the analog output no matter what pulseaudio settings I use. What's more annoying though is that I can't get the game to use my USB sound card. And the weirdest thing is this: if I play sound from another source, e.g. some music, I can hear the Civ5 sounds using my USB sound card – albeit with crackle still present – but the moment the song stops, so do the Civ5 sounds. I've never had any problems like this before with pulseaudio. I'm really at a loss here, this is just weird.
Last edited by bitterologist; Jun 24, 2014 @ 8:23am
DiJuMx Jun 28, 2014 @ 6:42am 
Originally posted by shijtin:
Same problem. Arch Linux 64 bits Pulseaudio.


A workaround that did it for me :

edit the file /etc/pulse/daemon.conf and set
default-fragment-size-msec = 5

Can confirm that this seems to have worked on Debian Jessie.
Major Jul 2, 2014 @ 5:33pm 
Originally posted by DRMProd:
This is the solution that worked for me:
Open /etc/pulse/daemon.conf as root. At the end of the file you'll find these two lines:

default-fragments = 8
default-fragment-size-msec = 5

Edit them so they look like this:

default-fragments = 5
default-fragment-size-msec = 25

Next restart pulseaudio. Open a terminal and type:

killall pulseaudio
pulseaudio -D

That's all. Working like a charm now on Linux Mint 17 64Bit.

Confirmed that this worked for me on Ubuntu 12.04 64bit.
MrSuchyPL Aug 27, 2014 @ 11:25am 
default-fragments = 5
default-fragment-size-msec = 2

work for me on my Linux MInt 17 64bit.
morp Dec 20, 2014 @ 3:18pm 
Originally posted by shijtin:
Same problem. Arch Linux 64 bits Pulseaudio.


A workaround that did it for me :

edit the file /etc/pulse/daemon.conf and set
default-fragment-size-msec = 5

Well Done Kiddo! I had same problem. I have NVidia GTX 690 running 64 bit Ubuntu 14.04 with NVidia proprietary drivers version: 331.113
I set default-fragment-size-msec = 5 ... sound was better but choppy half as much
Then set default-fragment-size-msec = 1 and now sounds smooth as silk. Tanx!!!!
Oleg Dec 22, 2014 @ 2:54am 
Mageia 4.

Open /etc/pulse/daemon.conf

Find
; default-fragments = 4 ; default-fragment-size-msec = 25

And replace with:
default-fragments = 5 default-fragment-size-msec = 2

Exec
pulseaudio --kill pulseaudio --start

Works for me.
pseudonym404 Jan 19, 2015 @ 12:27am 
I fixed this on my system (Kubuntu 14.04 x86_64) with
cp /usr/lib/i386-linux-gnu/libopenal.so.1 ~/.local/share/Steam/SteamApps/common/Sid\ Meier\'s\ Civilization\ V
to replace the bundled copy (1.13.0) with the system copy (1.14.0)
jemmasta Mar 6, 2015 @ 12:39pm 
Originally posted by pseudonym404:
I fixed this on my system (Kubuntu 14.04 x86_64) with
cp /usr/lib/i386-linux-gnu/libopenal.so.1 ~/.local/share/Steam/SteamApps/common/Sid\ Meier\'s\ Civilization\ V
to replace the bundled copy (1.13.0) with the system copy (1.14.0)


For me this was the key as well, although SteamApps was in lowercase :) Changing Pulseaudio configs did nothing.
zalasur May 16, 2015 @ 9:48am 
I finally got the stuttering to stop by setting the following in /etc/pulse/daemon.conf

default-fragments = 8
default-fragment-size-msec = 1

So the takeaway I got from trying different settings that people have recommended on this thread is that there isn't a one-size-fits all solution to the stuttering problem. Trying the different parameters that various people have suggested seems to me to be the preferred solution.

What didn't work:

As others have suggested it is *not* recommended to use ALSA as it is outdated and proprietary. Despite its wrinkles, PulseAudio is the sound driver of choice for modern Linux distributions for a good reason.

Also, copying libopenal.so.1 to the game directory under SteamApps as someone suggested cause a big problem for me: it caused my sound card to stop working at all until I did a hard reboot (power off then power on). I wouldn't recommend it.
evilny0 May 18, 2015 @ 11:32am 
Hum... nope. Alsa is released under the GPL, it's definitely not proprietary. It's not outdated either. Pulseaudio is actually using Alsa as a backend by default on several distributions, including Ubuntu, Mint and Arch afaik.

However, as you said we should stick with Pulse, and not use Alsa directly :).
AsavarTzeth Linux May 20, 2015 @ 8:20am 
Just to complement evilny0, and his obviously correct comment.

Alsa is the sound system integrated in the kernel. All linux audio drivers are pretty much written for Alsa.

PulseAudio is a sound server/daemon that runs on top and manages things like multiple output from different sources at the same time and obviously a lot more. It is obviously much more appropriate for a desktop application (like a game) to talk to pulse, if that is available on the system.

Both are Free Software.
Last edited by AsavarTzeth Linux; May 20, 2015 @ 8:21am
crazy.crazy.eco Oct 31, 2015 @ 2:21pm 
changing `default-fragment` and `default-fragment-size-msec` did not change anything.

~/.steam/steam/steamapps/common/Sid Meier's Civilization Beyond Earth$ cp /usr/lib/i386-linux-gnu/libopenal.so.1 .

helped. tnx.
cado_arena Dec 4, 2015 @ 10:28am 
Originally posted by shijtin:
Same problem. Arch Linux 64 bits Pulseaudio.


A workaround that did it for me :

edit the file /etc/pulse/daemon.conf and set
default-fragment-size-msec = 5
Solved!
JonnyTeronni Dec 13, 2015 @ 5:33am 
Originally posted by shijtin:
Same problem. Arch Linux 64 bits Pulseaudio.


A workaround that did it for me :

edit the file /etc/pulse/daemon.conf and set
default-fragment-size-msec = 5

This and pulseaudio -k to restart it

(Ubuntu 14.04 64bits)
Last edited by JonnyTeronni; Dec 13, 2015 @ 5:34am
PixelGuff May 29, 2016 @ 8:20am 
Hah, can also confirm that the pulseaudio fix sorted out the stuttering for me on 64-bit Debian 8.
< >
Showing 46-60 of 61 comments
Per page: 15 30 50

Date Posted: Jun 10, 2014 @ 1:10pm
Posts: 62