crispy_nonsense Jul 13, 2013 @ 5:02am
It randomly crashes after installing a brave new world
Anyone got any advice? The game just crashes after 5-20 minutes of gameplay. The only message is that Civilisation 5 has stopped working. Ive checked the integrity of the game cache three times and uninstalled all steam workshop mods, and no luck. I've also updated my video card drivers. My machine has an AMD radeon hd 6780 and an ATI phenom 2. Any help would really be appreciated, Thanks
Showing 1-15 of 24 comments
< >
crispy_nonsense Jul 13, 2013 @ 5:04am 
Running 64 bit Windows 8
dllin22 Jul 13, 2013 @ 5:42am 
I run 64-bit Win8 as well and I have the same problem, but I don't own BNW. I think this may have something to do with Win8 then.
crispy_nonsense Jul 13, 2013 @ 5:49am 
Maybe, but if it was something to do with windows 8 i think the problem would be more widespread.
noiser Jul 13, 2013 @ 6:04am 
I checked the official Civ5 forums, people have the same problem there, mixed OS as well.
I made a post about it in on of the threads and I would recommend you guys to do the same so we can bring this problem to light and hopefully the developers will be able to fix it.
crispy_nonsense Jul 13, 2013 @ 6:06am 
oh cool, I'll go and do that then, Thanks
Stravix Jul 13, 2013 @ 6:40am 
I have the same issue running Windows 7. Latest drivers for the graphics card and everything.
TYLSONgg Jul 13, 2013 @ 6:51am 
my civ crashin pretty mutch every 1/2hrs [win8] :/
Spudgunner Jul 13, 2013 @ 6:58am 
Same here except my playtime is anything from 5 minutes to 3 hours. One time I noticed a Render error. It was one of the popups that hides behind the game window, You can only see it by alt-tabbing. Other times is a CTD.

I play the game on DX11 mode. Win7, nVidia GTX 580 latest drivers.
crispy_nonsense Jul 13, 2013 @ 7:00am 
Yeah I just managed to get around 2 hours, as far as i can tell it crashes when a move finishes
Traveler Jul 13, 2013 @ 1:03pm 
So your saying that the game is just as unstable with BNW as without.
crispy_nonsense Jul 13, 2013 @ 1:04pm 
When i didn't have BNW it never crashed
Darkfirephoenix Jul 13, 2013 @ 6:40pm 
Civ 5 started crashing for me after I installed BnW, didn't happen after Gods and Kings. The crash happens EVERY TIME I try to create a game, so I'm on loading screen with my civ and halfway through sound repeats and then I'm back at desktop. I have Win XP SP3, nVidia Gt 440
with latest drivers
|Lag Co'|Regulus Jul 13, 2013 @ 7:55pm 
Same problem here, getting a bit ♥♥♥♥ed off about it too...
Korsobar Jul 16, 2013 @ 2:29pm 
I have the same crashing mid game problem w/ no error messaging. Win 7 64 bit. If anyone finds a fix, please post it.
ewannicolson Jul 16, 2013 @ 2:43pm 
I've just downloaded the DLC and installed it and instead of it loading it says it's running BnW but then opens up as Gods & Kings instead...
Showing 1-15 of 24 comments
< >
Per page: 15 30 50
Date Posted: Jul 13, 2013 @ 5:02am
Posts: 24