αλίενο - 333 -333 -333 Jun 9, 2013 @ 9:05pm
Civilization V: gold edition. Crash, issues.
I recently bought the gold edition of Civilization V, from Steam.
The game was installed correctly, but there have been a multitude of problems that make the game unplayable.
At first: If I put the game in directx 10-11 after about 5 minutes of play, the game crash, with this message: FGXRenderer11;;present failed hr=DXGI_ERROR_DEVICE_Removed.
What I did to try to solve this problem is to update my drivers for the video card, update my windows 7, give the option to check cache from Steam, and finally reinstall the game.
Nothing worked.
I tried to play from the version of directx 9 and apparently worked well, but after a half hour, can't end turns. I tried to start another game again with another civilization, but turns can't end.
In truth and tried almost everything, but I see that this game is so poorly optimized, it is possible that about half of the computers do not run well.
I demand an answer, I paid for the game, and it does not work.
Showing 1-15 of 38 comments
< >
Stubz Jun 9, 2013 @ 9:25pm 
I bought it last night, and it ran fine for 2 hours, now it crashes after like you say 5 minutes.

I'm running Win8 though.

I can this being a prolonged problem, going to be FUN!
Stubz Jun 9, 2013 @ 9:44pm 
Its only been a short while still, 15 minutes but I've turned of "Vsync" in my preferences and it seems to be getting farer, but can't promise anything yet, will reply later either way.
Peter Pan Jun 10, 2013 @ 3:38am 
Sorry can't help, I can only say that I have not suffered any problems.

But, in my old PC, I could not run in Directx 10-11 because it would freeze the opening cinematic. I had to stick with Directx 9.

In my current PC, I have no such problems.
KHORNE FLAKES Jun 10, 2013 @ 3:44am 
It started happening to me as well after last update, tried everything i could think off, even re-downloaded the game and still I get a crash right of the bat

Problem signature:
Problem Event Name: APPCRASH
Application Name: CivilizationV_DX11.exe
Application Version: 1.0.2.44
Application Timestamp: 510a1a7a
Fault Module Name: CivilizationV_DX11.exe
Fault Module Version: 1.0.2.44
Fault Module Timestamp: 510a1a7a
Exception Code: c0000005
Exception Offset: 001eb273
OS Version: 6.1.7601.2.1.0.768.3
Locale ID: 1045
Additional Information 1: 0a9e
Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
Additional Information 3: 0a9e
Additional Information 4: 0a9e372d3b4ad19135b953a78882e789
magicmazuma Jun 10, 2013 @ 4:39am 
Reading quite a few of these posts regarding crashes etc.
Guess im lucky I havent experienced any myself and I am close to 30 hrs in..

Windows 8,
i5_3350
GTX 650

Might be helpfull if you guys post youre system specs with these issues. Gives the devs something to go on.
marvinbland Jun 10, 2013 @ 10:31am 
yeap .......... count me in as getting crashed as well .... crash after crash after crash , makes the game unplayable ...
Espresso Jun 10, 2013 @ 10:36am 
System specs or a dxdiag would help.

Try running the "secondary installers" instructions from this site: http://pcgamingwiki.com/wiki/Civilization_V#Secondary_installers

Close any running programs except Civ V and Steam.

Make sure your GPU is not getting too hot during the game.
KHORNE FLAKES Jun 11, 2013 @ 5:23am 
okay, I deleted all the intro movies and restarted the steam. seems to have worked. the game is working now
αλίενο - 333 -333 -333 Jun 11, 2013 @ 3:15pm 
Thanks for all the anwers, guys. I tried all. Reinstalling, using the "secondary installers"; removing the movies from the intro, updating my wndows 7, updating my drivers from the video card, and nothing.
Civ 5 is the only game with this problems. I play dota 2, starcraft 2, diablo III, LoL, with no problems.
Civilization V, most bugued bad opti game ever.
Espresso Jun 11, 2013 @ 3:27pm 
Found another person with the same problem, no solution though: http://forums.2kgames.com/showthread.php?209901-FGXRenderer11-Present-failed-hr-DXGI_ERROR_DEVICE_REMOVED-Driver-failure

One person reports getting it to work in windowed mode: http://forums.2kgames.com/showthread.php?180171-FGXRenderer11-Present-failed-hr-DXGI_ERROR_DEVICE_REMOVED-Driver-failure&p=2569091#post2569091

Apparently I looked at this error before (I don't remember) because I posted a link to this in a similar thread: http://msdn.microsoft.com/en-us/library/windows/desktop/bb509553%28v=vs.85%29.aspx

According to that link, this is what the error means: "The video card has been physically removed from the system, or a driver upgrade for the video card has occurred. The application should destroy and recreate the device. "

One person said they fixed it by disabling leaderheads: http://pcgamingwiki.com/wiki/Civilization_V#Leaderhead_crash

If you're using ATI, one person was able to get it to work by changing power and fan settings in Catalyst: http://forums.steampowered.com/forums/showpost.php?p=31710552&postcount=15

Turning on VSync may help.

Try unchecking GPU Texture Decode: http://forums.steampowered.com/forums/showpost.php?p=33494934&postcount=26
Stubz Jun 11, 2013 @ 4:48pm 
All I did was launch in DirectX10/11 settings and it hasent crashed since.
αλίενο - 333 -333 -333 Jun 13, 2013 @ 2:28pm 
Thank you, Ragan. I checked all the issues, but not one gave me the solution. For example, unchecking the gpu texture decode did not work because it does not even give me the option to select that option, lol.
2K support did not help, only made me do things I had done, as reinstall, update drivers, etc..
I love this game, but I fear that I will ask for a refund, as it is unplayable.
Greetings.
Nines Jun 13, 2013 @ 5:07pm 
I've had this game since it came out and it's worked perfectly, plus I have a really high spec computer with everything in working order. Yet for some reason even I'm getting this same dumb error!

Whatever the problem is it's got to be due to the recent update, and they should definately fix it soon. We shouldn't have to be forced to do these stupid work around fixes, they could potentially end up doing more harm to our systems than good in the long run.
αλίενο - 333 -333 -333 Jun 15, 2013 @ 1:21pm 
Then do you think they should fix this soon? Because I can ask for a refound.
d4rwin19 Jun 15, 2013 @ 11:40pm 
I also have problems with the game, it always crash about 30 minutes after I started to play. Sometime he screen freeze and I can not do ctrl+alt+del or alt+tab. Sometime the pc just restart suddely. :(
I already tried to put the leader setting to minimum, it doesn't work. I heard Civ V have some problems with my VGA card Gforce 560 Ti
Showing 1-15 of 38 comments
< >
Per page: 15 30 50
Date Posted: Jun 9, 2013 @ 9:05pm
Posts: 38