Sid Meier's Civilization V

Sid Meier's Civilization V

View Stats:
World Builder not launching.
I cannot launch World Builder, it just freezes on the loading screen.

Help ?
< >
Showing 1-7 of 7 comments
Malakai Feb 27, 2013 @ 12:54pm 
Try closing Steam and launching from the exe.
jphilip79 Feb 27, 2013 @ 2:42pm 
I am having the same problem. I can't use World builder anymore. Tried closing Steam, doesn't help
I'm having this issue too. Whenever I launch World Builder from the SDK it just goes to the loading screen and stays there, frozen. I've launched World Builder and made maps using it in the past, so it must've been the result of some patch, either to Civ V or Steam, but I've no idea which one or how to solve it.

I've looked about for a solution elsewhere and the only suggested solution I've found is to close Steam and then launch the SDK independently, which doesn't seem to work for me. I've also tried launching the SDK whilst Steam is in Offline mode, launching whilst the in-game Steam Community is disabled, verifying the integrity of the tool cache, even un- and reinstalling the SDK.

And for some reason whenever I try to open World Builder now Steam jumps to the Store page, whereas it was previously on the Library page. :/

Any help regarding this issue would be great. :)
Oh, and I'm on Windows 7 64-bit, if that's any help. :)
Oh! I just found a solution on the 2K forums - it suggested closing Steam *through the Task Manager* then going to the World Builder application file (not the SDK's file) and opening it from there. I tried this and the World Builder took a while to load, but it didn't stop responding and it has now loaded!

Some of the people on the 2K forum said that it only worked after they tried it a few times, so it might be an intermittent or unreliable fix.
Originally posted by L'Empereur:
Oh! I just found a solution on the 2K forums - it suggested closing Steam *through the Task Manager* then going to the World Builder application file (not the SDK's file) and opening it from there. I tried this and the World Builder took a while to load, but it didn't stop responding and it has now loaded!

Some of the people on the 2K forum said that it only worked after they tried it a few times, so it might be an intermittent or unreliable fix.

Will try.
It DID work but I really hope it will be fixed ... Thanks.
< >
Showing 1-7 of 7 comments
Per page: 15 30 50

Date Posted: Feb 27, 2013 @ 12:14pm
Posts: 7