kj_links Jan 6, 2013 @ 2:37pm
Civ gameplay is moving very slow, please help?
after i begin a game its either its moving slow or freezes
Showing 1-12 of 12 comments
< >
frozengoods241 Jan 6, 2013 @ 2:55pm 
i'm having the same problem
SuperDuper Jan 8, 2013 @ 7:01am 
Same here! and I have re-installed it and ran it on the least demanding graphics options.
Espresso Jan 8, 2013 @ 9:23am 
First, make sure your computer meets the requirements. This game is surprisingly demanding on computers, and you need a good system to run it. Make sure your operating system and drivers are up to date, because that will affect performance.
kj_links Jan 8, 2013 @ 11:02am 
thanks for the support guys, the problem has been fix. first my computer was running on power saver which is intel graphics HD card on my computer, I had to change it to HP recommended which is ATI Mobility Radeon Premium Graphics Direct x 11. Also my cpu is running on 6gb of memory, it is working wonderful now. Hope this can help
gregg.t.robertson Jan 8, 2013 @ 1:56pm 
I purchased Civ V about two weeks ago, and it worked fine (although a bit slow) on my machine until I got G & K. Now it is virtually unplayable. Very slow and hangs at almost any action I try. I've read all the issues and recommendations from Firaxis and other players, and none of them do any good. All my drivers are up to date, and my machine exceeds the game requirements. I'm very disappointed in the game. Until Firaxis fixes the issues, I'll probably go back to Civ IV.
smal Jan 8, 2013 @ 4:50pm 
make sure game threading is set to 0 in config.ini
EnableGameCoreThreading = 0
SuperDuper Jan 9, 2013 @ 9:46am 
Originally posted by smal:
make sure game threading is set to 0 in config.ini
EnableGameCoreThreading = 0
Did this but it didn't help.
I have a new computer i5, 6gb ram, and the game worked superbly about a month ago - haven't played since. Now it just is painfully slow even with all graph options at their lowest. Even the first turn takes for ages and I even get (never seen this before) info at bottom of screen say 'player x taking making their turn' and 'city state taking their turn'.
Something must be way of with an update or a computer update on my part as it seems like Civ is moving in slower than slowmotion.
kj_links Jan 9, 2013 @ 6:24pm 
have you downloaded any of the mod, some causes the game to move ackward
SuperDuper Jan 10, 2013 @ 8:53am 
I have not.
I think I figured it out. A few weeks back I dropped my computer on the floor and I think I broke the graphics card(/chip) as I cannot find it in the device manager. It displays a generic Microsoft one and that's why the graphics will run soo slow. Thanks for all your help though. I am off to buy a new computer as I cannot seem to find a Geoforce GT 630M (M is the key) anywhere. This is how much I love playing Civ5 when I can find the time.
kj_links Jan 10, 2013 @ 10:01am 
I'm glad to c that u have gotten the problem fixed. Civ 5 baby
gregg.t.robertson Jan 15, 2013 @ 2:53am 
I changed the game threading to 0 and it is now playable but still very slow.
Ditters von Dittersdorf Nov 20, 2013 @ 3:21pm 
i have the last version and using an APU8 8gbRAM and the turns skip is very slow: from 30 seconds to 1 minute, in standard map post modern and atomic ages.
so slow what could never end a game without getting bored!
please firaxis fix the slow turns!!! my pc has 4 cores and uses only 1 for the game!
Showing 1-12 of 12 comments
< >
Per page: 15 30 50
Date Posted: Jan 6, 2013 @ 2:37pm
Posts: 12