playingwithdust Dec 6, 2012 @ 10:04am
Downloaded Civ 5 - and won't start...
Hi there - just downloaded a copy of Civ 5, and it refuses to start using both DirectX 9 and 11 on a machine running Windows 7, 6GB of RAM.

Any help/advice would be greatly appreciated...
Showing 1-15 of 40 comments
< >
Satoru Dec 6, 2012 @ 10:06am 
Try running steam as an administrator. When you say it doesn't start what happens once you click to launch either the dx9 or dx11 executable
playingwithdust Dec 6, 2012 @ 11:12am 
I get the menu to start it either in dx9 or 11 - and then precisely nothing happens.
samuellee29 Apr 14, 2013 @ 9:42pm 
I am having the exact same problem, and running steam as an admin did not help.
The trouble shooting guide just has like a hundred things to try, but that is not very helpful.
If I had known I would not be able to play the game and would be out $50 bucks I would not have bought it.
The game will show up in Task manager, but will be "not responding" all I have seen of it is the black screen. This seems strange, since the demo I downloaded from steam worked fine.

This issue seems to be happening to a large number of people, so any help anyone can give will be appreciated. I also have a "question" in with steam support about it.
Thanks.
BDK Apr 14, 2013 @ 10:01pm 
1) Delete everything in the assets\terrain\pieces\ folder
2) Open the Steam library and verify files for Civ 5
3) When it tells you that it's done, start Civ 5 again

It should work now.
Last edited by BDK; Apr 14, 2013 @ 10:01pm
JustJeff722 Apr 14, 2013 @ 10:05pm 
I am having a problem with Civ5 also. When I run in 9 it doesn't work after the first turn. When I run in 11 it says not responding every time. Can anyone help with this? I did make sure I have a good updated copy of directx on my pc. Thanks
Last edited by JustJeff722; Apr 14, 2013 @ 10:07pm
samuellee29 Apr 14, 2013 @ 10:43pm 
Thank you TheBDK, for your quick response. I tried doing what you said, but nothing changed. After verifying the files it just downloaded them again.

I've restarted, tried safe modes, tried running it as admin, and still all I get to is a blank black screen. I'm trying not to let it ruin my day, but its hard when I know I will be spending many more hours trying to fix it so I can play.
Ragan Apr 15, 2013 @ 5:22am 
Do you have the newest video drivers?
JustJeff722 Apr 15, 2013 @ 11:31pm 
Yes if you are talking to me.
Satoru Apr 15, 2013 @ 11:33pm 
Post a full dxdiag.
JustJeff722 Apr 16, 2013 @ 12:00pm 
How do I do that?
Satoru Apr 16, 2013 @ 12:43pm 
In steam go to Help->System information

Post EVERYTHIGN up to the "Intalled Software" section
Last edited by Satoru; Apr 16, 2013 @ 12:43pm
samuellee29 Apr 16, 2013 @ 6:10pm 
Here is my dxdiag. Thanks for the help.

Processor Information:
Vendor: GenuineIntel
Speed: 1795 Mhz
2 logical processors
2 physical processors
HyperThreading: Unsupported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Unsupported
SSE41: Unsupported
SSE42: Unsupported

Network Information:
Network Speed:

Operating System Version:
Windows Vista (32 bit)
NTFS: Supported
Crypto Provider Codes: Supported 311 0x0 0x0 0x0

Video Card:
Driver: NVIDIA GeForce 8400GS

DirectX Driver Name: nvd3dum.dll
Driver Version: 9.18.13.1106
DirectX Driver Version: 9.18.13.1106
Driver Date: 26 Feb 2013
Desktop Color Depth: 32 bits per pixel
Monitor Refresh Rate: 59 Hz
DirectX Card: NVIDIA GeForce 8400GS
VendorID: 0x10de
DeviceID: 0x10c3
Number of Monitors: 1
Number of Logical Video Cards: 1
No SLI or Crossfire Detected
Primary Display Resolution: 1680 x 1050
Desktop Resolution: 1680 x 1050
Primary Display Size: 23.35" x 14.57" (27.48" diag)
59.3cm x 37.0cm (69.8cm diag)
Primary Bus Type Not Detected
Primary VRAM: 1024 MB
Supported MSAA Modes Not Detected

Sound card:
Audio device: Speakers (Realtek High Definiti

Memory:
RAM: 3324 Mb

Miscellaneous:
UI Language: English
Microphone: Not set
Media Type: DVD
Total Hard Disk Space Available: 152625 Mb
Largest Free Hard Disk Block: 5260 Mb
OS Install Date: Sep 01 2007
Game Controller: None detected
Satoru Apr 16, 2013 @ 7:16pm 
Are you absolutely postively fully patched on Vista. This is a very common issue because for some reaons Vista users have some incredible aversion to service packs.
Ragan Apr 17, 2013 @ 12:51am 
That computer is below the system requirements. For some reason it isn't saying what the processor is, but it's 1.8 GHz. As it's an Intel, you will need to have a Core 2 Duo or better.

Your graphics card (GeForce 8400) isn't strong enough, and your RAM is barely enough.
samuellee29 Apr 17, 2013 @ 2:40am 
Hey thanks for the advice guys, I finally fixed it by rolling back my video driver to before my last windows update. After hours of tinkering with it I thought of that, lol. I finally got to play!
thanks
Showing 1-15 of 40 comments
< >
Per page: 15 30 50
Date Posted: Dec 6, 2012 @ 10:04am
Posts: 40