Sid Meier's Civilization V

Sid Meier's Civilization V

View Stats:
neowiz73 Jun 12, 2014 @ 1:49pm
Getting Mods to work on Linux
if you want mods to work...
first, find a file named "mainmenu.lua" located in ~/.local/share/Steam/SteamApps/common/Sid Meier's Civilizaiton V/steamassets/assets/ui/frontend
edit with with your text editor of choice.
locate a string "Controls.ModsButton:SetHide( true ); -- MAC_PORT - rickb Comment this line out to re-enable mods. Happy modding!"

simply comment this with 2 dashes -- Controls.ModsButton:SetHide( true ); -- MAC_PORT - rickb Comment this line out to re-enable mods. Happy modding!

Save the file and restart Civ5. this will enable Mods to be used. Be sure to select Options from the DLC window and check the box to show DLC Mods.
I have my own mods loaded from when I used Windows. They all work great. I do not use the workshop for mods, Your mileage may vary.


Hopefully this will help anyone that wish to try out some mods on their new Linux install of Civ5.
Last edited by neowiz73; Jun 12, 2014 @ 1:55pm
< >
Showing 1-15 of 31 comments
Petete Jun 12, 2014 @ 2:43pm 
I did that but it doesn't see my mods. :(
SamBC Jun 12, 2014 @ 2:44pm 
Have you put the mods in the relevant folder?
neowiz73 Jun 12, 2014 @ 3:28pm 
I put my mod in the MODS folder in ~/.local/share/Aspyr/Sid Meier's Civilization 5/MODS
I figured the game would autodownload mods from steam once selected in the MODS window. this is all experiemental, i've seen certain incompatibilities so far. some mods may need fixes to work with Linux fully.
Last edited by neowiz73; Jun 12, 2014 @ 3:29pm
SamBC Jun 12, 2014 @ 4:05pm 
It won't download stuff from Workshop because they haven't put workshop support in the Mac or Linux versions. You have to get the mods some other way and put them in place manually.
Petete Jun 13, 2014 @ 4:28pm 
I couldn't find the correct folder because I had a ~/My Games/etc folder from wine's installation of CivV and that confused me. Now I found the correct folder and a way to improve the compatibility of the mods. You need to install ciopfs, a case insensitive fs for linux.

Basically you have to do:
sudo apt-get install ciopfs
cd ~/.local/share/Aspyr/Sid Meier's\ Civilization\ 5
mkdir .MODS
rm -r MODS/*
ciopfs .MODS MODS

You can install some mods now and test.
Later you can add this line to /etc/fstab so it will mount at boot, remember to change "myuser" to your actual username:

/home/myuser/.local/share/Aspyr/Sid\040Meier's\040Civilization\0405/.MODS /home/myuser/.local/share/Aspyr/Sid\040Meier's\040Civilization\0405/MODS ciopfs allow_other,default_permissions,use_ino,attr_timeout=0 0 0

edit: Just added the "-r" to the instructions. You have to make sure that the MODS folder is empty before using it as a mount point.
edit2: fixed fstab, need to use \040 instead of spaces
Last edited by Petete; Jun 16, 2014 @ 6:23am
mordbrenner Jun 14, 2014 @ 2:11pm 
Originally posted by Petete:
You need to install ciopfs, a case insensitive fs for linux.

Thank you very much. Now I can use some mods I havent been able to before.

so to sum up the steps to get mods running under linux:
1. activate the Mod button, see first post by neowiz73
2. install ciopfs and activate it. See post 5 by Petete
3. download a mod and extract the archive to ~/.local/share/Aspyr/Sid Meier's Civilization 5/MODS
4. start game and chose the mod.

I have been able to run the lord of the rings scenario:
http://steamcommunity.com/sharedfiles/filedetails/?id=174781830

Petete Jun 15, 2014 @ 8:33am 
If you are a mac user this should be useful to you too. ciopfs is a FUSE fs so you can use it with macFUSE. But don't ask me how to install/compile it because I don't have a mac :)
lazypunk09 Jul 3, 2014 @ 4:51am 
After making MODS button appear, everything became unclickable. Also, version says "invalid" and "touch controls guide" appeared on the right bottom end of the screen. Anyone else has these issues?
neowiz73 Jul 3, 2014 @ 5:12am 
Originally posted by lazypunk09:
After making MODS button appear, everything became unclickable. Also, version says "invalid" and "touch controls guide" appeared on the right bottom end of the screen. Anyone else has these issues?

I would double check to make sure you commented out the correct line in mainmenu.lua. maybe reverse what may have been commented out, if nothing else, you can have the game cache checked via steam (select game in steam, and right click to options, select properties then local files tab), which will fix altered files to it's original state.

I don't use the mod notated later in the post. they work fine as-is. there is supposed to be an update soon that will enable the mods officially.
Last edited by neowiz73; Jul 3, 2014 @ 5:14am
lazypunk09 Jul 3, 2014 @ 5:14am 
Screenshot of what it looks like :
http://www.zimagez.com/zimage/screenshot-03072014-141259.php

Everything is unclickable, alt+f4 works..
Last edited by lazypunk09; Jul 3, 2014 @ 5:14am
Right now mods tend to cause problems with the user interface. Most likely because the mod wants to load some assets and can't find them because linux is case sensitive and the modder didn't have that in mind.

Best bet is probably to wait for the game to support workshop, and then for the modder to update his mod
neowiz73 Jul 3, 2014 @ 12:18pm 
most of the scenerio and map mods i've tried work, if it's a mod that changes/adds graphics and/or ui elements you will most likely have some issues getting it to work correctly under linux.
Last edited by neowiz73; Jul 3, 2014 @ 12:20pm
ghona76 Jul 5, 2014 @ 11:10pm 
I've been able to get Mods working pretty easily using the above instructions. But TSL on maps is not at all accurate I find. Brazil is forced to start it's first city in the far north of a Huge Earth map, just below the ice for example....
Last edited by ghona76; Jul 5, 2014 @ 11:11pm
King Buzzo Jul 6, 2014 @ 12:11am 
I play this primarily on Mac, but out of interest I've tried loading some mods via this method. Simple mods for additional civs, buildings, etc seem to work fine. I'm not much into scenarios so I can't speak about those.

Communitas is incompatible unfortunately. It makes the top bar of the UI disappear. I've tried reducing it down to just AI & Tools, but same result. Sad because that is, collectively, the most meaningful modpack available IMO.

IGE also loads & runs fine, if you're into that sort of thing... if you're one of THOSE people... :)
SamBC Jul 6, 2014 @ 4:13am 
Originally posted by ghona76:
I've been able to get Mods working pretty easily using the above instructions. But TSL on maps is not at all accurate I find. Brazil is forced to start it's first city in the far north of a Huge Earth map, just below the ice for example....
When playing a TSL map, you have to make sure you select the "load as scenario" checkbox. That might not be the exact label on it, but it's something like that.
< >
Showing 1-15 of 31 comments
Per page: 15 30 50

Date Posted: Jun 12, 2014 @ 1:49pm
Posts: 31