Freedom Force

Freedom Force

username03 Jan 14, 2014 @ 11:09pm
Fist Curser Bug and Movement Issue Fixed

Hey guys installed this game today and saw that there was no fix for the fist icon and running off the map crap. The only way this worked for me was because some old thread had mentioned a bunch of different fixes. It has nothing to do with composition mode, admin mode, etc. They worked for me sometimes and sometimes they didn't. So I noticed the reason why the bug happens is because if the game starts your mouse pointer at an area where you can attack something, then it will become the fist curser for the rest of the game until you exit out of the game(the whole fforce.exe). If you get the correct curser, it will also stay like that until you quit the whole game/application.

When you click new game, notice that your pointer is sitting on a bench which is something you can attack. If your curser is sitting on anything that can be attacked when you start or load a new game, it will turn into a fist until you exit the application and restart it.

Anyway so to fix this:

Note Addition: You have to have your video on 16bit in the game not 32bit. So any resolution with X16 after it in the video settings.

1.Try to click on one of the corner of the New Game button and don't move the mouse after that.You can skip the movie with esc.

2.If it worked then that corner should work for your resolution fine. If not then quit the whole game(not just quit campaign) and restart the game try another corner until it works.

3.Basically, you don't want your curser over anything attackable when you load a game or start a new game. You can even move the mouse during the movie and press esc see if you can land on something not attacktable.

4.If you still can't find a corner or move your mouse during the movie to a safe area, then a 100% way of doing it is start a new game. Walk to the top area so that your lower left area(this is where your load button is) is free of attackable things and save. Then quit the game. Restart the game and load the game. Your mouse should be in a the grass area where nothing is attacktable. After you get the normal curser all your load games should be fine until you quit the game again.

Side note: Resetting the video settings makes my sound turn off in the game. You have to just turn it back on.
Last edited by username03; Jan 22, 2014 @ 4:55pm
< >
Showing 1-15 of 16 comments
K Jaggens VII Jan 15, 2014 @ 1:01pm 
This fix actually makes sense, unlike others. Also explains why my original boxed version (non-steam, not patched to latest version) has same issue. But why does this happen now?
username03 Jan 15, 2014 @ 4:58pm 
By now what do you mean. I don't think the bug was ever fixed by the developers.
K Jaggens VII Jan 15, 2014 @ 6:46pm 
Originally posted by username03:
By now what do you mean. I don't think the bug was ever fixed by the developers.
By "now" I mean "at this point in time".

See, I had this game for a very long time, before even steam client were first revealed. Actually, my copy states that minimal reqs are "Windows 95/98/Me", so it was released before XP came. Bug persist through every version, I've checked my non-patched game, which is essentially an original - cursor issue appears there.

I've played it with XP, and it was absolutely fine. I've played this game when 98 was the thing - same, never this bug occured. It occurs on every version, but never happened like 5 years ago. Why now? What changed with Vista and 7, that triggers this bug? It may also explain why developers never fixed it: it's an issue that never occured with OS and hardware of that time.

username03 Jan 15, 2014 @ 8:08pm 
I have no clue. I have heard some say it is an issue with newer graphics drivers(nvidia and amd). Or it could be a OS issue. I don't think anyone has looked into the issue because it's an old game. Same problem with Breath of Fire IV for PC the newer graphics drivers make it so you can't play the game.
gamerfieldy Feb 12, 2014 @ 8:31pm 
It works great for me in vista and in windows 7
To fix the fist icon bug do the following:
All you have to do, is find the FF.exe file in the game folder and
right click it, go to properties, compatibility tab,
1. check the box that says
"run in compatability mode" , in the pull down menu select "Win98/ME"
2. check to box to disable visual desktop
3. check to box to disable desktop composition
4. click the OK button
5. Now right click on the STEAM shortcut on your desktop that launches STEAM (not the game shortcut.
6. right click it, go to properties, compatibility tab.
7. check the box that says
"run in compatability mode" , in the pull down menu select "XP service pack 3".
8. click the OK button
step 9.
*IMPORTANT*. EXIT steam, make sure you right click close steam thats is still running on your system tray or the changes won't take affect.
Now when you launch steam it will be in xp compatibilty mode, which will allow you to launch freedom force in win 98/ME mode to play the game without the fist bug on newer video cards / newer OSes.

.......Your welcome ;)
Excuses Jun 14, 2014 @ 6:13am 
Pressing the upper left corner of the 'New campaign' button allows me to play normally.
It works with 32bit resolutions, too. Specifically 1920x1080x32.

I've been playing the game since it released and I just experienced this bug for the first time on my new PC running Windows 8.1 Update 1.
Oceanus Jul 18, 2014 @ 7:49am 
I'm finding this game unplayable, too. However, where do I find the ff.exe.file?
Krounoz Aug 7, 2014 @ 8:35pm 
In case you're still wondering how to access the FF.exe files;
I. head to your game library
II. right click on the game and click "properties"
III. there should be a tab that says "Local Files" click it an then click on "browse local files" and it should send you to the games files and it should be the fforce application.
Last edited by Krounoz; Aug 7, 2014 @ 8:39pm
smoken Aug 28, 2014 @ 7:18am 
Tried moving to an attackable free area, did not work. Tried running in compatibility in earlier versions of windows, still no sucsess. Turn down resolution, nothing. Tried all three. Stuck tounge out. Can not get game to run properly.

Tried FF 3rd Riech, fine during the two minutes I tested it.
CROM Nov 17, 2014 @ 10:05am 
I've been on a retro gaming kick lately, and I must say I'm pretty disappointed that this game really doesn't work reliably in Windows 7. I've also tried all of the above listed tips here, and managed to get it to work once. However on saving and starting the game the next day, the mouse issue was back in full force. What I ended up doing, to avoid this with future games, was set up a VM of Windows XP using Virtual Box. With some tinkering this finally did the trick. The game now runs great at 1080p, and the cursor/mouse bug is gone. If you plan on playing other older games, for me up next is Diablo 2, this is probably the best way to go.
Santiago Jun 27, 2016 @ 3:39pm 
Exiting the Logitech software for my mouse seems to have fixed the fist cursor when nothing else would work.
Last edited by Santiago; Jun 27, 2016 @ 3:39pm
1800-CAPITALISM Aug 4, 2016 @ 1:24am 
Thanks, with a bit of fiddling, this worked. Good to see help on such an old and unpopular game.
Andrigaar Sep 7, 2016 @ 9:26pm 
Used compatibility for 98/ME and finished the tutorial mission with no problems. Then I clicked "next" and the bug came back and bugged out my end-mission save so I can't do anything in that save file anymore. Even if I restart the game and load the file, "next briefing" isn't clickable.

Oh well.
CollectiveS Sep 12, 2016 @ 10:10am 
Just thought I'd add what worked for me as I've seen it elsewhere. Having no trouble afterwards running it on 32 or 16 bit resolutions all the way up to 1920x1080, all I did was change the compatibility mode to 98/ME and verified the game files. It had to replace 8 files and the problem went away, so if you still have problems try verifying the files.
None of the other fixes worked for me, but this was dead simple. I just push my mouse to the upper left after clicking to start the game, cursor works correctly afterwards. Running in Windows 10.

< >
Showing 1-15 of 16 comments
Per page: 15 30 50