Zombien Feb 8 @ 8:42am
NOT working in Windows 7 64 bit...
Hello There

I have read alot of post, some get this game to work in windows 7 and some aren't...
well i am one of the persons who aren't able to get the game working in windows 7 64 bit...

i have tried to make it run in compatible mode "Windows XP" and "Windows 98"
even run as and administrator...

the game launch, but the screen is black and the computer freeze :(
i have made the setting and force the game using the Nividia instead of the Intel card...

so please tell me, how the hell do you get it working on Windows 7 ?
Showing 1-3 of 3 comments
< >
gamerfieldy Feb 12 @ 8:28pm 
It works great for me in vista and in windows 7
To fix the fist icon bug do the following:
All you have to do, is find the FF.exe file in the game folder and
right click it, go to properties, compatibility tab,
1. check the box that says
"run in compatability mode" , in the pull down menu select "Win98/ME"
2. check to box to disable visual desktop
3. check to box to disable desktop composition
4. click the OK button
5. Now right click on the STEAM shortcut on your desktop that launches STEAM (not the game shortcut.
6. right click it, go to properties, compatibility tab.
7. check the box that says
"run in compatability mode" , in the pull down menu select "XP service pack 3".
8. click the OK button
step 9.
*IMPORTANT*. EXIT steam, make sure you right click close steam thats is still running on your system tray or the changes won't take affect.
Now when you launch steam it will be in xp compatibilty mode, which will allow you to launch freedom force in win 98/ME mode to play the game without the fist bug on newer video cards / newer OSes.


.......Your welcome ;)
chelommy Mar 2 @ 8:38pm 
works fine for me on windows 7 64 bit with an integrated intel chip
Zombien Mar 6 @ 6:03am 
Well it works after i've installed the expansion for the game :/ but the original game without the expansion installed aren't
Showing 1-3 of 3 comments
< >
Per page: 15 30 50