Sid Meier's Civilization IV: Beyond the Sword
Helios Jun 5, 2013 @ 2:06am
CIV IV Expanson packs silently fail to load
When I try to load CIV IV: Beyond the sword it just does nothing.
Anyone have any idea how to fix it?
Thanks.
Showing 1-10 of 10 comments
< >
Captain Barbeard Jul 12, 2013 @ 1:07pm 
Me too, I've had this game for over a year and nothing happens. It says I'm playing the game on steam for a second, then nothing. I've hunted all over the internet and nobody says anything about this.
Sitcomedy [Dr. Triangle] Jul 13, 2013 @ 7:19pm 
Huh. That really stinks. is there any similarity between your operating systems?
-qp- <TOODIRK> Aug 7, 2013 @ 6:52pm 
Same thing is happening to me. Just started silently not loading about 5-7 days ago. No error messages, no signal that anything is happening, just fails to load.

I have already uninstalled and reinstalled with no change. Also verified game cache and it said 11 files were bad and reloaded those files with no change. Running out of options here.
-qp- <TOODIRK> Aug 7, 2013 @ 6:54pm 
Civ 4 Vanilla loads just fine though. I just noticed Warlords wasn't installed. Currently installing it to see if that is causing the problem with BtS not loading. I will post the results when it is ready.
Onebadterran Aug 7, 2013 @ 9:01pm 
That is an odd error. Let me know if installing Warlords solves the problem (I think it will)
Captain Barbeard Aug 8, 2013 @ 10:34am 
I already have Warlords installed, and that works while BTS doesn't. I honestly have no clue.
-qp- <TOODIRK> Aug 8, 2013 @ 2:34pm 
Installed Warlords....nothing. I deleted all Civ 4 content and reloaded and still the same result. Guess I will try deleting the .blob file in the Steam file and see if that fixes it. Getting quite frustrated though, finally got an itch to play Civ 4 again and simply cannot now.
_LUX_ Sep 1, 2013 @ 2:07am 
it happened to me but i just left it for a day or so and they worked :D
-qp- <TOODIRK> Sep 5, 2013 @ 6:37am 
Still no luck for me....I have 3000 hours logged and can't play. Granted most of those hours are from leaving a game on overnight, but still have played this ♥♥♥♥ a ton and now it won't load. Seems like it just starts for half a second then closed, the steam pop up that comes up after you exit games pops up after I attempt to start Civ 4 and nothing happens.
Helios Sep 5, 2013 @ 11:27am 
Manged to solve the problem by installing something called creative alchemy.
I found this out via even viewer in windows 7.
If you have windows vista or later it might be worth it to check out the event viewer.
Thankyou for the replies.
Showing 1-10 of 10 comments
< >
Per page: 15 30 50