Sid Meier's Civilization IV: Beyond the Sword
vladimir.tchouchkov Jan 29, 2013 @ 9:08am
How to get a MOD working with Steam BTS 3.19
Once you unzip (unrar,decompress,extract) the MOD
Open its main folder and get to the root folder of the MOD
Inside of it you will see <<public maps>> and <<assets>>
Place the folder MOD (name) containing those files in your

\Program Files (x86)\Steam\steamapps\common\Sid Meier's Civilization IV Beyond the Sword\Beyond the Sword\Mods\<<ExampleModFolder<<

Start the game

If you did everything right you should have (before you do anything) an ADVANCED option in the first main menu
Select that ADVANCED option and then select load <<ExampleModName<<
You should be able to load the MOD

Once you load the mod then select a MAP «««« either default maps or a dedicated scenario map for the MOD

Alternatively you can just load the scenario MAP for the MOD from your single player scenarios BTS 3.19 menu.
Provided that you placed the MOD in the right location and that it comes with a dedicated MAP.
It should load the MAP`s (WorldBuilderSave= .WBS) respective MOD automatically.
Showing 1-2 of 2 comments
< >
B.Snow Oct 23, 2013 @ 12:16pm 
Quote: "If you did everything right..."

And, If I didn't ? (=Didn't do everything right??)

Or, If I did something really "wrong" - like I tried a simple edit to the GlobalDefines.xml to turn off the blasted Global Warming = which just gets totally *redonkculous*?? via Notepad but not Notepad++ (I'm on an old PC with XP/SP3) which according to some folks seems to matter.

I tried undoing the change turning '20' into '0' at first, then changing it back, and then I started digging into all the mod forums & it appears to be REALLY EASY to "bork a file"! Any file it seems... editing & saving it with the version of Notepad or (Wordpad?) that comes with XP = is a possible culprit according to the pages upon pages of threads I've read through related to similar problems, AND all sorts of Mods & Modding.

I've tried the Civfanantics forums and it seems like it was the the filepaths (I searched for the shortcut to CustomAssetts.xml & got the wrong one I think, they're quite diffferent with this Steam Install, SO = I've messed it up, -somehow- I can't figure out which of a half dozen things it could've been.

IF I could figure out how to get the darn game re-installed properly & ideally my Save Game files = I copied the whole folder to another out of the way folder - & whatever other files I might want for the hours played, etc?

THEN, I might be able to propely load in a MOD like "Rise of Mankind" or something... But, I can't get the game to start at all right now, and I'd rather not resort to a 'scorched earth' type of method = I might take out a Key or a registry Entry or something I'd like to keep.

I've tried verifying files deleting the local files (that weern't read only - so some folders may have stayed ?) un-istallling & re-installing, I did the steam://flushconfig thing - Not 100% sure I dId any of it "the right way" though - and it seems to be picky as heck = HELP!
Last edited by B.Snow; Oct 23, 2013 @ 1:03pm
ゼーン Sitcomedy ゼーン Dec 12, 2013 @ 1:16pm 
Inside the main MOD folder, in the same location as ASSETS and PUBLIC MAPS, there are extra folders, such as INFO, RESOURCE, SETTINGS, and SOUNDS. I tried installing this mod the usual way, but the mod does not appear in the "advanced--->load a mod--->" when I attempt to play.
Last edited by ゼーン Sitcomedy ゼーン; Dec 12, 2013 @ 1:16pm
Showing 1-2 of 2 comments
< >
Per page: 15 30 50