Sid Meier's Civilization IV: Beyond the Sword

Sid Meier's Civilization IV: Beyond the Sword

BoomShackalakalaka Apr 24, 2014 @ 8:21pm
XML TXT_KEY not found errors on Civ IV: BTS
So I finally decided to get back into Civ on a new computer, and having a very frustrating time, as the XML is not working properly. I searched online and found it might be related to Windows 7 64 bit compatibilty, but didn't find a single solution posted. Probably related, but when steam checks the validity of the cache, it states "11 files failed to load and will be reacquired", but then it never reaquires them! Doesn't seem to matter how many times I try.

Specifically the errors seem to have to do with German and Spanish language XML files, but they clearly ruin the experience for me in English as well.

Any suggestions would be greatly appreciated!

< >
Showing 1-11 of 11 comments
wudi Jul 12, 2014 @ 10:11pm 
I have the same problem.
BoomShackalakalaka Aug 3, 2014 @ 3:07am 
Bump for visibility I suppose. I've looked through the civfanatics forums without success, also tried with a 2nd copy I bought on amazon which I downloaded to my other luck so far!
pepoluan Aug 17, 2014 @ 5:06am 
Did you install Steam (or the standalone copy) under C:\Program Files?
wudi Aug 17, 2014 @ 5:07am 
no, not in C:, is that the cause?
Originally posted by pepoluan:
Did you install Steam (or the standalone copy) under C:\Program Files?
BoomShackalakalaka Aug 19, 2014 @ 7:06am 
Hi Wudi, I definitely don't think that's the cause. I've heard about other issues with Windows 7 64 bit and installing anywhere other than C drive, but I don't think it applies to this issue. I have my steam copy assigned to the D drive, and the amazon copy installed to C:\Program Files (x86)\2K Games. If reinstaling to C drive works for you let me know, as I've heard it resolves this issue for some users
BoomShackalakalaka Aug 19, 2014 @ 7:07am 
I really want to play Civ 4 again it's my favourite strategy game ;(
doeddi Mar 23 @ 12:10pm 
It seems that changing your PC language Settings to "English (United States)", would fix the problem.

At least fixed the problem for me.
Nappytime Mar 23 @ 4:23pm 
I am also having this problem and my system language has not affected the issue. I do not fail to validate any files if I try, but I still get XML errors and the names of many items in the Civpedia are showing up as XML titles.
H. [] Mar 24 @ 1:14am 
Could you try to revert to the old patch using this trick (read the note for Steam users):
Nappytime Mar 24 @ 6:46am 
I've already done so. I previously had the game working on this PC so I believe an update may have created this issue. I also have the game downloaded on my old computer so maybe it will work if I get the missing files from there. I thank you for your help but this seems to be an odd issue that I don't know anyone would be able to help me solve so no need to waste your time further.
H. [] Mar 25 @ 1:09am 
You may try our mod which contains the original game strings. That means if something is missing in the original game, it might still launch OK with the mod. It's like a new expansion pack ;)
It is also 70% in Japanese as of today.
Last edited by H. []; Mar 25 @ 1:10am
< >
Showing 1-11 of 11 comments
Per page: 15 30 50