Sid Meier's Civilization IV: Beyond the Sword
suolitomppa Jul 22, 2014 @ 7:36am
Civ IV won't launch in Steam - error 51
I just installed civ4 complete on my 2 different laptops. with the older one everything went smoothly, but with the newer one (wit win 8.1) none of the games will launch. it just says that failed to launch and gives error code 51. Can anyone help?
Showing 1-6 of 6 comments
< >
suolitomppa Jul 22, 2014 @ 7:39am 
And to be noticed that before it worked just fine with win 8.1 but that was with older version that i had installed from the original disc
suolitomppa Jul 22, 2014 @ 10:12am 
I also tried to play some free game via steam and that worked alright. this means that the problem is in steams version of civ and win 8? right?
Myu Jul 28, 2014 @ 7:35am 
Try running it in a different commbatibility mode. I'm having issues with the game right now too though. Won't work unless I uninstall then reinstall.
suolitomppa Jul 28, 2014 @ 8:53am 
Myu, how can i change the combatibility mode?
Myu Jul 28, 2014 @ 9:46am 
I'm not sure how to do it on Windows 8, but what should work is if you make a short cut from steam onto your desktop, right click it and open file location. Find the "Civ4BeyondSword" application, right click that then go to properties. Compatibility, run this program in compatibility mode for: Then try Windows 7 or Windows XP Service Pack 3
suolitomppa Jul 31, 2014 @ 12:12pm 
So the problem was with F-secure and it's aplication called "deep guard" which messed steam up. After i turned deep guard off everything started to work
Showing 1-6 of 6 comments
< >
Per page: 15 30 50