Fletch Mar 24, 2013 @ 3:02am
Microstutter or lag
hi,

Love this game, played it alot, both on xbox and PC after I sold my xbox (my record is 4M)

I'm having trouble running the game smoothly on PC, it microstutters and/or lags when things get busy although it stays constantly at 120fps and gpu is only at around 30% load. I've tried various v-sync settings and different settings in game, makes no difference if game is at 640x480 or 1920x1080

anyone else experience this ?

my pc:
Intel i7-3930k @ 4.7GHz * Nvidia GTX 680 (1.25GHz/6.6GHz) * MSi X79A-GD65 (8D) * 32GB DDR3 G.Skill RipJaws * SSD's & HDD's * Asus Xonar Essence STX
CPU&VGA Watercooled * CoolerMaster HAF-932 * Corsair AX 1200W * 27" Asus VG278H 3D 120Hz * Windows 8 Pro x64
Showing 1-10 of 10 comments
< >
Magnus | ertesda Mar 24, 2013 @ 3:36am 
I never had this problem before...Maybe you need to update your graphics driver?
Fletch Mar 24, 2013 @ 3:39pm 
im running 314.07 now, no matter what driver I try it always micro stutters..... (none issue in other games)
Magnus | ertesda Mar 25, 2013 @ 5:13am 
Hmm...that´s odd.What about DirectX? I never used Win8,but what about compatibility-mode?
0mnicydle Apr 6, 2013 @ 12:08pm 
Forcing vsync in my graphics driver (nvidia) fixed this problem for me.
AxeMan Apr 22, 2013 @ 11:28am 
Same problem on my gaming rig, none on my laptop.
[CotF] KKiONI Apr 5 @ 10:12am 
Bumping this (opposed to making a new thread).

I've been getting this problem on my laptop as well and it is really peculiar. This game seems to be a bit of an oddity when it comes to performance. No matter what setting I fool around with, whether it'd be in game or my GPU control panel, I seem to get stutters in game.

Weirdest part is the framerate doesn't seem to decrease at all during these moments. Fraps reports a rock solid 60 frames throughout.

For the sake of documentation, my specs:
Intel i5 3210M
6 GB memory
Nvidia GeForce GT 640M 2GB GDDR3 / Intel HD Graphics 4000
Nvidia Driver: 297.07*

*It's the recommended driver for my laptop and even my own tests show greater performance than newer versions.
Fletch Apr 5 @ 12:39pm 
I've found that turning these things off helps a lot

Hyperthreading
HPET timer (bios)
Speedstep
[CotF] KKiONI Apr 5 @ 1:39pm 
Not sure if the hyperthreading might affect it though since the OP has the problem with his i7. But I'll give the last two a shot and see what happens.
Fletch May 24 @ 4:59pm 
did it work for you?

This is how I get it to run smoothly
bios settings:
HT off
HPET Timer off
Speedstep off

Nvidia driver setting
Adaptive V-Sync
Power Management Mode -> Prefer Maxmum performance

maybe not all of these settings needed but with this its butter smooth

my pc now:
Intel i7-3930k @ 4.7GHz * Nvidia GTX 780 Ti (+250/+380) * MSi X79A-GD65 (8D) * 32GB DDR3 G.Skill RipJaws * SSD's & HDD's * Asus Xonar Essence STX
CPU&VGA Watercooled * CaseLabs T10 * Corsair AX 1200W * 27" Qnix Evolution II * Windows 8.1 Pro x64
[CotF] KKiONI May 24 @ 5:23pm 
Apologies, I completely forgot to update this. I went through it minus the hyperthreading and it was no different. My hardware isn't the most reliable though as I have seen other games perform in other peculiar ways. So I have concluded it's mostly that plus a hint of shoddy port syndrome (won't stop me from playing!).
Showing 1-10 of 10 comments
< >
Per page: 15 30 50