Just Cause 2 > General Discussions > Topic Details
ToxicCola Dec 30, 2012 @ 10:30am
FATAL DirectX ERROR!!!! CODE 3
I just bought the game and i really want to play it but it keeps giving me this error!!!

I Have A Lenovo IdeaPad y580

6gb ram

Intel Core i7

Geforce GTX 660m

All the new beta drivers

Plz Hep I really wnt t play this game!
Showing 1-15 of 58 comments
< >
Billy "Smiles" Evans Dec 30, 2012 @ 10:43am 
AFTER MUCH TROUBLESHOOTING (I have an Asus S56CM Ultrabook with a GT635M using Optimus), I HAVE FOUND A SOLUTION THAT WILL WORK, GUARANTEED.

Here are the steps to said solution.

1. Go to your DESKTOP, right click, hit SCREEN RESOLUTION
2. On the window that appears, press DETECT.
3. Click on one of the new screens that appear, and from the DISPLAY DROPDOWN, select YOUR GRAPHICS CARD
4. Under MULTIPLE DISPLAYS, select TRY TO CONNECT ANYWAYS.
5. SAVE IT UP, HIT APPLY.
6. Click on your brand new SECOND SCEEN.
7. Under MULTIPLE DISPLAYS, select EXTEND THESE DISPLAYS.
8. APPLY, OK.

BOOM, JUST CAUSE 2 WORKS, JUST START IT UP FROM STEAM.
Last edited by Billy "Smiles" Evans; Dec 30, 2012 @ 11:36am
ToxicCola Dec 30, 2012 @ 11:46am 
OMG THANK YOU IT WORKS!!! YOU ARE THE BEST
Billy "Smiles" Evans Dec 30, 2012 @ 11:49am 
Originally posted by CoCoMcFly:
OMG THANK YOU IT WORKS!!! YOU ARE THE BEST
No problem, just glad I could help. I've been trying to figure out something for the last 2 days, and this is what finally worked!
ToxicCola Dec 30, 2012 @ 11:56am 
Originally posted by Billy "Smiles" Evans:
Originally posted by CoCoMcFly:
OMG THANK YOU IT WORKS!!! YOU ARE THE BEST
No problem, just glad I could help. I've been trying to figure out something for the last 2 days, and this is what finally worked!


Is there a way to put it in full screen??
Billy "Smiles" Evans Dec 30, 2012 @ 11:58am 
Originally posted by CoCoMcFly:
Originally posted by Billy "Smiles" Evans:
Originally posted by CoCoMcFly:
OMG THANK YOU IT WORKS!!! YOU ARE THE BEST
No problem, just glad I could help. I've been trying to figure out something for the last 2 days, and this is what finally worked!


Is there a way to put it in full screen??

I'm not too sure what I did, but after messing around with the resolution for a bit, it played in fullscreen while it was in windowed mode.
ToxicCola Dec 30, 2012 @ 12:03pm 
ok, thanks
Billy "Smiles" Evans Dec 30, 2012 @ 12:04pm 
Originally posted by CoCoMcFly:
ok, thanks

Got a solution here. Download the link from the first paragraph here: http://forums.steampowered.com/forums/showthread.php?t=2675769

Run the program. Open Just Cause 2. Right click program icon in tray, press add window. Go to Just Cause 2, press F3. As long as this program is open Just Cause 2 will be fullscreen!
MstrDelusiional Dec 30, 2012 @ 4:08pm 
Did this... I think it worked the first time but then I messed it up by changing the main display and now can't get it to work again... and unfortunately there is no reset to default setting on the page.

All it does now is when I do all of the steps and click apply for the second time, the screen goes black and then comes back as if my computer is now the 2nd screen, and I can't do anything with it until the 15 seconds goes up where you can accept or revert the changes you made... all windows and icons are absent, only my taskbar on the bottom is shown.
Last edited by MstrDelusiional; Dec 30, 2012 @ 4:29pm
ToxicCola Dec 30, 2012 @ 4:55pm 
Originally posted by MstrDelusiional:
Did this... I think it worked the first time but then I messed it up by changing the main display and now can't get it to work again... and unfortunately there is no reset to default setting on the page.

All it does now is when I do all of the steps and click apply for the second time, the screen goes black and then comes back as if my computer is now the 2nd screen, and I can't do anything with it until the 15 seconds goes up where you can accept or revert the changes you made... all windows and icons are absent, only my taskbar on the bottom is shown.

Same For me, but when i plug in my tv to my computer it some reason dosn't switch the main computer screen to the second one.
ToxicCola Dec 30, 2012 @ 5:30pm 
Originally posted by MstrDelusiional:
Did this... I think it worked the first time but then I messed it up by changing the main display and now can't get it to work again... and unfortunately there is no reset to default setting on the page.

All it does now is when I do all of the steps and click apply for the second time, the screen goes black and then comes back as if my computer is now the 2nd screen, and I can't do anything with it until the 15 seconds goes up where you can accept or revert the changes you made... all windows and icons are absent, only my taskbar on the bottom is shown.

I figured out how to fix our problem.

First you make the second screen as usual. Befor you click "extend destop to this display", you check the box on the second screen that says "Make this my main display", then click the "extend destop to this display" and apply.

When your screen switches to the second one, you want to go back into the screen settings and go to the first screen and check the Box That Says "Make this my main display, then hit apply, and everything should be back to normal and you should be able to start Just Cause 2.
MstrDelusiional Dec 31, 2012 @ 1:03am 
Hmmm... I connected it to my tv and did some weird stuff there and got it to work (I think, my laptop isn't plugged in and only uses the GTX 660M when it is plugged in. However, I am able to scroll my mouse off of the right side of the screen as if another screen was still hooked up... I know I enabled a multiple screen feature, but is there any way to disable this? It is rather annoying.
MstrDelusiional Dec 31, 2012 @ 1:44am 
Ok well I got the game working... so there's a step in the right direction. By the way, I'm using a Lenovo Ideapad Y580 with Windows 8 preinstalled (i7 3630 and GTX 660M). I guess the multiple screen thing isn't a huge issue because I can just disable it when I am not playing JC2. But next thing I want to look into is how come you can't click out of the JC2 window when you initially open it without having to completely shut down the program and reopen it? If I click on the taskbar or mess up with the windowed gaming script thing the other guy provided then the screen goes black and then comes back on showing the desktop, and it won't let me open JC2 again until I close out of it and restart it.
dab88 Dec 31, 2012 @ 7:31am 
bolopatch is a hack- it's perfectly safe but don't be surprised that it crashes your game. Alt+Tab works fine when you're not using bolo
Last edited by dab88; Dec 31, 2012 @ 7:31am
ToxicCola Dec 31, 2012 @ 7:41am 
Originally posted by MstrDelusiional:
Ok well I got the game working... so there's a step in the right direction. By the way, I'm using a Lenovo Ideapad Y580 with Windows 8 preinstalled (i7 3630 and GTX 660M). I guess the multiple screen thing isn't a huge issue because I can just disable it when I am not playing JC2. But next thing I want to look into is how come you can't click out of the JC2 window when you initially open it without having to completely shut down the program and reopen it? If I click on the taskbar or mess up with the windowed gaming script thing the other guy provided then the screen goes black and then comes back on showing the desktop, and it won't let me open JC2 again until I close out of it and restart it.

To fix the multiple screen problem, you want to move your mouse to the right corner to open up the tab.

Next you want to go to devices and then second screen, the click Pc screen only. To fix the problem with just cause 2 you want to uncheck the full screen button in the display settings IN the just cause 2 resolution tab.

If you are still haveing any problems tell me.
MrSteelerfan66 Dec 31, 2012 @ 9:01am 
This like permantly wont mess up the resoloution of my computer, right?
Showing 1-15 of 58 comments
< >
Per page: 15 30 50
Date Posted: Dec 30, 2012 @ 10:30am
Posts: 58