Enticles! May 14, 2013 @ 12:57pm
Low FPS after PC upgrade
Hi all,

originally posted this in another thread without realising. Hoping posting here gets a response that isnt from an illiterate troll :P

looking to see if anyone has a solution to an issue which i have started to experience since upgrading my PC (a completely new machine - only the monitor is the same). Old and new specs are as follows:

OLD PC:
Core2Duo E6750 @ 2.66ghz
2GB DDR2 800mhz RAM
EVGA 630i Motherboard with integrated nVidia GeForce 7100 Graphics (shared memory)
Windows XP Professional 32-bit
22" 1680 x 1050 monitor
320GB HDD

NEW PC:
AMD FX-8350 @ 4.0Ghz
32GB DDR3 1866mhz RAM
Sapphire Radeon HD 7970 3GB
Windows 8 Professional 64-bit
22" 1680 x 1050 monitor
2 x 256GB SSDs running in RAID0

as you can see the new machine's specs should have absolutely no problem running this game.

Troubleshooting that i have already done:

1) Disabled Vsync and lowered settings to minimum - low FPS issue remains
2) Ran more modern (and demanding games) - Tested with CS:GO, TF2, Borderlands 2, and Civilisation 5. All newer games run absolutely flawlessly.
3) Ran Anti-Virus, Anti-Spyware, and Anti-Malware scans - no problems found.
4) Uninstalled CCC Drivers, Ran Driversweeper, Reinstalled latest CCC Drivers (13.4) - low FPS issue remains.
5) Uninstalled CCC Drivers, Ran Driversweeper, Installed latest CCC Beta Drivers (13.5) - low FPS issue remains.
6) "Tricked" the 7970 into remaining at full 3d clock speed settings (925mhz core, 5500mhz effective memory etc) - low FPS issue remains
7) Formatted my C:\ Drive and re-installed Windows 8 completely - low FPS issue remains.
8) Deleted the RAID0 Array, reformatted and re-installed Windows 8 - low FPS issue remains.

I was using the old machine listed above until about a week ago, and it ran CZ with a solid 100 FPS (unless a smoke grenade was used), even after the linux support updates from Valve. As soon as i built my new machine and installed CZ on it, the FPS was extremely sporadic, dropping as low as 40 FPS, and averaging about 55-60 FPS in general.

I have noticed that the card doesnt seem to kick into 3d clock speeds when running this game, but as mentioned above even forcing the card to stay at full 3d clock speeds makes no difference with CZ. If someone else has experienced this problem and found a workaround for it i would love to hear about it.

Thanks in advance
Showing 1-15 of 15 comments
< >
Enticles! May 16, 2013 @ 8:12am 
bumping this thread, surely im not the only person having this issue?
Sajin May 16, 2013 @ 11:10am 
My PC is built by similar architecture,which consists of Phenom II x4 955 BE & HD 7950 can run this at steady 100fps.Driver version is 13.1,and even Anti-Aliasing and Texture Filtering override with maximum setting don't affect it..I don't think other factor involve your problem.
Win 8 64bit OS or newer Catalyst?
Last edited by Sajin; May 18, 2013 @ 6:20am
Dreadnaught May 17, 2013 @ 6:13am 
Enti, Windows 8 is not very friendly when it comes to handling direct x versions below version 10 (basically what comes with windows 8 installation if I'm not mistaken) Games that require 9.0c are prone to bugs, and crashing due to conflicts with previous versions. Aion in particular.
The relevance of this statement is that with condition zero being a much older application, it runs a much older version, direct 7. Try to run 1.6 if you can since it uses the same DX version. If neither run, you'll know why
Enticles! May 21, 2013 @ 8:44pm 
ok, ive tried an older driver version and this hasn't resolved the issue either (12.8). considering this game runs on a Windows 8 laptop with a nVidia GTX640M in it i am almost positive it is either a faulty graphics card or bad drivers, and since the graphics card plays all other games flawlessly i'm inclined to believe its the drivers :(
Enticles! May 21, 2013 @ 9:04pm 
just tried with the 13.1 drivers as well, no difference. Kind of feeling let down by AMD and their notoriously awful drivers
Picuira May 21, 2013 @ 11:34pm 
so, i know this has nothing to do with this thread but, how are you guys even managing to play it? mine's still stuck on the "w_kevlar.mld" file missing... i can't even start a game
sorry for the totally off topic comment here... but i'm really upset by this
Sajin May 22, 2013 @ 6:00am 
Awful driver is same at nVidia's one.They has lost compatibility with many old games for new game performance.If you need stability on old games,don't use new drivers.New driver is experimental and focussed on new games.

Moreover,you should report issue through AMD Issue Reporting Form[www.amdsurveys.com] .Keeping Compatibility is built on accumulation of such reports.
Last edited by Sajin; May 22, 2013 @ 6:01am
Enticles! May 22, 2013 @ 8:49am 
thanks for the insight sajin, it is something i had considered could be the case but found nothing solid to support my line of throught. I reported the issue via AMD's bug reporting form yesterday evening, although i'm half expecting not to hear anything from it, after all it is a dying game. Overall i am really impressed with the sheer power of the card, its just upsetting that i might have to give up one of my all time favourite games in order to use it!

I'll report back if AMD come back to me with any information.

Picuria - what a lot of people have done to resolve issues with CZ / 1.6 following the linux update is to copy their old CS folder into the new destination, failing that uninstall the game completely, go into steams directory and delete all folders left behind for CS / CZ and then re-download the game. Sometimes the uninstaller leaves files behind.

Picuira May 22, 2013 @ 5:32pm 
Originally posted by =(E&G)= Enticles!:
thanks for the insight sajin, it is something i had considered could be the case but found nothing solid to support my line of throught. I reported the issue via AMD's bug reporting form yesterday evening, although i'm half expecting not to hear anything from it, after all it is a dying game. Overall i am really impressed with the sheer power of the card, its just upsetting that i might have to give up one of my all time favourite games in order to use it!

I'll report back if AMD come back to me with any information.

Picuria - what a lot of people have done to resolve issues with CZ / 1.6 following the linux update is to copy their old CS folder into the new destination, failing that uninstall the game completely, go into steams directory and delete all folders left behind for CS / CZ and then re-download the game. Sometimes the uninstaller leaves files behind.

oh... thanks for the tip... but should i uninstall every cs? i mean... i've got them all... i'll try with cs and cz... let's see what happens ^^
but thanks anyways
Enticles! May 22, 2013 @ 8:56pm 
only cs 1.6 and cs:cz, as they're in the same folder. If you have halflife1, dod, tfc, or any other game that uses the halflife1 engine it may be a good idea to get rid of them too whilst your at it - to eliminate any engine related files from being the issue and not getting rid of it in the uninstall
Picuira May 29, 2013 @ 10:04am 
sorry i couldn't reply sooner... but thanks... it worked perfectly
thank you very much ^^
<-AIM->_ɌЄPŦƗLЄ★ May 30, 2013 @ 6:27pm 
wow same issue bro....
Enticles! Aug 15, 2013 @ 3:20pm 
i figured out what was causing my problems, and since nowhere else has this listed i thought i'd post it here:

i was using my PC as a virtual server machine when not gaming via Windows 8's Hyper-V feature. when Hyper-V is installed it becomes a Hypervisor workstation and virtualises the host machines OS as well.

in lamens terms it virtualised my install of Windows 8 as well my virtual machines i had running, when Hyper-V got uninstalled my FPS issue disappeared.

hope this helps someone else, this was so infuriating to figure out.
LoG | IndianaTEK Aug 16, 2013 @ 2:01pm 
good
Spirit Aug 16, 2013 @ 2:02pm 
Personellement, j'avait un bug de FPS aussi, mon pc tournée a 5fps pas plus ! j'ai fait une mise a jours de mes pilote graphic ! j'ai désactivé ma synco verticale reglez ma configue et je troune a 100.5 fps !
Showing 1-15 of 15 comments
< >
Per page: 15 30 50
Date Posted: May 14, 2013 @ 12:57pm
Posts: 15