Bejeweled 3

Bejeweled 3

View Stats:
Bejeweled 3 > General Discussions > Topic Details
Ronnie Aug 9, 2013 @ 7:12pm
FATAL ERROR!
Hello!
I sell this game tonight.
I could run the game, but I saw that the resolution was not good. So I changed and restarted the game
But I could not run!
I have a window that opens with registered FATAL ERROR!

An unexpected error has occured! Pressing 'Send Report' will send us helpful debugging information that may help us resolve this issue in the future.

You can also contact us directly at feedback@popcap.com.


Exception: Access Violation (code 0xc0000005) at address 0076AF6E in thread EB0
Module: Bejeweled3.exe
Logical Address: 0001:00369F6E

0018F80C 0076AF6E 0001:00369F6E Bejeweled3.exe
Params: 02DCBE60 00000300 0046DAC2 00000000


EAX:02DCBE60 EBX:00000000 ECX:00000000 EDX:00000000 ESI:00000000 EDI:008647B4
EIP:0076AF6E ESP:0018F808 EBP:02DCBE60
CS:0023 SS:002B DS:002B ES:002B FS:0053 GS:002B
Flags:00010206

Windows Ver: NT 6.1 Build 7600
DDraw Ver:
DSound Ver:

Product: Bejeweled3
Version: 1.1.12.4196
Time Loaded: 00:00:01
Fullscreen: Yes
Primary ThreadId: EB0
Resolution: 1024x768
3D Mode: OFF
Times Played: 0
Build Num: 0
Build Date:

Anyone has had this problem?
I tried everything, but nothing made ​​the game does not start.
I also uninstalled and reinstalled, but still the same problem ..
Someone would have an idea please?
< >
Showing 1-15 of 15 comments
sroberts3492 Oct 12, 2013 @ 6:55pm 
I have the same problem game played before but now it won't play at all with the same error your getting
Toff Nov 2, 2013 @ 5:36am 
Open regedit, go to
HKEY_CURRENT_USER\Software\SteamPopCap\Bejewelled3
and change the value of
ArtRes to 258 (Hexadecimal) or 600 (Decimal)
This should make the game start again.
cseneque Dec 21, 2013 @ 10:18pm 
Originally posted by Toff:
Open regedit, go to
HKEY_CURRENT_USER\Software\SteamPopCap\Bejewelled3
and change the value of
ArtRes to 258 (Hexadecimal) or 600 (Decimal)
This should make the game start again.

Thank you! I had this issue for ages and was very glad to find your solution :)
Quintic1200 Dec 26, 2013 @ 8:57am 
I have this issue all the time, or at least a similar issue. My issue happens when Steam is running from one account on the computer and someone tries running Bejeweled 3 from the other account on the computer. Nothing happens on the other account, but when you switch to my account, you see that FATAL ERROR message show up. So Bejeweled 3 has issues when you try running it from a computer account separate from the one on which Steam is running. Just thought I'd mention that.
The Evil Soultaker Jan 10, 2014 @ 12:05pm 
wait did your game crash or your computer crash?
Last edited by The Evil Soultaker; Jan 10, 2014 @ 12:05pm
borisport52 Jan 17, 2014 @ 4:36pm 
I have the same problem. But the solution above doesn't help. Is the value specific to each computer? My error said the above, can someone help?


Exception: Access Violation (code 0xc0000005) at address 0076AF6E in thread 114C
Module: Bejeweled3.exe
Logical Address: 0001:00369F6E

0018F80C 0076AF6E 0001:00369F6E Bejeweled3.exe
Params: 002C73E8 00000001 0046DAC2 00000001


EAX:002C73E8 EBX:00000001 ECX:00000000 EDX:00000000 ESI:00000000 EDI:008647B4
EIP:0076AF6E ESP:0018F808 EBP:03B09B90
CS:0023 SS:002B DS:002B ES:002B FS:0053 GS:002B
Flags:00010202

Windows Ver: NT 6.2 Build 9200
DDraw Ver: 6.2.9200.16384
DSound Ver: 6.2.9200.16384

Product: Bejeweled3
Version: 1.1.12.4196
Time Loaded: 00:00:06
Fullscreen: No
Primary ThreadId: 114C
Resolution: 800x600
3D Mode: OFF
Times Played: 0
Build Num: 0
Build Date:
Mr_Peaches Mar 8, 2014 @ 4:55pm 
I have the exact same error, down to the exact same text in the error message. When I looked through the game files in RegEdit, the "ArtRes" value didn't exist, so I couldn't try that solution.

Dozens of possible causes are listed in my research but nobody's got a solution. Very frustrating. I'll try putting in some tickets I guess and see if anyone responds.
Mr_Peaches Mar 8, 2014 @ 5:23pm 
I've managed to get the game running fullscreen again by editing the registry. For those familiar with computers: set the "Screen Mode" value of Bejeweled 3 from 0 to 1. For those less familiar with computers, I've included what I hope are easy to follow instructions:

1) Press and hold the Windows key, and press "f" while you're holding it.

2) (Windows 8.1) Make sure you're searching "everywhere," not "files."

3) Search for "RegEdit."

4) Open Regedit.

5) In the navigation pane in the left column of Regedit, navigate to HKEY_CURRENT_USER --> Software --> SteamPopCap --> Bejeweled 3. Click on the Bejeweled 3 Folder. In the right column of the Regedit window you should now see several values.

6) Right click on "ScreenMode," and select "Modify."

7) In the "Value Data" field, change the value to 1 and click "OK."

For me, Bejeweled 3 now opens, but it opens fullscreen, and I can't make it do windowed mode. On the main menu the graphics on the lower half of the screen also get a little weird, but the game still plays. When playing the graphics are normal.

I'll keep playing with the registry to see if I can get windowed mode functioning again. Good luck!
ShamaloDXD Oct 23, 2014 @ 10:55am 
I have the game with origin... :/
eckhard Apr 1, 2015 @ 3:37am 
Not sure if this is still a topic but i have had the same issue and no Artwork Entry for this game in the registry.
Instead of Messing with the registry i tried to localize the game in another language. So after switching from german to english, french and back to german the game stated successfully.
Tired Dragon Jul 26, 2015 @ 4:22am 
Yeah, the registry fix makes the game behave weirdly. Changing the language fixed the problem beautifully for me.
ArthurYu Sep 10, 2015 @ 8:15am 
Originally posted by Mr_Peaches:
I've managed to get the game running fullscreen again by editing the registry. For those familiar with computers: set the "Screen Mode" value of Bejeweled 3 from 0 to 1. For those less familiar with computers, I've included what I hope are easy to follow instructions:

1) Press and hold the Windows key, and press "f" while you're holding it.

2) (Windows 8.1) Make sure you're searching "everywhere," not "files."

3) Search for "RegEdit."

4) Open Regedit.

5) In the navigation pane in the left column of Regedit, navigate to HKEY_CURRENT_USER --> Software --> SteamPopCap --> Bejeweled 3. Click on the Bejeweled 3 Folder. In the right column of the Regedit window you should now see several values.

6) Right click on "ScreenMode," and select "Modify."

7) In the "Value Data" field, change the value to 1 and click "OK."

For me, Bejeweled 3 now opens, but it opens fullscreen, and I can't make it do windowed mode. On the main menu the graphics on the lower half of the screen also get a little weird, but the game still plays. When playing the graphics are normal.

I'll keep playing with the registry to see if I can get windowed mode functioning again. Good luck!
Thanks a million! Your solution works for me
GG Crono May 21 @ 7:02pm 
I'm encountering this problem myself. Changing the ScreenMode thing makes the game sort of work... but the graphics are choppy and, again, can't play in windows mode. I'm in Win 10, and the weird thing is, the game USED to work just fine, but just started kicking up this error code for me a few weeks ago.

Does anyone have any insight for other potential fixes?
Mihai984 Jun 28 @ 12:52pm 
Originally posted by GG Crono:
I'm encountering this problem myself. Changing the ScreenMode thing makes the game sort of work... but the graphics are choppy and, again, can't play in windows mode. I'm in Win 10, and the weird thing is, the game USED to work just fine, but just started kicking up this error code for me a few weeks ago.

Does anyone have any insight for other potential fixes?

The game doesn't work with 3d acceleration because your system is using 8gb of ram. Before I upgraded from 4gb to 8gb of RAM Bejeweled Twist and Zuma's Revenge's 3d acceleration worked flawlessly. Here's how to play it with 3d acceleration but you have to restart your computer every time you want to play it in 3d acceleration mode.

1.Type Windows Key + R.
2.You will see the run program.
3.Type msconfig.
4.You will see the system configuration program.
5.Go to the boot tab.
6.Click on Advanced Options
7.Check Maximum memory.
8.Change the number to 4096.
9.Click OK.

This will set your system to use 4gb of RAM so make sure theres not much background tasks so your RAM isn't filled up and crashes the computer.
open the game from game files and change resolution, it worked for me
< >
Showing 1-15 of 15 comments
Per page: 15 30 50

Bejeweled 3 > General Discussions > Topic Details