BioShock > General Discussions > Topic Details
CamoMan Dec 24, 2012 @ 6:58am
bioshock for windows 7
Does bioshock work on windows 7 platfourm It says it only works on vista or XP
Showing 1-12 of 12 comments
< >
gorilla glue Dec 24, 2012 @ 7:06am 
I have it on win7, it works for me
Dayman, fighter of the Nightman Dec 24, 2012 @ 7:22am 
It works fine.
ToSkyX Dec 24, 2012 @ 7:30am 
Yes it does.
Atheist Dec 24, 2012 @ 12:31pm 
not working on mine
Darvos Dec 24, 2012 @ 1:29pm 
It has a Anoying problem with the Subtitle!!
kooplar Dec 24, 2012 @ 2:18pm 
not working for me on w7
Bash Dec 24, 2012 @ 4:20pm 
It'll work if you just change a few things real quick. See the following thread: http://steamcommunity.com/app/7670/discussions/0/846940247908272955/
Last edited by Bash; Dec 24, 2012 @ 4:20pm
Felipe_0406 Dec 24, 2012 @ 6:56pm 
Yo solo hablo español =D , pero tratare de ayudarte...

I had the same problem.

To play this game, you need to change 3 things:

1- This game doesn't work with directx 10. Try to run this game in dx 9. You just have to put this code "-dx9" in your launch options (Right click on Bioshock and select properties in steam and go to "set launch")

2- About the problem with windows 7,you can change the game compatibility, choosing Windows Vista and making right click on bioshock.exe (you can find this file on steam folder)

3- Change the video card config. Nvidia have a lot of default settings, like high textures and buffer things. Try to disable those things.


Sorry for my bad english.

DCNRolly Dec 24, 2012 @ 8:22pm 
Sure does!
N3tBuM Dec 24, 2012 @ 9:58pm 
I bought BioShock tonight and after installing it I was getting the same problem as others so I checked the Windows Event Viewer:

Faulting application name: bioshock.exe, version: 1.0.0.0, time stamp: 0x474f5a3a
Faulting module name: OLEAUT32.dll, version: 6.1.7601.17676, time stamp: 0x4e58702a
Exception code: 0xc0000005
Fault offset: 0x00004971
Faulting process id: 0x1624
Faulting application start time: 0x01cde24ca0fe4ff2
Faulting application path: C:\Program Files (x86)\Steam\steamapps\common\Bioshock\Builds\Release\bioshock.exe
Faulting module path: C:\Windows\syswow64\OLEAUT32.dll
Report Id: e0c80608-4e3f-11e2-9ea5-005056c00008

After some searching I found a solution that worked for me. http://forums.2kgames.com/showthread.php?37774-That-ol-crash-problem


Post # 7 by QuakeBert - I've got the 'Steam' download of BioShock. I had the same problems, this fixed it for me.

To fix the crashing when launching the game, you need to install the OpenAL drivers.
http://connect.creativelabs.com/openal/Downloads/oalinst.zip

I am running
OS 7 x64 Enterprise SP1
AirborneGamer Dec 28, 2012 @ 7:21am 
Originally posted by Felipe_0406:

I had the same problem.

To play this game, you need to change 3 things:

1- This game doesn't work with directx 10. Try to run this game in dx 9. You just have to put this code "-dx9" in your launch options (Right click on Bioshock and select properties in steam and go to "set launch")

2- About the problem with windows 7,you can change the game compatibility, choosing Windows Vista and making right click on bioshock.exe (you can find this file on steam folder)

3- Change the video card config. Nvidia have a lot of default settings, like high textures and buffer things. Try to disable those things.


^^^^^THIS!
sille_cl Dec 29, 2012 @ 4:32pm 
Since now it didnt work. That helped for me:

--->>> NOTICE: I have still sound with the "nosound"-option.

A. BioShock will not load. OR BioShock freezes after the splash screen.

This has been attributed to several causes. One is sound, the other is an improper download. Follow these steps:

1. Verify you game cache with-in steam.
2. Attempt to run the game again. If it fails to load again you may have a sound issue.
3. Add "-nosound" to your launch options. To do this:
4. Go to My Games panel.
5. Right Click "BioShock" icon.
6. Go to Properties.
7. Click "Set Launch Options".
8. Type "-nosound" (without quotes).
9. Try to run the game. Did it work? If it worked you have a sound issue. Even though your game has presently loaded the "-nosound" launch option will not allow you to play with sound. If you remove "-nosound" your game will likely not load again.
10. Now that you are aware you have a sound issue check the following fixes below that deal with sound.

IMPORTANT: After using the "-nosound" launch option, remember to remove it after doing any possible fix. This will ensure that your sound will work. If you leave "-nosound" on you will not have sound, and you will be unable to figure out whether or not the change to your driver, etc has had any affect.
Showing 1-12 of 12 comments
< >
Per page: 15 30 50
Date Posted: Dec 24, 2012 @ 6:58am
Posts: 12