BioShock > 综合讨论 > 主题详情
Your_Daily_vTmNs 2012年12月22日下午8:32
No Sound and Black screen Fix
I dont know if these fixes have been posted but the worked for me so I am going to put them up here and hopefully everyone that is still having issues can benefit from it.

For the "no sound" issue this is waht I did:
Go to the Control Panel, Hardware and Sound, Manage Audio Devices, and select the Recording tab.

Next, right click the empty space below the installed devices and check Show Disabled Devices.

The Stereo Mix should appear. Right click on the icon and enable it. Then, click on OK to close the window and then close the Control Panel

For the black screen erroe try this:
Go to your Library, right click on Bioshock and open Properties

In properties click "Set Launch Option..." and type in "-dx9" without the parentheses.

You should be able to run the game no problem, or atleast these fixes worked for me. I hope this helps.
正在显示第 1 - 8 条,共 8 条留言
< >
Kattums 2012年12月22日下午8:51 
Thanks a lot, man :)

After numerous attempts at fixing the thing I finally managed to do it on my WIndows 7 64-bit PC. Might as well share my experience with you guys.

First I was getting a Bioshock.exe error from Steam. I did what they suggested and set Bioshock.exe to run in compatibility mode with Windows 2000.

Then I ran into the "Application is already running" issue. For this I did what they said and disabled the tablet pc feature, here's how to do it:

1) Open Control Panel.
2) Open Programs and Features.
3) On the Programs and Features window, look on the left and click on the link that says "Turn Windows Features On or Off"
4) In this new window, uncheck the feature called "Tablet PC Components"
5) Reboot your computer.

After this I disabled the unused audio devices. I was getting sound, but a black screen. I did the black screen fix posted here and I'm already in the bathysphere on my way to Rapture :)

Hope this information helps anyone else.
最后由 Kattums 编辑于; 2012年12月22日下午8:53
Your_Daily_vTmNs 2012年12月22日下午9:08 
No problem, glad you got it working.
LastSide 2012年12月26日下午12:45 
I went to the .exe file and set the compatibility to Windows 2003 service pack.
☣☠JadeStalker☠☣ 2012年12月26日下午1:13 
hey I couldn't find the Stereo Mixer On recording Section, when I right click and show disable devices, I still couldn't find it, Im using headset btw, All Im seeing are Mircophone Twice and Line In , only 3 option
最后由 ☣☠JadeStalker☠☣ 编辑于; 2012年12月28日下午5:01
Your_Daily_vTmNs 2012年12月26日下午5:53 
I am not sure why it isnt showing, maybe try removing the microphone, sorry if that doesn't help man.
Mudguy47 2012年12月26日下午8:38 
Hello everyone. And I suppose this is the proper place to ask for help on the sound issue. I ahve a similar problem as JadeStalker with the "Stereo Mix" not showing, and there is not any devices inside that box. I have no clue as to what the problem maybe and I'm not computer savvy. And if it helps I play on a television screen.
n4yp.beorn 2012年12月27日上午3:07 
I have the same problem as Mudguy47 and JadeStalker.
Jurgen 2012年12月29日上午11:31 
Hello everyone, i got a bit of a problem, when i done all that thing u needed to do for getting the sound to work, it dosent work my stereo mix showed up for me but when i activated it i didnt get any sound to the game i dont know why someone know how to fix it?
正在显示第 1 - 8 条,共 8 条留言
< >
每页显示数: 15 30 50
发帖日期: 2012年12月22日下午8:32
帖子数: 8