BioShock > General Discussions > Topic Details
SirWargrave Dec 22, 2012 @ 1:26am
Bioshock 1 exe crashed
I tried to start Bioshock 1 on w7 64 bit then i see the bioshock logo and then the message the game exe doesnt work anymore...

I need help ;)
Showing 1-15 of 26 comments
< >
Nolawer Dec 22, 2012 @ 1:59am 
I have the same on Windows 8 x64
Last edited by Nolawer; Dec 22, 2012 @ 2:03am
TheOneOfAllTime Dec 22, 2012 @ 2:29am 
got the exact same problem :/
Hœnir Dec 22, 2012 @ 2:36am 
Same problem for me, Windows 7 x64
SirWargrave Dec 22, 2012 @ 2:41am 
Okay i found the problem

sry for my bad english but i tried to explain how i made my game running

1. go on steam libary and go on the settings from bioshock

2. choose "files searching" or the first point on the settings one

3. In the next folder you have to search the bioshock exe and make a right klick on it and go to the compatibiliy step and choose windows 2000 and press okay

And then the game will start

i hope you understand the text ;)
Hœnir Dec 22, 2012 @ 2:45am 
Ok I fixed it by following DMB4237's advice

"Did you run it in Vista compatibility mode? Go to C: > Program Files (x86) > Steam > steamapps > common > Bioshock > Builds > Release. Right Click on Bioshock, select properties, go to Compatibility Tab, where it says "Run this program in compatibility mode:" choose windows vista.

If you run into sound issues in game, right click on the little speaker at the bottom right next to your clock, choose "Recording Devices", choose stereo mix and press "set to default" (if stereo mix doesn't show up, right click on an empty space within the box of devices and press "Show Disabled Devices"

Works fine for me now.
beedoo (代购) Dec 22, 2012 @ 3:58am 
hard to play
oldriku Dec 22, 2012 @ 6:46am 
I'm having the same problem but in WXP 32 bits... I tried the compatibility thing but it still doesn't work.
Ganjuto | Weed ON Dec 22, 2012 @ 7:40am 
to me still does not work
JESTEM JAK TESTOVIRON Dec 22, 2012 @ 7:51am 
Don't buy it... It won't work on most machines. ♥♥♥♥ing scam.
oldriku Dec 22, 2012 @ 8:02am 
Try this, it didn't work for me but it seems to work for most people:

http://forums.steampowered.com/forums/showthread.php?t=1133842
onna Dec 22, 2012 @ 12:36pm 
Originally posted by oldriku:
Try this, it didn't work for me but it seems to work for most people:

http://forums.steampowered.com/forums/showthread.php?t=1133842

I had no in-game sound after the menu. This thread really helped me, thanks.
Dr.Gutt'O Dec 22, 2012 @ 3:10pm 
Hi dudes!
I don't know if you've tried, but I had the same issue and after some geek-common-sense & google I came up with this:
Install the latest directx. There's one provided in the game install dir ..\steamapps\common\bioshock\directx\ but it didn't work out 4 me, so I used:
http://www.microsoft.com/en-us/download/confirmation.aspx?id=35

So from the side of directx it takes care of the problem - this fixes sound problems.

Then check if you have installed Visual C:
also presented in the game install dir: ..\steamapps\common\bioshock\vcredist\

Then go to ..\bioshock\builds\release\ and right-click bioshock.exe
On compatibility tab ( [don't read this part if you're noob] forgive my Lord but it's called folder since win 7 but it's freakin confusing so it's tab anyway) set it to run compatibility mode for Vista (NOT sp1 or sp2, plain vista) and also tick the box: run this program as administrator.

Since I did this, the game just runs perfect for me - this takes care of the crashings.

So! I really like to support those developers who create awesome stuff. Like this game. And really dig how this steam system works nowadays, how it delivers digital content to us.
But every once in a while... (if you don't have sense of humour do NOT click on the following link! :D and pretty please with cherry on top do not take it seriously :D )
http://ipretorian.org/en/files/2010/12/pirate_vs_original.jpeg
Last edited by Dr.Gutt'O; Dec 22, 2012 @ 3:15pm
topsekret Dec 23, 2012 @ 1:56am 
Originally posted by oldriku:
Try this, it didn't work for me but it seems to work for most people:

http://forums.steampowered.com/forums/showthread.php?t=1133842

Thanks for the link; I found the info I needed to get it to work here.

I had already tried all the compatability mode and sound fixes, but none of those worked for me. In the launch options, I added the command "-dx9" (without quotes) and the game worked perfectly. If you can't get the game to work, and you've done everything else, try doing this!
Last edited by topsekret; Dec 23, 2012 @ 1:56am
ruiv Dec 23, 2012 @ 3:17am 
Originally posted by oldriku:
Try this, it didn't work for me but it seems to work for most people:

http://forums.steampowered.com/forums/showthread.php?t=1133842

THANKS. I just uninstall OpenAL, and it works now.
SirWargrave Dec 23, 2012 @ 3:26am 
Originally posted by topsekret:
Originally posted by oldriku:
Try this, it didn't work for me but it seems to work for most people:



I had already tried all the compatability mode and sound fixes, but none of those worked for me. In the launch options, I added the command "-dx9" (without quotes) and the game worked perfectly. If you can't get the game to work, and you've done everything else, try doing this!


This one works fine!!!!!
Showing 1-15 of 26 comments
< >
Per page: 15 30 50
Date Posted: Dec 22, 2012 @ 1:26am
Posts: 26