BioShock > General Discussions > Topic Details
The Raccoon Apr 30, 2013 @ 6:30pm
does it work with Win8?
cx
Showing 1-13 of 13 comments
< >
DINOSAURS May 1, 2013 @ 12:09am 
so far it works without sound for me, gonna mess around a bit more, tried one fix and didn't work

GOTY 9/10 etc. etc.
Angeal May 1, 2013 @ 12:39am 
works for me
Harbinger-HU May 1, 2013 @ 1:30am 
You need a few trick on Win7 too. At least for me, the only way I get sound from the game, if I plug my headphone line-in jack. -_-
Hippiegirl May 1, 2013 @ 5:30pm 
It worked fine up until the end of level 2 - now it crashes. Have tried various fixes listed here (compatability, resolution, etc.) and so far, nothing works. I'd beware if your'e running Win 8 because apparently I'm not the only one having issues.
j4960s May 2, 2013 @ 3:57am 
windows 8 64bit it works great
Peer Review May 2, 2013 @ 7:27am 
No sound problems here. Win 8 pro 64 bit as OS
Lebon69 May 2, 2013 @ 9:57am 
no sound for me too.
Хлібчик May 4, 2013 @ 10:04am 
Crash at startup on my Win 8 x64.
The Raccoon May 4, 2013 @ 10:06am 
thanks for saving me 20$ LOL
j4960s May 4, 2013 @ 11:30am 
how do you update your software & drivers
Hippiegirl May 5, 2013 @ 12:45am 
Okay, I'm back in business (knock on wood). This is what I did;

In Windows Bioshock Properties (not Steam):
1. Adjusted the compatibility mode for the game to Windows Vista Service pack 2
2. Checked "run as administrator"

In Bioshock game graphics options:
1. Set all Graphics qualities and details to "Medium"
2. Set game dpi to "1280x720"

I had been launching the game from windows bioshock.exe instead of from Steam but have since tried both with no problems.

My game always crashed at the same spot: In Neptunes Bounty, towards the end of level when returning to Fontaine Fisheries to meet up with Peach with the completed splicer research. Even after some adjustments, I still crashed at this spot. I made the above adjustments, and went back to a saved game towards the beginning of the level and played forward till that crash spot and held my breath... made it , whew!

I have never experienced any sound issues.

Anyways, so far, so good. Hope this may help someone.

My system: Core i7 3630QM, GE Force GT 650M, Windows 8 64 bit, 8Gb DDR3, 1 TB SATA HD
FlocK May 5, 2013 @ 2:43am 
It is working 100% I bougt it on Friday
ImSpongy May 5, 2013 @ 3:28am 
Mine did nott have sound so I went to recording devices and enabled Sound Mix and it worked perfectly.
Showing 1-13 of 13 comments
< >
Per page: 15 30 50
Date Posted: Apr 30, 2013 @ 6:30pm
Posts: 13