BioShock > General Discussions > Topic Details
kbauer87 Apr 11, 2013 @ 3:19pm
Can only run with "-nosound" ... with no sound..
I'm only able to start Bioshock when i have "-nosound" in the launch options. This works great for starting the game, but once it reaches past the cut scenes, i have no sound during game play. I've looked through the forums, and so far, none of these solutions have worked for me.
Showing 1-15 of 18 comments
< >
Nemesis82F Apr 13, 2013 @ 2:37am 
what operating system are you running? what are your computer hardware specs? (motherboard, soundcard, video card, etc)
tulio Apr 13, 2013 @ 7:45am 
I cant run Bishock eitrher. My operating system is Win 8 Pro. The nosound option only works till you enter the batiscafe in the beginning of the game and then freezes there. I think the game was only compatible with Win XP.
~Mr Grumples~ Apr 14, 2013 @ 1:35pm 
I had the same issue, the solution I used was the following, game runs fine for me now, with sound:
-Go to control panel->Hardware and sound -> manage audio devices
-Click "Recording" tab
-Right click in white space area, select "Show Disabled Devices"
- Right click "Stereo Mix" and enable it
eGG3h Apr 14, 2013 @ 7:21pm 
Originally posted by kbauer87:
I'm only able to start Bioshock when i have "-nosound" in the launch options. This works great for starting the game, but once it reaches past the cut scenes, i have no sound during game play. I've looked through the forums, and so far, none of these solutions have worked for me.

eGGactly the same for me man.



Originally posted by AnApparition:
I had the same issue, the solution I used was the following, game runs fine for me now, with sound:
-Go to control panel->Hardware and sound -> manage audio devices
-Click "Recording" tab
-Right click in white space area, select "Show Disabled Devices"
- Right click "Stereo Mix" and enable it

This still doesnt give me sound in-game.

My OS: Windows 7 64bit.


Clearly a sound issue.... why is there no patch to fix this? its ♥♥♥♥ing ♥♥♥♥♥♥♥♥.
JKflipflop Apr 14, 2013 @ 10:20pm 
Do you have real audio drivers installed? Or are you using the default ones windows comes with?
Reststopkirk Apr 14, 2013 @ 10:40pm 
This worked for me (courtesy aj058 from http://forums.steampowered.com/forums/showthread.php?t=1747424&page=2):

- Going into the Sound section of the Control Panel and disabling all playback devices EXCEPT Speakers and all recording devices EXCEPT Microphone (I have no idea why it needed to have a microphone enabled, but oh well...)
- Going into the game folder and setting bioshock.exe to Windows 2000 compatibility mode.
Last edited by Reststopkirk; Apr 14, 2013 @ 10:41pm
eGG3h Apr 15, 2013 @ 4:59am 
Originally posted by JKflipflop:
Do you have real audio drivers installed? Or are you using the default ones windows comes with?

Creative X-FI
Duskwood Apr 15, 2013 @ 11:09am 
eG, I have the same sound card, and am having the same issue. All the drivers are updated, however Im not even USING the card, im using HDMI audio from my ATI card......I dunno wtf is goin on.

edit* just went into sound deviced, disabled all but HDMI output to my TV and my headset speakers. Disabled even the soundblaster X-fi. Works great now.
Last edited by Duskwood; Apr 15, 2013 @ 11:12am
tj86 Apr 15, 2013 @ 2:01pm 
I have same problem on Windows8, but nothing helps. Game runs only with -nosound parameter, but without it it's not fun. On saturday everything worked fine.
Last edited by tj86; Apr 15, 2013 @ 2:04pm
Joey19990 Apr 15, 2013 @ 6:19pm 
Originally posted by AnApparition:
I had the same issue, the solution I used was the following, game runs fine for me now, with sound:
-Go to control panel->Hardware and sound -> manage audio devices
-Click "Recording" tab
-Right click in white space area, select "Show Disabled Devices"
- Right click "Stereo Mix" and enable it

Doing this is what finally allowed me to play as well.
tj86 Apr 16, 2013 @ 7:46am 
Originally posted by Joey19990:
Originally posted by AnApparition:
I had the same issue, the solution I used was the following, game runs fine for me now, with sound:
-Go to control panel->Hardware and sound -> manage audio devices
-Click "Recording" tab
-Right click in white space area, select "Show Disabled Devices"
- Right click "Stereo Mix" and enable it

Doing this is what finally allowed me to play as well.

But do you still run game with -nosound parameter or without it ?
Roler42 Apr 25, 2013 @ 5:17pm 
Go to your game properties in your library and go to set launch options, remove the -nosound command, it's useless, instead use -dx9, that should do the trick, it worked for me
MonsterTraps Apr 25, 2013 @ 11:35pm 
I have the same problem. No 3rd party sound cards installed. I've tried everything posted here and no dice.

Game just isn't worth playing with no sound, wish there was a definitive fix for this, very frustrating. I'm trying to play this finally for the first time!
Nathan Apr 27, 2013 @ 1:36pm 
Originally posted by AnApparition:
I had the same issue, the solution I used was the following, game runs fine for me now, with sound:
-Go to control panel->Hardware and sound -> manage audio devices
-Click "Recording" tab
-Right click in white space area, select "Show Disabled Devices"
- Right click "Stereo Mix" and enable it

This sorted the problem for me
(win 7 Ultimate)
GoneTomorrow Apr 27, 2013 @ 2:52pm 
Originally posted by AnApparition:
I had the same issue, the solution I used was the following, game runs fine for me now, with sound:
-Go to control panel->Hardware and sound -> manage audio devices
-Click "Recording" tab
-Right click in white space area, select "Show Disabled Devices"
- Right click "Stereo Mix" and enable it

The annoying thing about this fix is that it only plays stereo sound, which defeats the purpose if you want surround sound. Plus enabling it caused my sound to glitch and wouldn't revert back to 5.1 when I disabled it, but mysteriously begain to work again later (Recon3d PCIe via SPDIF to receiver).

And this whole issue is weird; I was so frustrated recently trying to get my Steam version of Bioshock to run, that I went and dug up my original retail box version. I installed it and it ran fine on v.1.0, surround sound, DX10, everything worked perfectly, sound and all. So I installed 1.1 and I had the EXACT same issue of the game not starting--and that's on the retail version! The Steam version comes with 1.1 installed, so it's the same issue; something all of a sudden in patch 1.1 is causing issues with the latest sound hardware and/or drivers. Uninstalling 1.1 from the Steam version might seem like a solution, but 1.1 resolved a ton of OTHER issues when it first came out.

This is all such ♥♥♥♥♥♥♥♥.
Last edited by GoneTomorrow; Apr 27, 2013 @ 2:55pm
Showing 1-15 of 18 comments
< >
Per page: 15 30 50
Date Posted: Apr 11, 2013 @ 3:19pm
Posts: 18