BioShock > General Discussions > Topic Details
Nemesis82F Apr 6, 2013 @ 2:24am
How to run Bioshock in Windows 7 with and/or without dx10 (maybe 8)
Please make sure all drivers, DirectX, and VC studio C++ redist fully updated (I have 2005, 2008, and 2010 on my machine, I do not know which one Bioshock requires). Also please keep in mind that this fix may not work for you if you have a sound card that is not Realtek/Creative and does not support stereo mix.

1) right click on Bioshock in steam, select properties -> go to local files -> browse local files and find bioshock.exe. Right click on it, select properties -> compatability and set bioshock.exe to run in windows vista, windows vista service pack 1, or windows vista service pack 2. Any of the 3 will do just fine but I recommend service pack 2. This will make your game not crash upon launching your game. Now to fix the sound in step 2a or 2b.

2a) two ways to fix the sound: one is set bioshock.exe to run in dx9 mode by setting "-dx9" (without the quotes) flag in launch options. DX9 will make the graphics look less appealing than DX10. This solution is for people who do not mind dx9 graphics and want the most painless solution. However some of us want this game to utilize dx10 so in order to avoid downgraded graphics go to step 2b. This step for some reason does not work for most people, if that is the case move on to step 2b.

2b)Control Panel > Hardware and Sound > Manage Audio Devices > select the Recording tab > right click the empty space below the installed devices > check Show Disabled Devices > stereo mix will appear, right click and enable stereo mix. That's it. THIS WILL NOT WORK FOR SOUND CARDS THAT DO NOT SUPPORT STEREO MIX. Your onboard audio must be either realtek or creative and with latest drivers installed for stereo mix to appear (according to online forum post for people asking why stereo mix does not appear for them). If this is the case your best bet for getting this game to run is to buy an inexpensive sound card that does support stereo mix.

Why does this work? I have no idea it just does.
Last edited by Nemesis82F; Apr 10, 2013 @ 8:09pm
Showing 1-15 of 29 comments
< >
Nemesis82F Apr 6, 2013 @ 2:25am 
also if someone can please test this on windows 8 and give some feedback.
mazuren Apr 7, 2013 @ 1:20am 
With #2 when you say "setting -dx9 flag in launch options." do you mean just typing in -dx9? Because doing that only screwed the graphics up. I'll be honest, I have no idea what dx9 or dx10 even means, so I have no clue which one I want, I just want sound. I'm not great with this technical stuff, if you could clarify that would be awesome.
Last edited by mazuren; Apr 7, 2013 @ 1:22am
Nemesis82F Apr 7, 2013 @ 1:27am 
you type in "-dx9" without the quotes in launch options. running the game in dx9 will make the game run (theoretically) slower than dx10 on dx10/dx11 machines. dx or DirectX is the name of the graphics API games for windows use.

But anyway if you feel uneasy do the second solution: just go to control panel > hardware and sound > manage audio devices > select recording tab > right click on empty space and select "Show Disabled Devices" > Stereo Mix will appear, right click it and enable.

I will re-organize the original post to make it easier to follow.
Nemesis82F Apr 7, 2013 @ 1:28am 
oh and dx9 will make your graphics less appealing than dx10 so that is to be expected, but do the stereo mix fix. Its guaranteed to work.
mazuren Apr 7, 2013 @ 1:36am 
Ok so I tried the second solution and at "Select Show Disabled Devices" no Stereo Mix appeared, now what?
Nemesis82F Apr 7, 2013 @ 1:47am 
in the recording tab? not the playback tab correct?
Nemesis82F Apr 7, 2013 @ 1:47am 
you have to select show disabled devices in the recording tab
mazuren Apr 7, 2013 @ 1:56am 
I followed your instructions completely and no Stereo Mix appeared when I chose Show Disabled Devices. No clue what to do now.
Nemesis82F Apr 7, 2013 @ 1:59am 
try running bioshock.exe in windows xp service pack 2 compatibility mode instead
mazuren Apr 7, 2013 @ 2:08am 
That didn't work either. I also tried running it in Vista service pack 1 and windows 7, neither worked.
Nemesis82F Apr 7, 2013 @ 2:19am 
the last thing i can think of is to update your sound drivers, and if that does not make stereo mix appear it is because your onboard audio card does not support stereo mix unfortunately. Otherwise the only way you can get this game to run with sound is adding "-dx9" flag to launch options. What model is your computer? I can find out if your onboard audio supports stereo mix.
Last edited by Nemesis82F; Apr 7, 2013 @ 2:20am
Archangel_XIII Apr 7, 2013 @ 4:33am 
Ok, I've tried all ALL the fixes found on community and on net. Compatibility settings; Patch from 2K (2007 by the way); .ini one; sound card stuff; nothing has worked. Wanted to play through 1 & 2 again since it's been so long before I get Infinite to get me refreshed on the storyline. This is really a fail from 2K and Steam. I have friends that bought 1 and have never played it before; so now they are out $19.99 and no resolve in sight. Has anyone seen an actual fix or official thread noting the problem from either 2K or Steam? How is this fair to the customers who prebooked to get 1 and can't play it? Guess I have to break out the xbox from the basement! <walks away shaking head>
Scoots The Wut.wuT Apr 7, 2013 @ 8:00am 
i tried (2a but it did not work
Last edited by Scoots The Wut.wuT; Apr 7, 2013 @ 2:40pm
Scoots The Wut.wuT Apr 7, 2013 @ 8:01am 
can you please help
Arctic Apple Apr 7, 2013 @ 8:13am 
I did all of the above, and 2b) was succesful for me. I am using windows 8
Showing 1-15 of 29 comments
< >
Per page: 15 30 50
Date Posted: Apr 6, 2013 @ 2:24am
Posts: 29