BioShock > General Discussions > Topic Details
GeekaSeltzer Mar 29, 2013 @ 12:04pm
Bioshock.exe Crash Workaround
If you have a newer windows PC and bioshock.exe crashes no matter what, you may want to try a simple single fix to the default ini file that I found worked for my rig, Gumby (ASUS Z77 mobo, i7-3770k, Win8Pro64, 2 Radeon HD 7870's in CrossFireX).

1) In Steam pull up Bioshock's game Properties. Under the LOCAL FILES tab, select VERIFY INTEGRITY OF GAME CACHE... Wait for the verification process to complete.

2) Also under Local Files, select BROWSE LOCAL FILES and locate the Release sub-folder where the Bioshock.exe file is located. Also there should be the default.ini file which is invoked upon launch. You may want to copy it aside to something else, like default_save.ini, so you can revert if need be without repeating step 1. (The verify step reinitializes the default.ini file, among other things.)

3) Open default.ini for edit and locate the heading [Compatibility] near the bottom. The only line there is RequireMinSpec=true. Change the value from true to false, then save and close the file.

4) Optional: Under the General tab, select SET LAUNCH OPTIONS... and add the -nointro parameter. This will make launching the game freqently a less stressful experience.

5) Launch Bioshock and see what happens!!

NB: No windows file property compatibility changes should be needed, and neither should sound hacks be required. Your screen resolution will initially be 1024x768, so be prepared to adjust it upward. My Gumby now rocks Bioshock at 1920x1080 fullscreen, and with great sound. I hope this one simple fix helps you gets your rig rockin' Bioshock too. It's gotta be played now that Infinite came into this universe.
Last edited by GeekaSeltzer; Jul 1, 2013 @ 5:25pm
Showing 1-15 of 31 comments
< >
GeekaSeltzer Mar 29, 2013 @ 12:52pm 
Just minutes after I posted, an update to Bioshock was applied by the Steam client. As a result the fix I described proves no longer necessary, at least on Gumby.
Thanks Steam and game developers for resolving!!
Boogalu Mar 29, 2013 @ 2:11pm 
so the game works now without having to do this?! haha i was about to what u stated
PsychoDeli Mar 29, 2013 @ 2:43pm 
So this works on Win 8 64 bit?

I want to buy this but read that Win 8 is not supported?
GeekaSeltzer Mar 29, 2013 @ 3:46pm 
Yep, Windows 8 64 bit... and running like a charm now. My guess is 2K (and Valve) wanted this fixed as fast as possible, what with all the turmoil of late about the .exe crash. Now you can show a little love by purchasing your copy and (fingers crossed) enjoy it on Win 8! And in the event you do take the plunge, please do post how it runs for you... that'd be informative.
GeekaSeltzer Mar 29, 2013 @ 8:44pm 
Discovery: Bioshock.exe still crashes upon launch if FRAPS is running. Exiting FRAPS allows the game to start again but the screen resolution reverts to 1024x768 - no big deal adjusting manually. FRAPS starts after game (using alt-tab) but no visible fps, and screen and video captures come out black. Frownie face.
Brian D Mar 29, 2013 @ 9:02pm 
so this fix did not help me at all
Brian D Mar 29, 2013 @ 9:02pm 
I really want to play this but I cant. Please HELP! D:
Duskwood Mar 29, 2013 @ 11:52pm 
Game still doesn't work. Bioshock.exe has stopped working.
johnny5five Mar 30, 2013 @ 2:14am 
me 2
MrOattee Mar 30, 2013 @ 4:30am 
FRAPS was my problem. I just exited FRAPS and ran bioshock unaltered. Voila!
GeekaSeltzer Mar 30, 2013 @ 9:03am 
Correction: In my original post step 2 should read "copy it to something else" not "rename it to something else". Regardless, the change to the default.ini seems unrequired at this point.
GeekaSeltzer Mar 30, 2013 @ 9:06am 
Argus - glad you finally had sucess, albeit not without some finagling.
Kanaka87 Mar 30, 2013 @ 12:36pm 
did not work for me either, even with update.
GeekaSeltzer Mar 30, 2013 @ 3:34pm 
This is gettting weirder by the day. I've been following some of the related threads but personally found none of those tweaks necessary. And since nobody's suggestions help everybody there must be some more common denominator - other than the obvious fact of the age of the game. We have way more capable PC's now, with nicer OS's and more memory than most of our home 64bit systems don't even use. Yet why is this game not working like many older Steam games do? My guess is another update will be released at some point. It's gotta be worth it to 2K in order to cement the legacy of the BS series.
On a side note, I have a 3yo win7 box (Underdog) which I'll get up and running later just to see if BS1 runs or not. Geez, it's a beautiful holiday weekend where I live and I'm doing what??
NoNameNomad Apr 1, 2013 @ 6:45am 
After trying many combinations this worked on my system.

Windows 7 64Bit
NVIDIA GeForce GTx 550 Ti
AMD FX-4100 Quad Core Processor
16GB RAM
High Definition Audio Device

-----------------------------------------------------------------------------------------
Depending on what version widows you are using (32 or 64Bit)

Go to the Bioshock.exe Steam folder at:

Program Files/Steam/Steamapps/Common/Bioshock/Builds/Release/

or

Program Files (x86)/Steam/Steamapps/Common/Bioshock/Builds/Release/
-----------------------------------------------------------------------------------------
Right click on the 'Bioshock.exe' file and select 'Properties'
-----------------------------------------------------------------------------------------
Click the 'Compatability' tab.
-----------------------------------------------------------------------------------------
Select 'Run this program in compatability mode for:'
and select 'Windows Server 2003 (Service Pack 1)'
-----------------------------------------------------------------------------------------
Select 'Run this program as an administrator' so that it is
turned on
-----------------------------------------------------------------------------------------
Click the 'Apply' button
-----------------------------------------------------------------------------------------
Click the 'OK' button
Showing 1-15 of 31 comments
< >
Per page: 15 30 50
Date Posted: Mar 29, 2013 @ 12:04pm
Posts: 31