Scottgun Dec 19, 2012 @ 1:26pm
Does X-com Apocalypse look bad on your new PC? Read this.
If you are getting ugly text and strange artifacts in the artwork:

1. Find your dosbox.conf file in the xcom-apocalypse folder. (Steam>steamapps>common>xcom-apocalypse)

2, Open dosbox.conf file with Notepad

3. Find a line that reads "output=surface"

4. Change to read "output=ddraw"

5. Save the changes.

6. Launch the game. Should look much better.

Thanks to the guys in the "Glitched Writing" thread for the solution.
Last edited by Scottgun; Dec 19, 2012 @ 1:27pm
Showing 1-15 of 20 comments
< >
derim422 Dec 22, 2012 @ 1:23pm 
Any chance on getting this into the default download?
nickolaidas Dec 31, 2012 @ 9:37am 
Originally posted by Scottgun:
If you are getting ugly text and strange artifacts in the artwork:

1. Find your dosbox.conf file in the xcom-apocalypse folder. (Steam>steamapps>common>xcom-apocalypse)

2, Open dosbox.conf file with Notepad

3. Find a line that reads "output=surface"

4. Change to read "output=ddraw"

5. Save the changes.

6. Launch the game. Should look much better.

Thanks to the guys in the "Glitched Writing" thread for the solution.

Actually, you could also change some graphic filters while you're at it.

Find the [render] options on the dosbox.conf file (notepad can open it quite nicely)
scaler=advmame3x from scaler=whatever the hell Steam has as default.

These are the same scalers used in most 16-bit emulators and they work wonders on UFO Defence and TFTD, wonders.
nickolaidas Dec 31, 2012 @ 9:39am 
fullscreen=true
fulldouble=false
fullresolution=1920x1080
windowresolution=original
output=ddraw
autolock=true
sensitivity=100
waitonerror=true
priority=higher,normal
mapperfile=mapper.txt
usescancodes=true

Paste these on the [sdl] menu on the dosbox.conf file, and

frameskip=0
aspect=true
scaler=advmame3x

on the [render] menu.
Triple H3lix Jan 25, 2013 @ 8:26am 
Ok, I just have to say thank you Scottgun. I've been searching the interwebs for almost a year trying to fix this thing; should have just gone to the hub in the first place. Thanks.
Tericc Jun 25, 2013 @ 4:40pm 
This should be stickied
Max Power Jul 29, 2013 @ 2:38am 
The game wasn't playable for me in fullscreen until I tried your direct draw fix. Thanks!
scorpin17 Aug 21, 2013 @ 4:27pm 
thanks now i can play it on my new computer
Last edited by scorpin17; Aug 21, 2013 @ 4:28pm
GreyBeard Aug 21, 2013 @ 11:02pm 
Tried all that, and the game still plays in 256 colors. Unattractive and unplayable. Even updated to DosBox 0.74. Win7 Home Premium 64, ATI HD 5770. I play plenty of other DosBox'ed games w/ no issues. So it goes ...
Last edited by GreyBeard; Aug 21, 2013 @ 11:04pm
Max Power Aug 22, 2013 @ 2:17am 
Sorry to hear that. For me, version 0.74 solved all graphical glitches, crashes and the "insert CD" error, without the need of any other fix (including the ones from this thread). I am using Win7 32 though.
... stupid question, I know, but did you actually replace the DosBox files inside the apoc folder with 0.74, like described in another thread here, or just install it on your system?
Scottgun Oct 27, 2013 @ 8:06pm 
I see.
jdmeth_1990_15 Nov 7, 2013 @ 12:24pm 
fixed it for me!! Thanks
maxkmcdowell Nov 29, 2013 @ 6:14am 
Thats What I Call Sir.DOSBox
DasRedBeard Dec 14, 2013 @ 7:11am 
Does anyone have a fix for the delayed sound?
Cego em Tiroteio Dec 31, 2013 @ 5:44pm 
Thank you, Scottgun! Thank you, nickolaidas!
toni.haapasaari Jul 16, 2014 @ 9:42am 
thanks, worked perfectly for me. but i made a rookie mistake, i didn't save the game frequently enough so the game for some reason lost the mounted cd when i was playing and i wasn't able to continue.. i lost 4 hours worth of progression.
Showing 1-15 of 20 comments
< >
Per page: 15 30 50