Devastator Jim Sep 7, 2012 @ 8:36am
Technical Problems?
does anyone else find that they have issues getting this game to run on WIndows 7?. about half of the time I find it will fail to launch or Steam cant detect it. The game works fine on the occassions it does start up though
Showing 1-15 of 26 comments
< >
Urbanwastelander Sep 7, 2012 @ 10:32am 
Hey I play on windows 7 64 bit it runs good for me
Devastator Jim Sep 7, 2012 @ 10:45am 
hmm yeah it could just be this old computer i guess lol
Urbanwastelander Sep 7, 2012 @ 4:33pm 
What are you using ? lol
Bioreign Sep 7, 2012 @ 5:35pm 
I have the same Problem. Error message says "Failed to find Steam" no matter what I do.. nothing works. I remember that this behaviour began as Steam has made an update for itself.
But that's a good while ago, about 2 months now
I'm using Win7 x64

Jim, it can't be caused by an old PC. You know, that game was designed to run on Win95/98. And i hardly believe that you still run Win3.11 on a DX4-66
Last edited by Bioreign; Sep 7, 2012 @ 5:37pm
lmacconn Sep 7, 2012 @ 6:53pm 
I have to start by validating the properties on RT2, usually 1 file will fail and get downloaded (a few seconds), then it will validate successfully and I can play normally.
After a 2-4 hours of playing it will appcrash, and I can wait for it to recover itself in a few minutes, then go back to playing for another 2-4 hours.
[I'm running Windows 7 Home Premium 64-bit with 16GB RAM and AMD x6 1055T cpu & ATI HD 5700 graphics. This far exceeds the recommended system requirements for RT2 (set in 1998) of Pentium 166, 16MB RAM, and 1024x768 capable video card on Windows 95/98. Much better than other software from that era.]
Although I have not found it necessary - nor tried it with this program - you could try setting the program to run in compatibility mode. This has worked when I had problems running other old software on modern hardware:
...\Program Files (x86)\Steam\steamapps\common\Railroad Tycoon 2 Platinum\RT2_PLAT.EXE
right click - properties - select Compatibility tab - check "Run this program in compatibility mode for:" - select compatibility option (such as "Windows 98/Windows Me") - Apply.
Ellingham Sep 8, 2012 @ 2:58am 
Same problem, "failed to find steam" on start up! Occasionally fixes itself if I restart steam but even that is a touch hit and miss!
RiCZie Sep 8, 2012 @ 5:41am 
Had the same problem. Restarted Steam, checked integrity of the game (it was necessary to do it more than once) and since then I haven't had any problems (Win7 AMD64).
lmacconn Sep 9, 2012 @ 3:11pm 
I get the "failed to find steam" message when I try to run program directly or from a desktop shortcut, but no problem when I start the program from my Steam Library.
zzirSnipzz Sep 10, 2012 @ 2:59pm 
Originally posted by Devastator Jim:
hmm yeah it could just be this old computer i guess lol
Try restarting steam after you played or it wont restart
Pop-A-Smurf Sep 11, 2012 @ 1:38am 
I just reboot my machine. Works for me. :)
RCSimmons10 Sep 16, 2012 @ 1:02am 
Im running a Windows 7 Virtual Machine on my Mac Book and I find that sometimes during play that it crashes but no problems with it not starting. It is possible though that I am just using too many resources while playing running powerful apps such as photoshop, illustrator, indesign, etc. at the same time.
BILL COSBY, ASS SLASHER Sep 17, 2012 @ 6:04am 
I have this problem sometimes after Steam's been open for a while. Restarting the program's worked for me so far. I'm using Windows Vista 32bit, FYI.
solomonbrr Sep 22, 2012 @ 6:46pm 
I have no problems loading the game on my I3 laptop.
VisualMelon Sep 23, 2012 @ 3:58am 
I have this problem occasionaly, but a restart of Steam seems to get it working.
matt-patterson Sep 26, 2012 @ 9:45am 
I have only had problems in the last month or so. Same thing, i restart steam and it usually works. Once game starts it operates normally
Showing 1-15 of 26 comments
< >
Per page: 15 30 50