Tom Mar 18 @ 2:23pm
Gold vs Gold HD?
May I ask what the difference is between Majesty Gold Edition and Majesty Gold HD? I played vanilla Majesty a lot as a kid, and was excited when I heard steam had it. When I bought it though, I got those two different versions. Can anyone explain the difference, so I can know what is going on in each?
Showing 1-15 of 17 comments
< >
//// Mar 21 @ 4:17am 
majesty gold hd, is the same good old majesty in high-definition format. this means you can play it with nowadays graphics hardware. i didn't even tried majesty gold edition myself... i doubt it will work on my machine without doing extra computer stuff. :]
Lip_Gloss Apr 27 @ 4:25am 
For me Majesty Gold works but is not stable. It crashes from time to time.

I find Majesty Gold HD more stable. Also I can use 1920x1200 and 1920x1080 resolution.
There is no reason not to use Majesty Gold HD I think. Well, perhaps if you fire it up on an old computer with old OS.

I'm on win7 64bit and an i7 processor.
Tom Apr 27 @ 6:27am 
Okay. Cool. Thanks guys. Majesty Gold works fine for me. Or at least, it hasn't crashed yet. My concern was that it was two different games or something.
Huib-Bloodstone Jun 9 @ 1:05pm 
HD version has a few more fixes and gui, i recommend the HD version.
Jack Burton Jun 29 @ 6:41pm 
Any one know if Gold HD has the Northen Expansion. From what i've seen it lacks that and that make majesty even more awesome!
//// Jul 2 @ 1:20am 
yes, it's with northen expansion.
Andy Jul 3 @ 12:17pm 
HD does come with the northern expansion, and the two downloadable extra missions already in the game.
sungchiu Jul 3 @ 7:43pm 
I'm still waiting for them to add that mini icon for Gold HD.
//// Jul 7 @ 2:19am 
Originally posted by sungchiu:
I'm still waiting for them to add that mini icon for Gold HD.

^

+ 1
Afgerak Sep 25 @ 11:54am 
I just try to play it just now. Apparently its require something call directplay.
Once I install that, it let me launch MajestyGoldHD, but immediately crash.

Anyone else get it to run?
Dorgath Sep 25 @ 12:33pm 
It runs fine for me (well, starting the game).

As always, you should post your computer specs. Also see if anything in this thread[forum.paradoxplaza.com] can help.
Afgerak Sep 25 @ 8:01pm 
yeah, I checked the thread and none of the solution work for me. :(

My spec:

i7-3630QM Processor
8 GB DDR3
GTX670MX w/ 3GB GDDR5
Windows 8

Just to clarify: As soon as I launch it, a popup saying the game had stop working. Its simply crash. I can't even get to the title screen.

update:
Finally get it to work in windows mode. However, it stuck at lowest resolution setting. There is no other option in the resolution setting at all to choose from. Anyone have this problem?

Update 2:
Finally get it to work. I go into the game directory and run the exe directly. Once launch, I can then change the resolution. Exit the game. Now, when I launch from steam, the resolution stay at 1080, and it won't crash.

This is for those who met the same problem.
Last edited by Afgerak; Sep 25 @ 9:43pm
Dorgath Sep 26 @ 5:33am 
Great! Question though: in the first update when you opened it in windows mode and was stuck at the lowest resolution, the button to change (Change/Set Options/Resolution) wasn't there? So in update #2, when you ran the exe directly, the button *was* there? Did it still open in the same lowest resolution (I think 800x600?)?
Afgerak Sep 26 @ 11:04am 
No, the button is there. But when you click on it, you get an empty box (there should be a list of option for diff resolutions).

When I run the exe directly, everything is the same, except that the resolution windows are nolonger empty (I can choose to increase resolution). But yes, it open in the lowest resolution (800x600), until I changed it.

Once I exit that and use the steam shortcut, the new resolution stay.

edit: I think the crash related to the resolution somehow. Once I changed the resolution, it work fine now. I can even change the resolution via the steam shortcut.
Last edited by Afgerak; Sep 26 @ 11:05am
Dorgath Sep 26 @ 11:31am 
It sounds like the installation of DirectPlay (or was it DirectX?) set it to the lowest resolution or something. I wonder if you could have edited it manually in the registry or something... but it looks like you were able to get around it.
Showing 1-15 of 17 comments
< >
Per page: 15 30 50