Carotte Oct 27, 2012 @ 1:08am
Bug with Windows 8
Hi,
Cities in Motion crashes at launch with Windows 8.
Yesterday I was on Windows 7 and it workled fine, but today i'ts not working anymore.

When I launch it, the screen becomes fully darked during less than half a second and get me back to the Desktop. The "Cities in Motion.exe (32 bits)" process keeps running (32,2 Mb in RAM), but without any activity of the processor.

Any idea ?
Steam checked the files, it's ok.

Thanks

---
Here are the details of my comp :
- Windows 8 Pro x64 (6.2, v. 9200)
- Intel i5-2500K @ 3,3 GHz
- 8192 RAM
- Direct X 11
- AMD Radeon HD 6970, Catalyst 12.10
Last edited by Carotte; Oct 27, 2012 @ 1:13am
Showing 1-15 of 21 comments
< >
Jokaabel Oct 29, 2012 @ 3:21am 
hi there

it seems that windows 8 is haveing backward compatability issues with Cities in motion. since i dont have windows 8 i will tell you how to launch the game in compatability mode the windows 7 way. you may need to do it slightly diforently but im sure you will get the idea.

1.navigate to the cities in motion folder within your steam folder
your drive\....\Steam\SteamApps\common\cities in motion
2. right click on the Cities in motion application and right click properties
3. in the compatability tab select windows 7
4. launch the application directly from the folder and see if it works.

of cource i dont have windows 8 so im not sure how accuret this guide is.

hope this helps
Carotte Oct 30, 2012 @ 8:55am 
Hi,

Thanks for your answer.
I tried to launch CIM in windows 7 compatibility mode but it gives the same result : a blink of dark screen and back to Windows 8. The process appears with about 45 MB in RAM, but nothing appears.

In both cases, I have to shut down the process with Ctrl+Alt+Del, by right clicking on it and select "Finish the app" (translated from french - because I'm french - I'm not sure it's that in english). When I shut down it, I get the same blinking dark screen as when I launch it.

I think that CIM is well working in W8 (the app is responding, according to Windows), but it may be running somewhere Windows can't display it on the screen. Conflict between the new "Metro" display and the desktop ?

I tried to launch the game "as an administrator", but it does not give much more results.

:(
Jokaabel Nov 2, 2012 @ 1:31am 
hi there

sorry to hear that it did not work out to well for you.

you mention that there is a posability that the game might be on desplay out with your screen. how many do you have access to? if you have a second one close to hand and are able to why not plug a second one in and see how you go.

good luck :)
Last edited by Jokaabel; Nov 2, 2012 @ 1:31am
Carotte Nov 2, 2012 @ 5:40am 
I've only one screen, can't connect another.
But I think that CIM is running in backstage (because the process is not "not responding"), I think there is a conflict with the new Metro screen.

I found the official forums, but it's spammed a hundred times a day, it seems abandonned...

EDIT : I made an update for Steam. I retried to launch CIM : now, I have a blinking dark screen and immediately another one (less than a half second for each screen). The desktop appears between the first and second one. The first blinking dark screen launches the game, then bug (when desktop appears), then the game automatically close himself during the second blinking dark screen. No errors messages, back to Windows. Strange :/
Last edited by Carotte; Nov 2, 2012 @ 5:43am
RaymundoMazz Nov 2, 2012 @ 11:59am 
Personaly, I would just re-install steam AND cities on motion if you didn't already did that.
You should also erase the settings stored in the save game folder.
Windows 8 shouldn't be much different from windows 7(technical).
I dont have many other tips, I tried out windows 8... but didnt install it on my main computer because then I gotta install all my crap again.
Carotte Nov 3, 2012 @ 10:27am 
Ok, I'm currently re-downloading the game. I'll delete all files, including saves, controls, and crash files. I'll be back here when it will be done.
Carotte Nov 3, 2012 @ 10:40am 
So after re-installing (with saves deleted), I have the same problem. Nothing changes.
Each crash produces a .mdmp (dump ?) file in the Steam CIM folder.
How can I read them ? Where can I send them to help the CIM Staff working on that issue ?
Carotte Nov 3, 2012 @ 10:46am 
I've just sent a e-mail to Paradox Support with all .mdmp files attached and a DxDiag report.
I'll be back here when I get an answer.
Carotte Nov 6, 2012 @ 6:11am 
They found that my video drivers weren't installed. Thought, I installed the 12.10 Catalysts after upgrading Windows 8...
So I re-installed the 12.10 another time, and now CIM works.

This is so crazy, because Battlefield 3 runned at 100% perfs with Windows 8 and the Catalysts not installed ?? Crazy bug.

Well, my problem is closed :)
Thanks all of you for your help !
Jokaabel Nov 6, 2012 @ 1:25pm 
Hay no problem. glad you can carry on simming :)
fzn007 Nov 11, 2012 @ 11:26am 
Hi. I'd installed CIM yesterday. When I'm playing, suddenly, my game just close e back to the Windows 8 desktop. By the way, my another games run normally. I already changed the exe file for Windows 7 compatible, but, didn't solved this problem.

Somebody can help me?
fzn007 Nov 13, 2012 @ 10:53am 
I discovered that my problem occurs when I try to save my game. Somebody?
fzn007 Nov 20, 2012 @ 11:48pm 
KSMF, can you save your games without problem?
Carotte Nov 21, 2012 @ 1:30am 
I can, W8 Pro. Send an e-mail to Paradox (https://paradox.zendesk.com/home --> submit a request) with your DirectX Diag file and wait for an answer. They'll check your dxdiag file and get a solution for you ;)
Last edited by Carotte; Nov 21, 2012 @ 1:31am
LloydSev Nov 24, 2012 @ 9:54pm 
I am running Windows 8 Pro as well with no problems inside CIM.
Showing 1-15 of 21 comments
< >
Per page: 15 30 50