BlacK-ThUnDeR May 21, 2013 @ 1:09am
Low FPS in CS:GO Intel processor with a NVIDIA graphic card ??
You can try this !!
Showing 1-11 of 11 comments
< >
BlacK-ThUnDeR May 21, 2013 @ 1:09am 
Maybe this can help you guys.

I have a I7 3630QM with HD4000, 8 Gb DDR3 1600Mhz and a GTX680M.

When i first started the game i had 60-80 FPS, updated all drivers tried several FPS autoexec files still low FPS for a GTX680M.

I found out that the NVIDIA software didn't detect that CS:GO was installed on my computer.
So the HD4000 graphic driver from my I7 was doing all the work instead of the GTX680M.

I selected a list in the NVIDIA driver for not installed games, selected CS:GO and tell the driver to always use the GTX680M instead of the HD4000.

Now i got average 200FPS.

I noticed that many people with a Intel serie CPU with a onboard graphic card in combination with a NVIDIA gpu experience the same problem. Hopefully this will help them
OverlordTomala May 21, 2013 @ 1:15am 
Thanks for posting this. I've been trying to figure out why this has been running strangely on my laptop while my other source games are perfect.
BlacK-ThUnDeR May 21, 2013 @ 1:22am 
Same for me running Tomb Raider on High settings, AC3 fully open and CS:GO source on low settings :). Kinda strange, let me know if this works for you.
str1keforce -Alina (Banned) May 21, 2013 @ 1:37am 
everyone has their own opinion about what is low fps. I get 60 fps constant and it runs fine. thats low to some people with 200+
BlacK-ThUnDeR May 21, 2013 @ 1:47am 
Thats true, but when you have a high end graphic card and get 80 FPS thats low but still playable.
#BigPlays | The Pipe Cleaner Jul 13, 2013 @ 7:28am 
Originally posted by BlacK-ThUnDeR:
Maybe this can help you guys.

I have a I7 3630QM with HD4000, 8 Gb DDR3 1600Mhz and a GTX680M.

When i first started the game i had 60-80 FPS, updated all drivers tried several FPS autoexec files still low FPS for a GTX680M.

I found out that the NVIDIA software didn't detect that CS:GO was installed on my computer.
So the HD4000 graphic driver from my I7 was doing all the work instead of the GTX680M.

I selected a list in the NVIDIA driver for not installed games, selected CS:GO and tell the driver to always use the GTX680M instead of the HD4000.

Now i got average 200FPS.

I noticed that many people with a Intel serie CPU with a onboard graphic card in combination with a NVIDIA gpu experience the same problem. Hopefully this will help them

Where did you go for this, My cs go recently has been getting pretty low FPS and i use to get in the mid 200. do you mind giving me a step by step?
aIex Jul 13, 2013 @ 7:33am 
Originally posted by The Pipe Cleaner:
Originally posted by BlacK-ThUnDeR:
Maybe this can help you guys.

I have a I7 3630QM with HD4000, 8 Gb DDR3 1600Mhz and a GTX680M.

When i first started the game i had 60-80 FPS, updated all drivers tried several FPS autoexec files still low FPS for a GTX680M.

I found out that the NVIDIA software didn't detect that CS:GO was installed on my computer.
So the HD4000 graphic driver from my I7 was doing all the work instead of the GTX680M.

I selected a list in the NVIDIA driver for not installed games, selected CS:GO and tell the driver to always use the GTX680M instead of the HD4000.

Now i got average 200FPS.

I noticed that many people with a Intel serie CPU with a onboard graphic card in combination with a NVIDIA gpu experience the same problem. Hopefully this will help them

Where did you go for this, My cs go recently has been getting pretty low FPS and i use to get in the mid 200. do you mind giving me a step by step?


Right click on desktop - Nvidia control panel -> 3d Management or something like that (2nd option from top) -> Software (or program) setup -> look for CS:GO (if you don't see it, add it) -> Prefered GPU and you sellect Nvidia GPU.
ynz Jul 13, 2013 @ 7:42am 
Originally posted by Adolf Kitler:
Originally posted by The Pipe Cleaner:

Where did you go for this, My cs go recently has been getting pretty low FPS and i use to get in the mid 200. do you mind giving me a step by step?


Right click on desktop - Nvidia control panel -> 3d Management or something like that (2nd option from top) -> Software (or program) setup -> look for CS:GO (if you don't see it, add it) -> Prefered GPU and you sellect Nvidia GPU.

Thank you, that was useful!
jarjar1337 Jul 13, 2013 @ 9:02am 
why does the nvidia driver have to detect the game??
and do i have to do this with gt 330? GeForce Experience can't optimize games because gt 330 is too old
Last edited by jarjar1337; Jul 13, 2013 @ 9:06am
FANA Jul 28, 2013 @ 10:16am 
Sry but that is absolute ♥♥♥♥♥♥♥♥ what you are saying.
When you start up the mainboard detects if you have a graphics card in a PCIx16 slot. When you have something in there the processor GPU is deactivated.
ska1n Dec 25, 2013 @ 5:53pm 
when i select the nvidia gpu, i have constant fps drops from 100+ to all the way 20. have been having this problem since a month ago.
Last edited by ska1n; Dec 25, 2013 @ 5:53pm
Showing 1-11 of 11 comments
< >
Per page: 15 30 50
Date Posted: May 21, 2013 @ 1:09am
Posts: 11