Фантазија (Banned) Mar 31, 2013 @ 6:14am
Bad Optimization(Teribl FPS)
Hi people i have prety solid pc for this game
Intel Core 2 Quad 6600 2,4ghz
Asus GTX550TI
8gb ram
500silwerstone
and i have terible fps in this game ...
yeah i read a lot on other forum of and many say *you CPU,you pc crap...* but that is not true
This game is made on Source Engen from 2004 so my pc is Quad Core and i have on some map fps drop to 50fps :|. I not play on low i play all max out but on 1280x1024 and fps is like 70-80 and some thime belowe 60 WTF is this THIS IS ENGEN FROM 2004 HOW IS THAT .... WTF and cs go system req is OS: Windows® 7/Vista/XP

CPU: Intel® Core™ 2 Duo E6600 or AMD Phenom™ X3 8750 processor or better

RAM: 1GB XP / 2GB Vista

HDD: At least 7.6GB of Space

GPU: Video card must be 256 MB or more and should be a DirectX 9-compatible with support for Pixel Shader 3.0
WTF is this Vavle?
OMG this game is based on engen from 2004 when Intel Pentium 4 was on top and this s**** of game is terible becos of that!!! Vavle MAKE PERFOMANS IN GAME BETTER!!!! sory for bad engles
Showing 1-15 of 25 comments
< >
Vitdom Mar 31, 2013 @ 6:29am 
Append
-threads 4
to the launch parameters. It might just make a difference.

Also lower your settings and disable vsync etc.
GuNNuP Mar 31, 2013 @ 7:59am 
I have a little worse PC than you, i run the game at 60 fps, something is wrong on your PC.
Фантазија (Banned) Mar 31, 2013 @ 2:10pm 
In map Miltia and Aztec FPS drop to 50-55fps in few second but fps must be better i mean its still engen from 2004.
Phazar Mar 31, 2013 @ 2:12pm 
Try defragging your computer. That might assist some.
Anynamewilldo Mar 31, 2013 @ 8:36pm 
Vsync and AA off
furbYnator Apr 2, 2013 @ 12:50pm 
I have almost the same configuration:
Core2Quad Q6700 @2,66GHz
4 GB Ram
GTX660

Everything on Very Low/Low, everything turned off etc. (-threads 4, multicore rendering on)

Up to the last update I had about 120-170 FPS. But with the last update my FPS went down to 50-120. I changed absolutely nothing. From one day to the other (-> update) my FPS dropped really hard!

In other forums I read about more gamers experiencing this problem since the last update. This ♥♥♥♥es me off :-(
r1CKROIDZ Apr 2, 2013 @ 1:04pm 
i have same pc with nvidia gforce 9600 as video card and last night i got few huge fps drop .. the screen literally freezed for 3 seconds.. hope valve can fix the problem soon and i play on low settings..
Last edited by r1CKROIDZ; Apr 2, 2013 @ 1:05pm
fecske Apr 2, 2013 @ 1:14pm 
disable Aero, put "-high" in the starting comands to run CSGO with high priority, close every useless program, update your drivers, set CSGO settings to medium-low, and come back with the results, i have E7200+9600GT wich is way lower config than yours, and i have 70-90 fps with medium settings in 1080p, 50-60 fps in heavy fight
Last edited by fecske; Apr 2, 2013 @ 1:17pm
generatedname Apr 2, 2013 @ 1:18pm 
teribl, just teribl
furbYnator Apr 2, 2013 @ 1:44pm 
I used "-high" already, but I tried your suggestion of turning off aero. This didn't solve the problem completely but I gained essential FPS. Now I can play with constant 80-120 FPS (dust2, 7vs7). Thanks for the tip!

Nevertheless, these FPS are still too low for my system and were higher before the last update (I tried reinstalling cs:go already). Hopefully the next update will bring silencers and some FPS fixes.
fecske Apr 3, 2013 @ 6:46am 
yeah, still bit low for your config
charlie Apr 3, 2013 @ 1:48pm 
Overclock that cpu and your fps will be fine. Untill very recently i was running csgo on an E6600 (dual core version of what you have) and at 2.4 ghz i was sitting at 40-80 fps, overlocked to 3.4 i was running 80-150 fps with the same settings.
charlie Apr 3, 2013 @ 1:50pm 
Also your Graphics card is too powerfull is being bottlenecked by your cpu.
GETSHOTxJonas' Apr 3, 2013 @ 2:16pm 
The funny fact is that the engine you're sayin (from 2004) is the engine for CSS, not for csgo.exe . Only the basics has been copied from it. I played with Intel DUO 2.2GHZ and it runned OK until the december patch. Doesn't rly matter coz the CPU doesnt meet the requirements. I fixed it by overclocking it to 2.5 GHZ. Works fine with everything low except shadows. Stable 70 fps.
Processor: Intel® Core™ 2 Duo E6600 or AMD Phenom™ X3 8750 processor or better
Memory: 1GB XP / 2GB Vista
Hard Disk Space: At least 7.6GB of Space
Video Card: Video card must be 256 MB or more and should be a DirectX 9-compatible with support for Pixel Shader 3.0
These are the minimum requirements. (Haven't been changed since the release) and when your PC setups are at the limit of minimum you know that it might not work possibly with stable run. The PC's we are using (Intel DUOs etc) are at their very end in their fps gaming history.
Last edited by GETSHOTxJonas'; Apr 3, 2013 @ 2:20pm
furbYnator Apr 3, 2013 @ 11:44pm 
Yep, the architecture of these CPUs has aged quite a bit now. Though they still work very well in most games. Maybe I'm going to get a new cooler, so I can overclock it =)

With 80 FPS on cs:go I'm quite satisfied now. I was just wondering, why I lost about 40 FPS since the last update. Seemed awkward.

Another thing which I noticed is that turning on/off multicore rendering doesn't have this much impact on the FPS than it had some time back. When I first turned it on, I had about +80 FPS. Now it only makes 20-30 FPS difference (indepedent of the different modes).
Last edited by furbYnator; Apr 3, 2013 @ 11:46pm
Showing 1-15 of 25 comments
< >
Per page: 15 30 50
Date Posted: Mar 31, 2013 @ 6:14am
Posts: 25