Novax Jul 14, 2013 @ 3:55pm
Performance Issues with Skyrim
I will start off with stating my system specs:
Processor: I-5 2500k
RAM: 16GB DDR3 PC1333
Video Cards: Dual 660Ti Sli
OS: Windows 7 64bit Home premium

Okay, now what is happening is for some reason I took a huge hit in performance in skyrim lately. I used to play the game with at least 100-200 FPS. Now the game only runs with 30fps and is very choppy (This is with the auto detected settings). I was wondering if anyone could offer and advice to help me with this issue and this could also be used to help anyone else having issues.
Showing 1-10 of 10 comments
< >
[KL] Master Dan [StormCats] Jul 14, 2013 @ 4:00pm 
Y'mean like a HELP/TIPS/ISSUES with Skyrim, kinda thread yeah?...

Hmm, if only someone had thought of doing one of those, yeah.....
steam://openurl/http://lifehacker.com/5985304/get-the-most-from-your-games-a-beginners-guide-to-graphics-settings
Last edited by [KL] Master Dan [StormCats]; Jul 14, 2013 @ 4:01pm
Novax Jul 14, 2013 @ 4:03pm 
No need to be a ♥♥♥♥, I was just asking for some help.
[KL] Master Dan [StormCats] Jul 14, 2013 @ 4:14pm 
Why is that being a ****?

No need to insult someone who's helping either. If you look at the discussion forums, you might notice there is help available to your issues...or at least the link between you and your goal.

I doubt that is being a **** in my book, just try to look for help that's already there.
Last edited by [KL] Master Dan [StormCats]; Jul 14, 2013 @ 4:15pm
Novax Jul 14, 2013 @ 6:56pm 
You know what you were doing.
frogprincess_q4 Jul 14, 2013 @ 7:04pm 
Dan didn't mean it personally Novax, we try and help out and see a lot of the same questions so sometimes it gets a bit frustrating.
pike Jul 14, 2013 @ 7:09pm 
the first thing i would do would be run the game on a single card to see if the sli is messing up
[KL] Master Dan [StormCats] Jul 14, 2013 @ 7:37pm 
I'm not quite fully mature yet...still in that chrysalis phase...
Novax Jul 15, 2013 @ 4:43pm 
Apologies for the rough start. I ran on a single card, and it's the same thing. Normally I run everything maxed out and recieve no troubles, but for some reason it's not allowing me to now.
stabbykitteh Jul 15, 2013 @ 4:48pm 
Are you running the 320 series drivers for the Nvidia cards? They've caused some people issues, me included. You might try rolling back to 314.22.
Novax Jul 15, 2013 @ 7:44pm 
I will try that. Thanks.
Showing 1-10 of 10 comments
< >
Per page: 15 30 50
Date Posted: Jul 14, 2013 @ 3:55pm
Posts: 10