FÏÑÑ Feb 20, 2013 @ 1:41pm
Runtime errors of visual c++ library. Need help. Pleaaaasee!
Hey guys. I need your help. As you know, this error is fu**in' horrible. It started to apper after i installed DLC Dawnguard. Many hours of gameplay before this i spent with no errors like this.
_____________________________________
What i did:
1. I installed-reinstalled-wtf♥♥♥♥inlled-updated
-Skyrim
-Visual C++ redists (2005, 2008, 2010 and 2012)
-NET Framework (3.5, 4)
-Drivers (videocard, motherboard, sound etc.). It's up to date.
-Windows!
2. I verified hash of dawnguard.esm\bsa, skyrim files generally.. It's okay.
3. I cleaned-repaired registry (Ccleaner and Auslogics Registry Cleaner)
4. I cleaned the dust in my computer-box.
5. Cache of the game is checked. Okay.
6. I disabled many services in msconfig.
7. Googleing was a good idea. I googled over9000 forums, threads and mesages.
8. Unfofficial patches aren't a solution.
9. I have NO MODS at all. However i checked plugins.txt and DLClist.txt. It's okay
10. I checked my hard disk for errors with chkdsk. Good result.
11. Administrator mode.
...and many other actions.
All above doesn't solve my problem.
_____________________
My specs are there:
-AMD Athlon 64X2 5000+ 2.61 Ghz
-2GB ddr-2 RAM (yes, it's enough to play Skyrim, because it uses 700-1000mb and about 300mb are free)
-GeForce GTX550Ti 1GB.
_________________________
Configs of the game don't matter. DG is simple DLC, not Crysis-like. However i run the game in 1920x1080 with high textures (not HD pack), other on medium. Distance on medium-high values.
Well well. What i shoud do? Should i throw my computer through the window? THIS IS MADNESS! Seriously i don't know. I WANT TO PLAY SKYRIM (DAWNGUARD) WITH NO ♥♥♥♥IN' ERRORS! Urghhhh....it makes me cry. Really.
Showing 1-15 of 42 comments
< >
Digstar Feb 20, 2013 @ 2:10pm 
I had issues with this also. The ctd's were very sporadic but only started after leaving the Soul Cairn. Oddly enough I am not having these errors and I have no idea why. I uninstalled ALL the C++ from my PC and then followed links to reinstall. After a plethora of windows updates. I still however had random CTD's with the C++ runtime error.

The only possible "fix" that may have occured on my system may have been one of the following:

1) After relinstalling C++ visual, an update I received but not installed till a few days later may have sorted things out.
2) After purchasing Dragonborn, the problems seemed to disapear.
FÏÑÑ Feb 20, 2013 @ 2:25pm 
Thanks. I'll try uninstall all runtime libraries and install these again. So i already have many updates from WU. And this annoying error appears in Dragonborn's quest (quest with "crazy miner", who lookin for his ancestor) twice in the same place. I turned Вug-on-born off.
It's fine that Bethesda can't answer, WHAT causing this error. I think they must know what happens with DG (as developers they use debug programms).
Digstar Feb 20, 2013 @ 2:30pm 
Just bear in mind also, not all of the updates come through straight away. I'm pretty sure some of the updates were not available till a few days after I reinstalled the visual C++. I do believe though that the errors have something to do with Dawngaurd.

Edit: Try the below link too on the same subject.

http://steamcommunity.com/app/72850/discussions/0/846944689672283712/
Last edited by Digstar; Feb 20, 2013 @ 2:34pm
FÏÑÑ Feb 20, 2013 @ 2:48pm 
My issue also associated with Soul Cairn. I observed the errors after i leave Valerica and meet Durnehviir for three characters. Not before.
Buck213 Feb 20, 2013 @ 6:28pm 
Sorry, I have no help to offer, I also suffer from this after visiting Soul Cairn.

My list of things is pretty much identical to yours other than I never tried the unofficial patches yet, they were on my list of last resorts though. I have reinstalled everything at least twice after full formats, started new characters, and only once out of all my tests has a character made it through with out this problem. I just need to figure out why.
FÏÑÑ Feb 21, 2013 @ 4:17am 
Bro, i understand you. It's a nightmare.
Soo...i installed many many patches from WU (about 20), drivers for my nvideocard (with mark "FOR CRYSIS" huh) and went to bed. I'll test this. If it doesn't work, i'll try to complete DG with new character (third) again. Or not...
Daniel Feb 21, 2013 @ 4:55am 
Digstar Feb 21, 2013 @ 5:09am 
According to the link, the problems cause may be due too:

"This problem may occur when you use the /GR and the /MD compiler switches, and the version of the Msvcrt.dll file and of the Msvcirt.dll file is 7.0.x.

Note This problem does not occur when you use a version of the Msvcrt.dll file and of the Msvcirt.dll file that is earlier than 7.0. "


I didn't understand a word of that either lol but there is a hotfix on the above links link to MSofts that may help. Top job Daniel.
FÏÑÑ Feb 21, 2013 @ 5:48am 
Two different errors. Besides the error above appears in the source games (source engine) in WinXP. I use Win7. So i disappointed. But thanks for help.
.. I'm testing so far.
FÏÑÑ Feb 22, 2013 @ 1:51pm 
Hi again, dudes. Well...error appeared again, after 5-6 hours of "without-errors-gameplay". It's f*ckin' damnation. Any other solutions? I don't want to play Skyrim with new character. And i don't know, will it help me or not. DG was played me thrice, and always i have this problem.
I just want to talk with developers of DG about WHY I SHOULD BUY DLC (and any other products) IF IT CONSTANTLY CRASHES AND BETHESDA DOESN'T REALLY HELP (infamous and notorious advice is not help i think)? If I gave them money, they must give me stable working product, or they must fix problems, but i don't see any fixes or advice from Bethesda, even when hundreds (or thousands) of people have this problem, and mailbox of support is crowded. Sorry, but i'm annoyed.
I will write the letter to Bethesda again. Please, if you solved this problem, write here how you did this. I'll try any solutions.
Digstar Feb 22, 2013 @ 3:15pm 
My C++ errors were extremely sporadic. I had 2 within 15min. The next didn't occur till the next day.

One possible solution I used but forgot to mention is that I added Skyrim and the Skyrim launcher to the DEP (data exectution prevention) exception listing. Since about this time I have only had 1 forementioned error. Instructions below.

http://windows.microsoft.com/en-AU/windows-vista/Change-Data-Execution-Prevention-settings

Please reply if this works as I'm keen to also see if that was a possible solution for my errors.
Vandelion Feb 22, 2013 @ 3:49pm 
Well I am not a computer savvy as any of you are but am experiencing the same issues and it seems to happen with some regularity since dragonborn was downloaded
Vandelion Feb 22, 2013 @ 3:52pm 
What exactly does C++ and runtime do for a game?
Digstar Feb 22, 2013 @ 4:09pm 
Originally posted by Vandelion:
Well I am not a computer savvy as any of you are but am experiencing the same issues and it seems to happen with some regularity since dragonborn was downloaded
Dito. I'm not PC savvy either compared with many on these forums. I mainly try all suggested "fixes" and hope something works. Funny thing is when something does work, you can't be sure what fix "saved the day" lol.
Vandelion Feb 22, 2013 @ 4:42pm 
Digstar we'd make a great pair to bad this isn't coop1
Showing 1-15 of 42 comments
< >
Per page: 15 30 50
Date Posted: Feb 20, 2013 @ 1:41pm
Posts: 42