Cerbzerus Feb 13, 2013 @ 1:30pm
All save files turning corrupt
Everytime I play my save file it ends up corrupt and I have to start back off where I was that day. I stopped making any sort of progress ever since I got dragonborn and I dont want to get rid of it how do I fix this?
Showing 1-13 of 13 comments
< >
CycloUK Feb 13, 2013 @ 1:39pm 
I have exactly the same problem - it only started yesterday, quicksaves don't save, long saves and new saves don't show up, saves through tilda command dont show up and can't be found through windows, removing .ini files from savegame directory does no good, uninstall and reinstall still no change - what else can I try?
Cerbzerus Feb 13, 2013 @ 1:58pm 
This is the worst problem ive had yet
Buck213 Feb 13, 2013 @ 2:05pm 
Have you by chance tried creating a new character to test or disabling all mods if you have any?

Originally posted by CycloUK:
I have exactly the same problem - it only started yesterday, quicksaves don't save, long saves and new saves don't show up, saves through tilda command dont show up and can't be found through windows, removing .ini files from savegame directory does no good, uninstall and reinstall still no change - what else can I try?

Have you tried recreating your save folder?
- rename the Skyrim folder located at:
XP
%USERPROFILE%\My Documents\My Games
or
Vista/7/8
%USERPROFILE%\Documents\My Games
- start skyrim
- reconfigure skyrim
- exit skyrim
- copy your saves from the Old_Skyrim_Folder\saves folder into your new Skyrim\Saves folder
- test it out
Revue Mage Feb 13, 2013 @ 3:06pm 
I lost an entire character like this. No save was far back enough to be free of corruption. Best I can figure is that it has a lot to do with mods, and using more than 50 mods without cleaning them. I figured out that for me it was a bunch of dirty edits in some of the mods I was running.

If you have saved games that just simply go corrupt you must do everything I type here accepting that I have no idea what the hell I'm talking about and that listening to my advice will probably make your computer explode. I'm also a jerk. But my steps outlined here allowed me to keep some of my older saves (not the one I was trying to recover ironically) and I now have a cleaner smoother running Skyrim for my new character with more mods than I was running before, which isn't all that bad really.

So here's how I fixed it.

You're gonna need a few things.

BOSS
http://skyrim.nexusmods.com/mods/6

TES5Edit
https://code.google.com/p/skyrim-plugin-decoding-project/downloads/list

Nexus Mod Manager
http://skyrim.nexusmods.com/mods/modmanager

SKSE
http://skse.silverlock.org/

Stop playing the damn game. No seriously, don't even start a new game. Things are wrong and all hell has broken loose. It's time for some serious fixing.

(Now, you could take your chances and skip ahead to step 5 but I would STRONGLY suggest you don't. Your saves will be intact, but the errors from dirty edits can stack and create corruptions that last between saves. This is how I lost the save I was talking about, and probably my favorite Khajiit character of all time.)

1. You will need to take a deep breath, and uninstall Skyrim. Then go to the program folder and delete EVERYTHING. Again, this shouldn't even touch your savegames so relax. (Defrag if you need to.)

2. Reinstall the game and all the vanilla DLC.

3. Make sure you are subbed on workshop to all the mods you want, or download whatever mods from Nexus that you intend to run.

4. When your subscriptions are in order/all your mods are downloaded run the Skyrim launcher. Let it select your video settings and synchronize mods, but don't run the game yet.

5. Install Nexus Mod Manager, SKSE, and extract BOSS and TES5Edit to an easy to find location. BOSS and TES5Edit can be run from anywhere so just make sure it's somewhere easy for you to remember. You'll be using these a lot for now.

6. Run Nexus Mod Manager. Double check to make sure that the mods you want to run are enabled. Skyrim's launcher has a sneaky habit of not enabling certain mods when I want them to be. NMM is a safeguard against that. When your mods are enabled go ahead and close out the NMM.

7. Run BOSS. A neat little DOS looking window will pop up. Select Skyrim by pressing the appropriate number (0 in my case) and press enter. It might update some. It might not. Let it do whatever. It will then launch your browser and give you a little panel on the left and a log in front of you. Pay no mind to the log and guide yourself to the left immediately. Click on "Recognised Plugins" and start scrolling down the list. BOSS sorts your load order and detects any errors or conflicts. If your load order is anything like mine was, you'll notice that a bunch of your mods have a little message that says "contains dirty edits" and indicates that the mod needs cleaning. So how the hell do we do that?

Make a list of all the mods that BOSS flagged as needing cleaning and get ready for some serious hardcore clicking on stuff.

8. Run TES5Edit and get ready to cry. You'll notice that when you loaded the program it may have already selected a bunch of mods. It is being silly. Right click and click "select none". Now you remember that list you made? Select only the mods from that list. When you're done doing that, click OK and let it go to work.

You may notice that TES5Edit doesn't like BSA files. So any mods that have BSA files in them, TES5Edit will just pitch a fit. Fortunately for me that was like literally one mod. When it's done loading you'll have a list of ESM and ESP files in front of you starting with Skyrim.esm

9. You will now have to go down the list one by one and repeat the following steps to clean your mods and make them all shiny and smell nice.

(If you have the DLC then clean only from the last DLC you have installed. You may optionally clean previous entries in the list ie: Update.esm but do not clean any entry previous to Update.esm like Skyrim.esm or Skyrim.exe)

Right click the file, and click "apply filter for cleaning"
You might have to grab a snack.
Right click again and click "Remove "Identical to Master" records"
A big warning message might pop up. Click yes.
Right click again and click "Undelete and Disable References"

Do this for every mod in that list. When you are done try to close the program. It might ask you to save some stuff. Let it, and close it out.

10. Run Skyrim from SKSE and attempt to load your corrupted save. If TES5Edit was succesful in cleaning all the junk out of your save game then it will load up. It might be missing some content, but it's better than losing all those hours right? If this worked, then boosh! You're done! Go kill some Draugrs and make things from wolf skins.

If however you go to load the save game and you get a crash to desktop then it's time for some drastic measures. Proceed to step 11 and brace for the worst.

11. If you're here, then things are really bad. Errors and bad edits have conspired to create lasting corruptions in your save and there is only one option left, and it's probably gonna be a 50-50. First of all load BOSS again. Check the recognised plugins and double check that there aren't any bad edits. There really shouldn't be, but if there are... this means that you didn't load one of that mods dependencies. Rather than sort through and try to explain the difference between explicit and implicit dependencies or even worse try and tell you how to figure out which dependencies belong to which mod let's just do something much simpler. Longer? Maaaaybe, but simpler. I promise.

You need to load TES5Edit, and load every single thing on that list excluding mods that contain BSAs.

Skip to step 9, and clean every single entry from Update.esm down. This will take a very long time and you will likely want to kill someone before it is finished, but it must be done. This will ensure that any dependencies were loaded and cleaned. I managed to do this while watching some Netflix in an afternoon. Just a suggestion.

12. Go back to step 10. It should have worked by now. If it didn't... commit that character to the character boneyard and go drown your sorrows in some Tamika Vintage 399. Come back drunk as all hell and start a new character. Unless you're underage in which case, why do you have booze?

In my case doing all this restored two saves that I couldn't get back before, but failed to restore my latest savegame. I've heard that the sounds of skyrim mods are the culprit but I dunno.

Wow that was the longest forum response I have ever written, but seriously this blows and I didn't want anyone to go through what I did. Hope this helps.
Last edited by Revue Mage; Feb 13, 2013 @ 3:07pm
Cerbzerus Feb 13, 2013 @ 4:26pm 
Thanks for telling me all that I'll make sure to try it tommorow I'm sure itll be helpful
Revue Mage Feb 13, 2013 @ 4:29pm 
No worries at all dude. I seriously almost cried when I lost my last character so I totally understand. I since posted this as a new thread because it looks like you aren't the only person having problems but I'm more than happy to help.
Cerbzerus Feb 14, 2013 @ 12:59pm 
There is no BOSS on the nexus
Buck213 Feb 14, 2013 @ 1:02pm 
Did you try his link above as it works for me?
The link to download is on the Description page.
Last edited by Buck213; Feb 14, 2013 @ 1:04pm
TangleFoot Feb 14, 2013 @ 1:05pm 
Originally posted by cyth1:
There is no BOSS on the nexus
Follow the link and read the description. Alternatively, click here.
Revue Mage Feb 14, 2013 @ 4:33pm 
Double checked the link. All is well. Maybe the internet goblins have been at your system... DUN DUN DUN!
CycloUK Feb 15, 2013 @ 4:07am 
Just an update - I found the problem for me we that something (I suspect the Win8 update) had changed my folder permissions - so I no longer had access to my own folders, depsite being the admin - eventually figured a way round it and all is well again now - thanks to all for the ideas, I'm sure it will be useful in the future!
Spencer Aug 29, 2013 @ 8:20am 
Yaaay
[OTG]Taff Jan 17 @ 7:59pm 
I'm also one of those struck by corruption. Only it's the initial install. Will be following these steps and hoping for the best.
Showing 1-13 of 13 comments
< >
Per page: 15 30 50
Date Posted: Feb 13, 2013 @ 1:30pm
Posts: 13