Patrick Roanhouse Feb 4, 2013 @ 7:55am
My skyrim is still at version 1.3, steam is not updating it. What do i do?
I purchased this game at gamestop as the ps3 version kept bugging out on me. It was brand new and i'm playing it under windows 7. It won't update and i looked at the version info and it says its 1.3.9 I just want to play mounted horse combat. What gives? I have deleted my game and tried to restart a new one. Deleted local files. I keep getting a error of 1 file is not valid and will redownload but after it downloads this 735kb file i run the validation again and it still says the one file is invalid and downloads the 735kb file again. Its been about a year since i last played the game. HALP PEAS!!!!!!
Showing 1-8 of 8 comments
< >
DanteChrigu Feb 4, 2013 @ 8:50am 
When you deleted your local content, ie: let Steam delete the whole game, did you delete the Skyrim folder under steamapps/common as well? If you had mods installed then maybe something bugged out. Also, dumb question, and redundant when you deleted the local content anyway, but... is Skyrim set to auto update under properties/update?
That's the best I can think of right now.

Edit: Do you have the skse installed? If so, do you start Skyrim with it? If so, delete it and get the new version.
Last edited by DanteChrigu; Feb 4, 2013 @ 8:53am
Patrick Roanhouse Feb 4, 2013 @ 10:29am 
No i didn't delete the skyrim folder in steamapps/common. and skse is the skryrim execturer app right? I start the game by clicking on it in steam and that pops up te menu to change the graphics settings and what not or to start the game ... is that the skse?Also i have everything to autoupdate and even beta turned on. I just deleted all the workshop mods too.
Last edited by Patrick Roanhouse; Feb 4, 2013 @ 10:35am
DanteChrigu Feb 4, 2013 @ 10:38am 
No, that is the usual way to start Skyrim. The Script Extender (skse) is downloaded manually apart from Steam. So, if you never downloaded it, you don't have it.
Patrick Roanhouse Feb 4, 2013 @ 11:40am 
k i deleted the folder i then redid the install again but it still won't update. its stuck at 1.3.9 and it keeps saying some 756kb file is not valid then it redownloads it but still .... it keeps saying that file is invalid when i do a validation of data. I can play the game fine but just am not able to download updates. HALP!!!!!
DanteChrigu Feb 4, 2013 @ 11:55am 
Are you sure that you set Skyrim to auto update? I'm sorry if this is a stupid question, but it happens to all of us...
Right click on Skyrim in Steam, click on "properties", then click on "updates", and make sure it is set to update automatically. Restart Steam afterwards.
If that doesn't help then I am sorry. No idea.
Patrick Roanhouse Feb 4, 2013 @ 1:03pm 
ok i did it all and it was set for auto update already but it seems it just wouldn't update till magically resetting it again after making a new game. The old same game plays still too but now i have horse combat
DanteChrigu Feb 4, 2013 @ 1:08pm 
Good to hear. :)
rulo_0801 Oct 6, 2013 @ 3:01am 
I'll post again here as I can't create my own topic cause it says that I've published too much recently even though this is my first post ever. So any help is greatly appreciated.

I go to LIbrary, right click on Skyrim, select properties and only the Shortcut tab appears, no Update tab or any other. Why????? It's driving me nuts. All I want is to update the game.
I used to have the game folder on another location in my hard drive but then I installed Steam to update it but I had this same problem, thought it might be that the game folder must be inside the Steam folder so I moved it to the SteamApps folder: NO difference. What do I do?
Showing 1-8 of 8 comments
< >
Per page: 15 30 50
Date Posted: Feb 4, 2013 @ 7:55am
Posts: 8