Pugzz Mar 16, 2013 @ 10:58am
Skyrim Stuttering/Frame Tearing Issues *FIXED!*
EDIT: Apparently this is known as a "micro-stutter bug" and has been a problem with the engine that Bethesda has been using for some time now. If you have this issue, check out this mod. You may have to edit the antilag.cfg file to lower the FPS limit, but after that it should work seamlessly! HUZZAH for the interwebs.

First, here are the specs for my PC:

Intel Core i5-3750k @ 3.40 Ghz quad-core processor
2x AMD Radeon HD 7570 1 GB graphics cards running crossfire
12 GB of RAM

Here are some games that run perfectly fine at high FPS:

Diablo III
World of Warcraft
Minecraft

Now, these aren't exactly comparable to Skyrim in graphics, but it rules out that something might be terribly wrong with my GPU.

Skyrim defaults itself to Ultra-high settings when I hit the default button, which is great. I mean, at least it thinks it should be able to run well. The thing is, I have frame tearing and FPS issues whenever I run Skyrim on medium or higher settings. Obviously medium settings runs better than high and high better than ultra-high, but the frame rate issues are still evident, to the point that it bothers me and I don't want to play the game. I really don't want to settle for 'low" settings.

Any ideas/suggestions?
Last edited by Pugzz; Mar 17, 2013 @ 7:45pm
Showing 1-15 of 26 comments
< >
Pugzz Mar 16, 2013 @ 11:29am 
I should also note that when standing completely still in-game, everything seems to be running fine. No evident lag in NPCs movement or other environmental movement. It's only evident when I look around with my character. I've tried setting the mouse acceleration to 0 and that didn't help.
Dr. Shocks . DO Mar 16, 2013 @ 11:43am 
Do you have any mods or the HighresTexture DLC? WHat resolution are you running?
Pugzz Mar 16, 2013 @ 11:48am 
No mods or highrestexture. I am running 1920 x 1080 resolution on a 42" Panasonic HDTV. It may be my monitor has something to do with this. I just ran FRAPS with Skyrim in an environmental setting, and it logged 100+ FPS on medium settings, so nothing is wrong with my graphics cards. The weird stutter and tearing was still there.
Last edited by Pugzz; Mar 16, 2013 @ 11:49am
gaqo Mar 16, 2013 @ 12:23pm 
Some weird crap going on with this game! I keep getting rid of mods, just downloaded Nvidia Beta drivers, and used their optimization 'Geforce experience'. Hope I can stop it stuttering and CTD! There's loads of optimization possibilities online. Are you trying Beta version?If I can't fix it, I'll remove, and start again!!!
SupernastyPants Mar 16, 2013 @ 12:49pm 
I too have massive stutering issues when using the default Ultra settings.

The problem is specifically shadows on Ultra, they stress the CPU and cause intense micro stutter. What you need to do is set Shadows to LOW, everything else can be left on Ultra. Then, go into your SKyrimPrefs.ini and edit the shadows to be much higher quality without causing stutter.

fShadowBiasScale=0.1500
fInteriorShadowDistance=2500.0000
fShadowDistance=2000.0000
iBlurDeferredShadowMask=20
iShadowMaskQuarter=4
iShadowMapResolution=4096
iShadowMapResolutionPrimary=4096
iShadowMapResolutionSecondary=4096
iShadowFilter=4
fShadowLODStartFade=200.0000
iShadowMode=4
bTreesReceiveShadows=1
bDrawLandShadows=1
bDrawShadows=1
bShadowMaskZPrepass=1

Depending on your rig, tweak the settings to better values.

For example, lower the resolution tweaks to 2048, also note that by lowering Shadow Distance you increase the shadows resolution while increasing performance as well, but then you notice popin ore easily so its up to you to decide that tweak
Last edited by SupernastyPants; Mar 16, 2013 @ 12:49pm
Pugzz Mar 17, 2013 @ 3:52pm 
I'll give that a shot, but I'm not sure it'll work. There is still evident stutter running medium settings.
Pugzz Mar 17, 2013 @ 4:21pm 
Here is my SkyrimPrefs.ini data while my system is set to default "Ultra High" settings except my shadow detail, which is set to "low". What should I tweak and to what numbers?


[Display]
iBlurDeferredShadowMask=5
fInteriorShadowDistance=3000.0000
fShadowDistance=2500.0000
iShadowMapResolutionSecondary=1024
iShadowMapResolutionPrimary=2048
iShadowSplitCount=2
iMaxAnisotropy=8
fLeafAnimDampenDistEnd=4600.0000
fLeafAnimDampenDistStart=3600.0000
fTreesMidLODSwitchDist=3600.0000
fGamma=1.0000
fDecalLOD2=1500.0000
fDecalLOD1=1000.0000
fSpecularLODStartFade=500.0000
fShadowLODStartFade=200.0000
fLightLODStartFade=1000.0000
iTexMipMapMinimum=0
iTexMipMapSkip=0
iWaterMultiSamples=0
iMultiSample=0
iShadowMode=3
bTreesReceiveShadows=0
bDrawLandShadows=0
bFull Screen=0
iSize H=900
iSize W=1600
fMeshLODFadePercentDefault=1.2000
fMeshLODFadeBoundDefault=256.0000
fMeshLODLevel2FadeTreeDistance=2048.0000
fMeshLODLevel1FadeTreeDistance=2844.0000
fMeshLODLevel2FadeDist=3072.0000
fMeshLODLevel1FadeDist=4096.0000
iScreenShotIndex=2
bShadowMaskZPrepass=0
bMainZPrepass=0
iMaxSkinDecalsPerFrame=3
iMaxDecalsPerFrame=10
bFloatPointRenderTarget=0
Pugzz Mar 17, 2013 @ 4:26pm 
I tweaked my ShadowDistance and InteriorShadowDistance to 1500. There was definitely improvement, but stutter was still there. FRAPS still showed 100+ FPS on Ultra-High settings except for Shadow Detail, wihich is on low with some tweaks. Should I try capping my frames per second? How do I go about doing that?

Also, to rule out my monitor, how can I change my Vsync settings? I've read that since my monitor situation isn't the best, that might help.
Last edited by Pugzz; Mar 17, 2013 @ 4:26pm
Pugzz Mar 17, 2013 @ 4:36pm 
Tweaked my ShadowMapResolutionPrimary to 1024. Improvemant again, but stutter is still there. Couple more tweaks and I should be good. What else should I tweak?
Dr. Shocks . DO Mar 17, 2013 @ 5:01pm 
Perhaps there a setting on your TV to help with the stuttering.

I don't think it's the game as you have stated the FRAPS fps is well over 100.
SerfT Mar 17, 2013 @ 5:49pm 
skyrim runs best at 60 fps. do some research under 64hz micro stutter fix
Last edited by SerfT; Mar 17, 2013 @ 6:30pm
Pugzz Mar 17, 2013 @ 7:43pm 
Thank you so much! Guys, if you have this problem, check out this mod:

http://skyrim.nexusmods.com/mods/2581

You might have to edit the antilag.cfg file to eliminate the frame tearing, but other than that it works incredibly! The problem I was having was definitely a micro-stutter bug.
[RLC] SCAVENGER1 Mar 17, 2013 @ 7:52pm 
i had the same issue, but to fix it i had to go to nvidia control panel and set vsync to adaptive, after that my fps is at 60 fps all the time and no wierd gfx issue since.
Pugzz Mar 19, 2013 @ 3:39pm 
That's great! I have AMD cards and have no idea where Vsync is in my Catalyst Control Panel.
gaqo Mar 19, 2013 @ 4:26pm 
Yes it does seem possible to reduce that annoying 'stutter', by applying the solutions above. I just thought I'd tell you I'm having same probs with an Nvidia card(and Battlefield 3 runs fine),so I don't think its card related. That's a useful article,'Microstutter case study:Skyrim' @benchmark 3D.
Showing 1-15 of 26 comments
< >
Per page: 15 30 50
Date Posted: Mar 16, 2013 @ 10:58am
Posts: 26