Mechanity 2013年10月27日下午8:06
[FIXED] Skyrim framerate has suddenly dropped
Some background info: I'm running Skyrim with SKSE and a good 100+ mods (a lot of them are minor fixes) as well as ENB on performance mode, but I've been running it like this for a good few months and no problems.

Not really sure why, but out of nowhere Skyrim started lagging horribly. It began when I neared the end of the Civil War quests, and I've completed the questline (which took forever thanks to the lag) but still experiencing a terrible framerate. I haven't checked exactly what it is, but I wouldn't be surprised if it was less than 7 fps. No mods were suddenly installed to trigger this, nor any changes to my game settings or ENB.

Usually I get around 45fps outdoors and 60 indoors, if that helps. I have no DLC, no CTD's, my saves are around 15mb. I have ENB as an injector, so I tried turning ENB off. It might've changed my lag from 5fps to 6.

I also tried running BOSS, everything seems fine since I've cleaned with TES5Edit before.

Oh, and my GPU and CPU temperatures are on pretty normal temperatures (70c/50c during gameplay, respectively)

Lag seems to not really be dependent on certain areas, it's occuring everywhere in-game: indoors, outdoors, regardless of what map or how many people are in it. The only time lag doesn't hit is during the loading screens (loading takes the average amount of time, too) and during the main menu. It DOES still lag when I pause the game.

Rig Specs:
AMD FX-4100 3.6 GHz Quad Core CPU
8GB Patriot 1333mhz DDR3 RAM
AMD Radeon HD 7870 2GB GPU
Asus m5a78l-m lx Motherboard
Some GPU from CoolerMaster, 650W.

Any fixes that I can try?
最后由 Mechanity 编辑于; 2013年10月28日下午3:49
正在显示第 1 - 6 条,共 6 条留言
< >
MikuCore 2013年10月28日上午9:21 
any script heavy mods installed?
Mechanity 2013年10月28日下午1:20 
I don't believe so, there's no game-transforming mods on right now. Though, even when there were (i.e. Falskaar, the Jungle Mod), it didn't seem to affect the game much anyways.
MikuCore 2013年10月28日下午1:22 
something is wrong here... maybe try deleting your skyrim.ini and skyrimprefs.ini. you can copy them to your dektop as a backup.
Mechanity 2013年10月28日下午3:42 
Just tried that, not the issue. But I have found the problem. It's my save files.

I tried starting a new game, mods, ENB and all, and saved, loaded, restarted, and reloaded. The game is working just fine. But when I load my old save, the lag started up again.

I noticed a big size difference between the new saves and the old saves, (the new ones around 5mb, the old ones 15) so I went back and looked through my saves until I found one which wasn't too big or too far back (about 9mb, maybe 3 questlines behind my current) and it worked perfectly.

So now I know the issue, and I don't mind backtracking too much since it's not much progress. What I'm wondering now is how long it will be before my saves overload in size again or how I can prevent this. Any ideas? Thanks in advance.
MikuCore 2013年10月28日下午3:47 
in that case, good job
Mechanity 2013年10月28日下午3:49 
Never mind, I think I've found a fix.
http://www.darkcreations.org/forums/topic/3752-skse-cleans-invalid-scripts-from-old-mods/

The symptoms are the same as my problem, and I do have a lot of mods I've tried and scrapped, so I'm assuming this will work.
Apparently it takes a few hours for SKSE to purge all the invalid scripts from old mods though... :/
Anyways, thanks for your help and your time :D
正在显示第 1 - 6 条,共 6 条留言
< >
每页显示数: 15 30 50
发帖日期: 2013年10月27日下午8:06
帖子数: 6