SecretAaron Oct 19, 2013 @ 12:39pm
Help: Game/screen flickers (Windows 8.1)
I recently updated to Windows 8.1 and now my screen flickers when playing in fullscreen mode. In windowed mode it does not flicker. I tried to play the game in fullscreen and surprisingly everything (fps, graphics, view distance, etc.) looked normal with the exception of the game flickering making it unplayable (or at least unenjoyable). Anyone have any ideas of how to fix this?
Showing 1-15 of 35 comments
< >
🍞 Miku Wonderbread 🍞 Oct 19, 2013 @ 12:42pm 
do you use the same video settings as before your upgrade?
SecretAaron Oct 19, 2013 @ 12:43pm 
I initially tried 720p to see if that would improve performance on my game. Then I went back to 1080p with no difference in the flickering. Everything else stayed the same.
🍞 Miku Wonderbread 🍞 Oct 19, 2013 @ 12:45pm 
i heared about a lot of issues with win8.1... maybe you need to wait until microsoft fixes such problems...
Last edited by 🍞 Miku Wonderbread 🍞; Oct 19, 2013 @ 12:45pm
SecretAaron Oct 19, 2013 @ 12:45pm 
Alright, thanks for the help.
Edit: It might have something to do with the refresh rate of the screen. I am going to look into it a little more.
Last edited by SecretAaron; Oct 19, 2013 @ 12:48pm
FRAG.Sir Walrus Oct 19, 2013 @ 1:33pm 
Win 8 was designed for tablets in mind. Try lowering Graphics settings or if you have any graphics mods, turn them off. (This is also true if you have the High Res texture pack.)
Last edited by FRAG.Sir Walrus; Oct 19, 2013 @ 1:33pm
SecretAaron Oct 19, 2013 @ 1:44pm 
Originally posted by Spycrab:
Win 8 was designed for tablets in mind. Try lowering Graphics settings or if you have any graphics mods, turn them off. (This is also true if you have the High Res texture pack.)
I will try disabling some of my mods as that may help. Just so you know the desktop version of Windows 8 is almost the same as Windows 7 with the exception of the interface.
SecretAaron Oct 19, 2013 @ 1:47pm 
Disabling the mods didn't work. It starts flickering at the startup of the game.
FRAG.Sir Walrus Oct 19, 2013 @ 7:58pm 
graphics card up to date?
SecretAaron Oct 19, 2013 @ 8:50pm 
I was just thinking about my graphics card. AMD Catalyst Control Center broke with Windows 8.1 Update which could effect the switchable graphics part of CCC. I am going to backup (should of done it earlier) my Hard Drive before I start installing drivers, but I will try to see if I can set it up so my computer uses only my dedicated graphics.
Alembrik Oct 19, 2013 @ 9:01pm 
I wonder how many people have upgraded to Win 8.1 without any problems playing Skyrim and how many had some problems with it?

I'm going to hold off upgrading to 8.1 for a while. I'm not sure what the problems are with 8.1, but from some of the posts I've seen, it may require new drivers. Maybe by the beginning of 2014 all this will be sorted.
Lawrie Oct 22, 2013 @ 4:28am 
I have the exact same problem. Low FPS rate causes flashing screen. And it happens not only in skyrim, but also in many other games like mount&blade etc. Try running the game in compatibility mode. Win8.1 sucks :/
SecretAaron Oct 23, 2013 @ 6:44pm 
I updated my graphics drivers from the Dell support site and it resolved the problem.
UnKnOwN Nov 4, 2013 @ 12:58pm 
Same problem here
Fuzzy of the bear Dec 3, 2013 @ 8:19am 
Same here, But im glad its not just me with this problem, its the same with Dark Souls :/
SecretAaron Dec 4, 2013 @ 4:28pm 
Now I have to play in compatibility mode in order for it to play with a decent fps but now it has a blue border areound the screen as though it is being played in windowed mode. So fustrating.
Showing 1-15 of 35 comments
< >
Per page: 15 30 50