xmangibtown Nov 18, 2013 @ 6:45pm
elder scroll(dragon) glitched?
i am at the cutscene where i read the elder scroll atop the mountian... the cutscene stops when they say the dragon is coming... i have tried it a few times and still the same result.... is there a part i need to do before i read it? i mean it said i completed the quest and i needed to read it top the world or something... but like i said it gets stuck... any advice would help thanks.
Showing 1-4 of 4 comments
< >
Kelvy Nov 18, 2013 @ 6:54pm 
No just watch the battle at the end you return to normal, dragonrend will be in your inventory, click on it and look up just to the right of word wall and use it you do not get much time before Alduin shouts.
xmangibtown Nov 18, 2013 @ 7:00pm 
yes but i am telling you they are all just standing there... dragons are flying around above but nothing is happening... its like it is stuck...
rayrei81 Nov 18, 2013 @ 8:08pm 
It didn't work for me the first time, either. Reloading fixed it.
Trigger Nov 19, 2013 @ 8:20am 
use the unoffical Skyrim patch, it will fix the bug.
Showing 1-4 of 4 comments
< >
Per page: 15 30 50
Date Posted: Nov 18, 2013 @ 6:45pm
Posts: 4