The Elder Scrolls V: Skyrim

The Elder Scrolls V: Skyrim

View Stats:
 Saii  Nov 14, 2013 @ 8:28am
FPS drop after zoning
Problem
At all times I normally have a constant 60 FPS.
But randomly after zoning, or going in- or out a building/dungeon, the FPS drops to 40, 30, 20... and the game becomes "laggy", graphically stutters.

Workaround
The workaround is to ALT-Tab to the desktop and back into the game.
Problem with that is that it's annoying, the game sometimes crashes and you lose immersion.

Videocard and System
My videocard is an Asus ENGTX560 Ti DCII - Nvidia TX 560 Ti
My system is more than capable to run Skyrim on ultra settings, and it does... until i encounter this strange problem.

What I have tried
After searching on google, reading in forums etc. i found some solutions and suggestions, but none of them fixed the problem. I will list those solutions/suggestions below.

I've tried the following to fix it:
  • Played vanilla, with unofficial patch and with full mods. None of that have any influence.
  • Disabled energy saving in the 3d settings of the nVidia driver
  • Disabled FAA
  • Set AA to 2 samples
  • Tweaked SkyrimPrefs.ini to multithreaded (I have a 8 core processor)
  • Set bDeferredShadows=0 in SkyrimPrefs.ini (default is 1)
  • Tried with and without vsync on, (iPresentInterval=0 or 1 in SkyrimPrefs.ini)

Addendum
Sometimes ALT-Tabbing is not enough, and I have to start MSI kombustor with GPU burn-in.
It's like the videocard falls asleep and has to be poked to start working again.
Note that only Skyrim shows this behaviour in regards to my videocard, other games (gw2, swtor, etc) work fine and never "fall asleep". I say this, so you don't start pointing at my videocard, because that is clearly not causing the problem.

I would be very grateful if someone would have a solution for this problem, and an explanation what is happening here.

Thank you!
Last edited by  Saii ; Nov 16, 2013 @ 12:46am
< >
Showing 1-15 of 25 comments
MAU5 HOU5 Nov 14, 2013 @ 8:32am 
Thankyou for this, I am on a worse spec computer so my framerate drops are even more significant to the point of 10fps and below (which makes it unplayable) so any and all ways to work around this disaster of optimisation is much appreciated:)
Stalker Miku Nov 14, 2013 @ 9:05am 
check skyrim.nexusmods.com dor an 3 gb ram fix/lift
it seems that you run out of Ram or even VRAM, try lower texture settings first, fixed some folks problems
 Saii  Nov 14, 2013 @ 10:01am 
Originally posted by NightCore:
check skyrim.nexusmods.com dor an 3 gb ram fix/lift
it seems that you run out of Ram or even VRAM, try lower texture settings first, fixed some folks problems

3Gb fix is outdated, since Bethesda has implemented that in a patch. A few months after release, if I remember correctly. I'm running windows 7, 64 bit with 8Gb ram... so really shouldn't have a problem in that department.
Thanks for the suggestion though :)

Originally posted by grimus:
have you tried turning v-sync off, and capping your fps at 60 with your gpu utility software? i'm guessing you did but i didn't see it listed, so i thought i'd just throw the idea out there.

I haven't tried switching v-sync off. Read that it would give tearing on this particular videocard, but will have a go at it.
To disable v-sync, you have to add iPresentInterval=0 to the bottom of the [Display] section in SkyrimPrefs.ini

I haven't seen any possibility to cap the FPS. Is there a special utility for that, and would that maintain the FPS (which may solve the problem), or just limit the FPS (which would be of no help)?


Stalker Miku Nov 14, 2013 @ 10:08am 
Originally posted by Yamamoto Kansuke:
Originally posted by NightCore:
check skyrim.nexusmods.com dor an 3 gb ram fix/lift
it seems that you run out of Ram or even VRAM, try lower texture settings first, fixed some folks problems

3Gb fix is outdated, since Bethesda has implemented that in a patch. A few months after release, if I remember correctly. I'm running windows 7, 64 bit with 8Gb ram... so really shouldn't have a problem in that department.
Thanks for the suggestion though :)
i saw people, who still have this issue :) so its not oudated...
Flluroz Nov 14, 2013 @ 9:15pm 
I play with a constant 20 fps, on every pc game.... It goes down to 10-15 when I enter new areas. You're lucky.
 Saii  Nov 16, 2013 @ 12:55am 
Originally posted by NightCore:
Originally posted by Yamamoto Kansuke:
3Gb fix is outdated, since Bethesda has implemented that in a patch. A few months after release, if I remember correctly. I'm running windows 7, 64 bit with 8Gb ram... so really shouldn't have a problem in that department.
Thanks for the suggestion though :)
i saw people, who still have this issue :) so its not oudated...

Here's something to clarify the misconceptions about the 3Gb issue:
http://3Gb RAM Issue

When applying logic to the issue i presented, memory cap or any issue in that department has nothing to do with it. Simply because when using ALT-Tab to goto the desktop, and ALT-Tab (twice) to return to Skyrim will fix the issue.
Memory issues will result in a crash, and can not be fixed by changing the focus of the application.
Nineteen99 Jun 24, 2014 @ 10:53am 
I'm going to necro this topic because I'm having this exact issue. After an hour of playing, I get an extreme fps drop and alt-tabbing fixes it. However, if I exit the game while the low fps is happening, I have to restart my computer to load saves the next time I start Skyrim, otherwise it crashes (if I'm loading an outdoor save) or it freezes on the loading screen with the sound of the loaded save (if I'm reverting to an indoor save).
MageThis Jun 24, 2014 @ 11:31am 
O/P you listed your card, what about your system are you using a laptop?
Do you use Nvidia Inspector?
pedantic_roc Jun 24, 2014 @ 12:02pm 
My game sometimes slows down fps wise too - could be something to do with me doing 6 to 7 hour long stints - and when it does I either save and quit or (if I'm really into something) I just go indoors somewhere and type PCB into the consol. It worked in Oblivion, haven't tried it in F3 or FNV because I don't have any probs with those, and it still works (for me) in ESV. Give it a shot and if nothing else it'll free up some memory.
MageThis Jun 24, 2014 @ 12:13pm 
Nothing quite like a good flush of the ole' pipes.
Last edited by MageThis; Jun 24, 2014 @ 12:24pm
pedantic_roc Jun 24, 2014 @ 12:19pm 
Are you going to edit that? lol
Stalker Miku Jun 24, 2014 @ 12:19pm 
Can someone fix my name lol
MageThis Jun 24, 2014 @ 12:26pm 
Originally posted by pedantic_roc:
Are you going to edit that? lol

Errr.. yep. That was not, and I repeat, not a Freudian slip. It was my.. my..cat distracting me.
PG 18 Aug 11, 2014 @ 5:38pm 
I got the same issue but my fps drop to 1 fps so im completly forced to alt-tab ... and its anoying as ♥♥♥♥!

I got an I5 2.7ghz x4
GeForce 560 TI 4g
8 gig ram
windows 7 64 bits

so if anyone have a hint why only when I leave buildings for an exterior the fps drop to 1 ... I'd appreciate !
Last edited by PG 18; Aug 11, 2014 @ 5:39pm
Pellaeon Aug 27, 2014 @ 10:31am 
I have the same problem. I've been modding the game for the past couple of days to gain FPS outdoors. Been switching 2K texture mods to 1K etc. I alt + tabbed out to read something and when I tabbed back in, my game started running butter smooth at 60 FPS.

I am stomped as to how a simple alt+tab fixes my FPS. I wish I could find out what exactly is causing the stuttering so that I don't need to alt+tab out. I have an i7-3930k and a GTX 670 with fairly updated drivers.
< >
Showing 1-15 of 25 comments
Per page: 15 30 50

Date Posted: Nov 14, 2013 @ 8:28am
Posts: 25