lukeadamson Dec 31, 2013 @ 1:10pm
Skyrim flickering
I have put around 30 hours into Skyrim without having encountered this issue before. I have also used mods almost from the beginning without this problem before. But all of a sudden, when I boot the game up its like looking at an epileptic night club - its a flickering flashing image that is almost painful to watch. Worst with the initial logos of bethesda and dragon that gets better once the choice of 'new', 'load' etc. comes up but starts again when you choose to load/play new.

No idea what's causing it. Tried uninstalling and reinstalling game and mods but to no avail.

Specs:

Intel Pentium i5 3230M core 2.60 GHz
8GB RAM
900+ GB Hard Drive
64 bit Operating System/Processor
Intel HD 4000 graphics card with 2GB dedicated memory (Fully updated).
Being a laptop unfortunately has only 1366 x 768 resolution but hasn't proved a problem before.

No idea what is causing it or how to fix it. Doesn't occur for me on any other games as far as I am aware.


Showing 1-15 of 18 comments
< >
dakneo Dec 31, 2013 @ 2:18pm 
I wonder if some update, either from windows, or the game, effected your graphics drivers. Have you tried uninstalling, then installing the latest drivers for your HD 4000?
lukeadamson Dec 31, 2013 @ 2:43pm 
I have just had a look at doing that now... I did update it fairly recently - and since the last time I played the game. How might I go about uninstalling latest drivers though? Doesn't appear to be anything in control panel.
dakneo Dec 31, 2013 @ 2:45pm 
In Control panel, and under programs and features, there's no 'Intel HD graphics', or something like that?
Last edited by dakneo; Dec 31, 2013 @ 2:47pm
ᵏᶤᵚᶤ‰ Dec 31, 2013 @ 2:48pm 
try the Double Cursor Fix from nexus
http://www.nexusmods.com/skyrim/mods/36125/?
but remember to uninstall it if its not the problem so you will be sure that isnt adding or creating more problems
Last edited by ᵏᶤᵚᶤ‰; Dec 31, 2013 @ 2:49pm
[PHX]Echo1069 Dec 31, 2013 @ 3:06pm 
Try turning on V-Sync in nvidia or amd graphics profile, it fixed flickering and stuttering for me.
lukeadamson Dec 31, 2013 @ 3:44pm 
@dakneo - not as far as I can see.
@Echo1069 - How would I do that? (Apologies it is a fairly new laptop and I've never had to change graphics settings before as I've never had dedicated before).
@Kiwi - I'll try it though judging by the images he includes for the mod it does not look like the problem I am having.
lukeadamson Dec 31, 2013 @ 3:46pm 
And just tried without any mods. Still not working.
Buzzer Jan 6 @ 1:26pm 
its like this for me ill inform you if i have any luck PS. i have a high end radeon graphics card and 2.something quad core processor and its like this for me too
lukeadamson Jan 6 @ 2:03pm 
Thanks very much.

Yeah - I'm not great with computers and I only recently realised that the Intel HD 4000 card is the base card for my laptop and my dedicated is apparently an AMD Radeon HD 8750 with 2GB of dedicated graphics memory.

Only know this now because someone said that the HD 4000 isn't a dedicated so it didn't make sense that it had a 2GB dedicated memory. Can't find anywhere on my laptop itself that mentions the 8750 but it says it in my purchase order email so assume that is what is giving me the dedicated memory though have no idea how to access it from my laptop - can only seem to find evidence of the HD 4000.... weird but as I said I'm not great with computers...
Buzzer Jan 8 @ 7:24am 
k
Tomhap Feb 21 @ 11:23am 
Having the same issue currently, I belive it´s also because I updated an Intel 4000 HD. I have an inspiron 15R SE 7520 laptop with a 7700M Radeon HD graphics card as dedicated.

In no way does the issue resolve itsself since both drivers are now up to date. :( I guess the only way would be to delete the drivers and download older ones.
This is really frustrating.
Tomhap Feb 21 @ 11:58am 
Never mind, try setting skyrim's compatibility mode to windows 8. (program files->steam->steamapps->common->skyrim. right click the launcher you are using (might be SKSE) select properties, compatibility and set it to win8. credits for this answer go to ti.mmm.
Buzzer Feb 21 @ 1:35pm 
dude i just fixed this all you need to do is reinstall your graphics program etc and it works fine! try it
Shelt Feb 21 @ 3:06pm 
I'm on win7 running two cards in crossfire and get flickering when I bring up the ESC menu during the game. Otherwise it's fine. Not sure if SLI or Crossfire was supported by this game. It's not a big deal for me so I never bothered to try and "fix" it.
lukeadamson Feb 23 @ 11:52am 
Ah - I have it working now. Though for some reason its way more laggy than it was before even on really low settings... but at least it is playable again!
Showing 1-15 of 18 comments
< >
Per page: 15 30 50
Date Posted: Dec 31, 2013 @ 1:10pm
Posts: 18