MadCatCO May 18 @ 8:05pm
Broken Thieves Guild Quests
So Im replaying Skyrim, and aside from its normal minor bugs everything has been going well up until about halfway through the Thieves Guild Questline.

Issues started after 'Speaking With Silence' where 'Hard Answers' wouldn't trigger, and only sometimes would advancing the quest via the console with 'setstage' would it work. Once the quest was force-triggered, it ran just fine. However, at the end of 'Hard Answers' Karliah would just walk away and I would be able to trigger 'Trinity Restored' unless I forcibly moved her with player.movetome to force her to start the scene with Brynjolf. And as with 'Hard Answers' the quest worked just fine afterwards. Now I've reached the end of 'Trinity Restored' but I can't trigger 'Blindsighted' and the console commands will not work. I've tried replaying this section close to 10 times and I can't figure it out. On a whim I loaded Skyrim via Steam (I was previously playing it with SKSE) and managed to get 'Hard Answers' and 'Trinity Restored' to trigger just fine, but still no luck with 'Blindsighted'.

Anyone else running into this and found a solution? I've seen one other person make mention of this issue online but no one responded to their issue. Any help would be appreciated.
Showing 1-1 of 1 comments
< >
MadCatCO May 20 @ 10:22am 
I fixed it. The bug seems to be with Karliah, but I'm not sure.

To avoid being talked too, I jumped into the water and out of the room halfway down the hall, and used the command player.placeatme to spawn Karliah next to me. She ran through her dialog and reminded me to talk to Brynjolf, however as I went to go back to him I saw that Karliah was now spawned twice, once in the hall where I moved her to, and once in the room where the talk with Nocturnal just took place.

Brynjolf will automatically approach you to have the chat that finishes 'Trinity Restored' and starts 'Blindsighted' so I kept backing up, luring him away from Karliah #2 and into the hall. From there the dialog ran as normal, and the remained of the quests went on without a hitch.

Still not sure what caused it to bug out, I never had this issue playing vanilla skyrim (plus the unofficial patches), so perhaps one of my mods or SKSE interfered.
Showing 1-1 of 1 comments
< >
Per page: 15 30 50
Date Posted: May 18 @ 8:05pm
Posts: 1