Snigel May 7 @ 11:19am
Blood's honor quest bug (SOLVED)
Hi, I got the Blood's honor quest from the companions and you need to collect heads from some Hagravens in a cave but I cant get the heads I need. Do someone know of a way to fix this?

Edit: This is a list of things I have try'd to fix this:

Reloading a save before I entered the cave.
Spawning heads via console.
Giving one of the Hagravens/Witches one head and taking it back (this resulted in that the head disapered from the Hagravens/Witches inventory).
Check't if it was the right ones that I killed.

Edit: I have solved the problem by typing 'setobjectivecompleted c04 20 1' in the console. This completes the objective where you need to get the heads. Then I typed 'setstage c04 30' to get the objective where you return to Kodlak because if you dont do that, it will show that the objective is completed but the quest is still active and (Spoiler ahead) Kodlak is still alive and sitting in the chair where you left him.
Last edited by Snigel; May 8 @ 9:05am
Showing 1-13 of 13 comments
< >
matthias654 May 7 @ 11:31am 
You can reset the quest with a command in the console
the command can you find on the internet
wowszer May 7 @ 12:11pm 
Have you killed a Hargrave in the cave? It is one specific cave btw. When you killed her you should have got them then by the time you picked up your loot.
crapmonster May 7 @ 12:18pm 
As wowszer said, its not any Hagraven. The heads comes from the Glenmoril Witches in Glenmoril Coven. If its working correctly, you simply have to kill them and loot their bodies for the heads.

If for whatever reason the heads aren't there but the quest stage is advancing correctly, you can add the heads via console.
player.additem 2996f 1
Snigel May 8 @ 4:04am 
Originally posted by crapmonster:
As wowszer said, its not any Hagraven. The heads comes from the Glenmoril Witches in Glenmoril Coven. If its working correctly, you simply have to kill them and loot their bodies for the heads.

If for whatever reason the heads aren't there but the quest stage is advancing correctly, you can add the heads via console.
player.additem 2996f 1
I killed the Glenmoril Witches in that cave but they didnt have the heads in the inventory and I tryed to add the heads from the console to but that also didnt work
Ilja (Ref) May 8 @ 4:15am 
I can't find any reference to this bug. Glenmoril Coven is populated by standard hagravens prior of the quest. Those do not drop heads. This area does not reset, except for this mission.

It is possible that you have not yet slayed Glenmoril Withces. If the area had a probelm of setting itself, you might have killed mere hagravens. In this case Glenmoril Withces should appear there with area reset.

This is just a guess, but best that I can currently give.
SpeedFreak May 8 @ 6:01am 
I make a habit of making a save before a important quest ... if it it is bugged I revert to that save. I had yesterday a bug in the forgemaster's fingers quest arrow was all over the place ... no forgemaster's fingers reverted to an earlier save and it was not bugged.
Snigel May 8 @ 6:51am 
Originally posted by Ref:
I can't find any reference to this bug. Glenmoril Coven is populated by standard hagravens prior of the quest. Those do not drop heads. This area does not reset, except for this mission.

It is possible that you have not yet slayed Glenmoril Withces. If the area had a probelm of setting itself, you might have killed mere hagravens. In this case Glenmoril Withces should appear there with area reset.

This is just a guess, but best that I can currently give.
I must have killd the right Witches/Hagravens since the ones I killed had white hair unlike the regular Hagravens that have black hair and the ones I killed also had questmarkers on them
Snigel May 8 @ 6:52am 
Originally posted by SpeedFreak:
I make a habit of making a save before a important quest ... if it it is bugged I revert to that save. I had yesterday a bug in the forgemaster's fingers quest arrow was all over the place ... no forgemaster's fingers reverted to an earlier save and it was not bugged.
I loaded a save where I was outside the cave when I discovered that they didnt have the heads on them and that didnt work
Ilja (Ref) May 8 @ 7:16am 
Originally posted by xXpro_ghost_assassin_#macswagXx:
I must have killd the right Witches/Hagravens since the ones I killed had white hair unlike the regular Hagravens that have black hair and the ones I killed also had questmarkers on them

If they had questmarks, then you have killed right white haired lycantrophies.

Only thing that is left to ask is if you have installed Unofficial Patches? I did not find UESPWiki marking about this bug, so it is possible that haven't been fixed - or documented for - USP, but without any data nothing else comes to my mind.
Snigel May 8 @ 7:18am 
Originally posted by Ref:
Originally posted by xXpro_ghost_assassin_#macswagXx:
I must have killd the right Witches/Hagravens since the ones I killed had white hair unlike the regular Hagravens that have black hair and the ones I killed also had questmarkers on them

If they had questmarks, then you have killed right white haired lycantrophies.

Only thing that is left to ask is if you have installed Unofficial Patches? I did not find UESPWiki marking about this bug, so it is possible that haven't been fixed - or documented for - USP, but without any data nothing else comes to my mind.
At the moment I cant recall having any unofficial patches, but I will look into it soon.
Ilja (Ref) May 8 @ 7:20am 
Here you are. Rest of them have been linked below.

http://www.nexusmods.com/skyrim/mods/19/?
Snigel May 8 @ 7:48am 
Originally posted by Ref:
Here you are. Rest of them have been linked below.

http://www.nexusmods.com/skyrim/mods/19/?
Nope, havent installed the unofficial patches. It dosent seem to fix the problem anyway.
Snigel May 8 @ 8:20am 
Originally posted by Ref:
Originally posted by xXpro_ghost_assassin_#macswagXx:
I must have killd the right Witches/Hagravens since the ones I killed had white hair unlike the regular Hagravens that have black hair and the ones I killed also had questmarkers on them

If they had questmarks, then you have killed right white haired lycantrophies.

Only thing that is left to ask is if you have installed Unofficial Patches? I did not find UESPWiki marking about this bug, so it is possible that haven't been fixed - or documented for - USP, but without any data nothing else comes to my mind.
I've found a documentation of the bug now too but it doesnt have a solution tho.
Showing 1-13 of 13 comments
< >
Per page: 15 30 50
Date Posted: May 7 @ 11:19am
Posts: 13