jphillips2396 Mar 30 @ 11:17am
annoying
hey can anyone help solve a problem i have....just installed skyrim on my computer it finished but when i press the play button it automatically closes idk what to do ive tried running as an admin and still happens
Showing 1-12 of 12 comments
< >
MikuCore Mar 30 @ 11:19am 
reboot your pc
Trigger Mar 30 @ 11:31am 
YES to Nighcores REBOOT
jphillips2396 Mar 30 @ 11:39am 
i uninstalled and i am re installling ill reboot after
[KL] Master Dan [StormCats] Mar 30 @ 3:22pm 
Does your computer meet the minimum requirements?

Uhy veiy!
jphillips2396 Mar 30 @ 9:39pm 
its alienware i would hope so or i paid too much for nothin not bein a ♥♥♥
Alkpaz Mar 30 @ 9:46pm 
If you just bought it then we know what OS you should have which is Windows 8.1. Let us know if this is correct.
jphillips2396 Mar 30 @ 9:47pm 
nah i opted out of Windows 8 hate it im using windows 7
jphillips2396 Mar 30 @ 9:48pm 
but i literally just bought it two days ago it runs all my other games fine WOW, CIv V Dawn of War but skyrim itll go to a prompt after i click open i accept the launch screen pops up with play options all that noise i press play it just closes
Alkpaz Mar 30 @ 9:53pm 
have you used windows update to make sure you have all the security updates? Also, did it come with SP1? Right click on my computer in the start menu go to properties it should show the processor and RAM.
Last edited by Alkpaz; Mar 30 @ 9:54pm
jphillips2396 Mar 30 @ 9:53pm 
nvm i just looked up the the solution it was the registry.blob thing i needed to delete it off steam its working
Alkpaz Mar 30 @ 9:55pm 
lol haven't had to do that in a while for my PC. :P Glad you fixed it! :D
jphillips2396 Mar 30 @ 10:00pm 
im glad i spent all day at work lookin it up i was gonna lose it if i couldn't play skyrim cuz the ESO is out of the question good thing too :) thanks for coming to assist anyway
Showing 1-12 of 12 comments
< >
Per page: 15 30 50
Date Posted: Mar 30 @ 11:17am
Posts: 12