Ilja 3. mar @ 10:52am
Mod Organizer and FNIS
I have spent hours working with this, but I just can't get it right. I swithced to Mod Organizer, but I simply can not get FNIS data to work with Skyrim. I have done everything that was to be done (including fine print) from this guide: http://wiki.step-project.com/Fores_New_Idles_in_Skyrim

Additionally, I have also selected FNIS plugins and set both options as "True."

Furthermore I tested if FNIS actually worked properly from inside MO by inlcuding creature pack to it. FNIS regonizes and updates installed creature pack and spell animations. This does not affect to character in LAL prison.

I don't see anything else that I could or should be doing. I launch both FNIS and SKSE inside the MO. Game starts normally inside LAL prison, but game lacks FNISH data and each character I try to create suffers from scarecrow ragdoll effect.

Has anyone managed to get this work? If so, then how? I really can't play the game at all.

Edit: Yes, I downgraded MO, as instructed. That is how I got it to work in the first place.
Sist redigert av Ilja; 3. mar @ 10:54am
Viser 1-13 av 13 kommentarer
< >
HappyerbS 3. mar @ 11:07am 
This is how i launch FNIS through MO 1.1.1
Click on the Data tab on the left hand side.
Scroll down the list of installed mods find the file called "tools"
Right click tools,Right click GenerateFNIS_for_users
From the drop down Left click GenerateFNIS_for_users.exe,Right click it then select open
Ilja 3. mar @ 11:14am 
I can't find any EXE file from there. Strange. I can run FNIS trough MO dropdown menu, though. Problem is that I can't get the data to stick.

I have created FNIS Output (mod) from overwrite, but it doesn't seem to do anything. That, I think, is where this is going wrong.

Come on, guys. Any other ideas?

Edit: Characters do not get any FNIS spells. Perhaps I installed this incorrectly?
Sist redigert av Ilja; 3. mar @ 11:38am
Ilja 3. mar @ 11:51am 
Thank you. I am aware that where it should be. It is not and I am using the newer version of MO.

I would appreciate if you - or anyone else - would tell me how you managed to enable FNIS in your MO? There must be something that I am doing wrong, but I can't understand what it is?

I have tried to enable the whole RAR - as usual. That did not work.
I have also tried to peel FNIS for Users out of the RAR (trough MO). That was even worse, because FNIS did not even regonize animations.

Right now I am completely out of ideas. If nothing else works, then I will try the 1.1.1 version. However, if this is just me installing FNIS wrong with MO, then answers would be appreciated.
Sist redigert av Ilja; 3. mar @ 11:51am
Morkonan 4. mar @ 9:43am 
I don't know anything specific about FNIS. But, if you've done everything to be sure that all of FNIS scripts are working correctly, then I can only assume that it is a skeleton conflict that is causing your problem, not a scripting conflict.

Be sure that you are not letting any mods that alter the skeleton/rigging overwrite any custom skeleton, if any, that FNIS requires. Also make sure that you're not loading up anything after FNIS that modifies anything like animations or even scale settings so you can properly test it. If you even have something that overwrites any textures on characters, then temporarily take that out of your load order. Not all mods are made to the same standard and there could be something in one of them that is overwriting your FNIS necessary files.

Using MO, you can see exactly what is being overwritten in FNIS by other mods. Hunt for any information relating to anything that FNIS mods.

Have you ever installed any .dll files in the root directory that FNIS would need or that call anything that may conflict with animations/FNIS? Is another mod using the same .dll name that FNIS must call by itself? How about your data directory? Did you ever install anything directly into your Skyrim data directory instead of using a mod-manager that will keep it clean?
Sist redigert av Morkonan; 4. mar @ 9:45am
Ilja 4. mar @ 9:49am 
I did everything from the clean table and I am using XPMS Heavy skeleton - working especially well with FNIS.

I am able to get FNIS to run and realize that it has add-ons - like creature animations. All should be well, but game does not regonize FNIS data trough MO. I even updated my frameworks to be sure that there was not any missing DLL files messing with my system.

Heh. There's probably either very simple or extremely complex explanation for what is going on right here. Currentely my best bet would be to await for both MO and FNIS to recover from their resent updates and see what forums can come up with.

Of course, I wouldn't mind if this would be the forum to come up with something.
Sist redigert av Ilja; 4. mar @ 9:49am
Morkonan 4. mar @ 10:06am 
Opprinnelig skrevet av Ref:
I did everything from the clean table and I am using XPMS Heavy skeleton - working especially well with FNIS....

Did you use the appropriate file/patch for the skeleton? I just looked for a sec online, and isn't XPMS just the same XP32 skeleton? There's a patch specifically made for the XP32 skeleton so that it will work with FNIS: http://www.nexusmods.com/skyrim/mods/26800/?

I didn't take long enough to verify that they are both, indeed, the same skeleton. But, I saw a bunch of references from people who apparently have used either/both and many seemed to refer to them as "XPMS/XP32." It's not uncommon for skeletons to be the same, but have different names, just to show that they have minor changes to them.

You could patch/install the appropriate XP32 skeleton and see if that fixes the problem.
Sist redigert av Morkonan; 4. mar @ 10:10am
Ilja 4. mar @ 10:17am 
I appreciate your attempt to help.

Everything - including Skeleton and all animations - work perfectly trough NMM. I have made sure that this is not a patch problem with XP32 skeleton - that I actualy misspelled up there.

This problem seems to be with compatibility issues between FNIS and MO - or something in my system causing that issue.

I don't have to move to MO, but for several reasons I want to. NMM is till in Beta stage and has bugs of its own. Testing WIP mods trough it can sometimes be a real painful experience that could mostly be avoided with MO.

Edit: Am I realy the only one experiencing this trouble? I keep quite strict order in my mod department, so problem might actually be in my system (Win 7 and relevant frameworks.) I may have to revisit few pages to sort this out.
Sist redigert av Ilja; 4. mar @ 10:20am
Halinka Dinka Moo Moo 4. mar @ 10:29am 
Speaking of posing I tried FNIS because I wanted to use the dramatic action poses but they didn't even appear in my game as spells/items and it just kept doing CTD after a minute or two.. so at least you got further than me! haha. I'd try fixing it some more but I get very weary of playing with the files and saves because it usually ends badly if you don't pay attention..

Kinda hoping there will be something easier than FNIS with custom stuff in the future, but that'll probably never happen, hmm.
Ilja 4. mar @ 10:40am 
I do not know about the amount of your experience with FNIS, so sorry if I am telling you something obvious. :)

That is usually caused by selecting wrong boxes from FNIS before running it. I selected only top 2 for XP32 skeleton - the gender based and skeleton arm fix. Selecting others - if you do not actually have them as individual mods - can cause unpredictable behavior. If pose mods add other selections, then should also always be selected, in addition with top 2.

If you have some of these mods as individual mods, then I would recommend switching to XP32 New Animation Package[www.nexusmods.com] instead. There is no need to select extra options beyond top 2, even if you have selected the mod to be installed from this file.

I don't know about PCA, though, but that only affects to custom races and does only harm without one.
Sist redigert av Ilja; 4. mar @ 10:41am
Morkonan 4. mar @ 10:59am 
Opprinnelig skrevet av Ref:
I appreciate your attempt to help.

You're very welcome. Just realize that I may not actually be able to eventually help... But, at least I'm enthusiastic about trying!

Everything - including Skeleton and all animations - work perfectly trough NMM. I have made sure that this is not a patch problem with XP32 skeleton - that I actualy misspelled up there.

Gotcha. OK, I missed the ball on that call. Hmm..

This problem seems to be with compatibility issues between FNIS and MO - or something in my system causing that issue.

Very likely, I agree.

I don't have to move to MO, but for several reasons I want to. NMM is till in Beta stage and has bugs of its own. Testing WIP mods trough it can sometimes be a real painful experience that could mostly be avoided with MO.

I've only been modding Skyrim for a few days, btw. BUT, I do have experience with modding Oblivion and I understand most of the concepts fairly well. There is little functional difference, that I know of, the most dramatic being how intricate and well-formed these latest mod-managers are. I'm having a blast with MO! Just think - I can now mod "on the fly" with almost complete abandon. I'm giddy just thinking about it and my hard-drive space is shrinking, rapidly.

From what I have seen, MO, if it's stable for you, is the best choice of all of them. I say that because it provides the most flexibility and, IMO, safety. Though, User Error can still be a problem and I still have much to learn about MO.

Edit: Am I realy the only one experiencing this trouble? I keep quite strict order in my mod department, so problem might actually be in my system (Win 7 and relevant frameworks.) I may have to revisit few pages to sort this out.

No, you can be guarranteed that you're not. In fact, somewhere in the world, someone else dealing with this same problem and is screaming at the remains of their computer as they beat on it with an immoliated and recently deceased dead weasel... :)

OK - Let's go through the basic checklist: http://wiki.step-project.com/Guide:Mod_Organizer

1) Obviously installed MO.
2) Did you install the latest .NET framework?
3) Did you install the latest/correct Python libraries?

Next up:

1) You selected the appropriate game from MO's First-Run menu, obviously.
2) The Tutorial doesn't matter, but it does have a weird bug in one popup dialog box that ticked me off.
3) Automatically logging into the Nexus doesn't matter, either.
4) Same as above.

<Pause>

I just remembered something I read a few days ago: Doesn't FNIS have to be reindexed/whatever using SKSE every time you add/remove any animations or models? Have you successfully done that during your debugging phase, where you're likely adding/removing various mods, trying to hunt down the problem? I know it works now, using NMM, but I don't exactly know why.

<Unpause>

OK, lastly, the thing that everyone hates - Did you run the game through MO in "vanilla" and it works fine? What about only loading the bare minimum of what you need to run FNIS with MO? The bare minimum, no other mods, .dll files, data-directory changes, nothing?

I know it's frustrating, sorry for all the questions. I'm going to take a look at FNIS today and see what I can make of it as well as possible problems directly with MO. But, if you've got other mods stacked in there and have made changes to your game that aren't being managed by a good mod manager, even ones that you may have forgotten about, I wouldn't know where to begin. I would wish to, honestly. I enjoy trying to help people who love their games. But, I don't have the necessary info to work with. That's why debugging these issues is such a pain - It involves lots of complete reinstalls.

I'll d'load FNIS and, if I don't think I'll have any issues with it for my current game setup, I'll see what I can figure out by installing and running it.

Note: I didn't go through all the things like mod-order and debugging conflicts, BOSS and all that in this post. You seem fairly familiar with all that, so there wasn't much need. Just double-check MO's reports on your mods and any possible conflicts.
Sist redigert av Morkonan; 4. mar @ 11:02am
Halinka Dinka Moo Moo 4. mar @ 11:01am 
@Ref: I literally know nothing about FNIS so maybe that's why it didn't work haha, I'll try again on a seperate save with your advice! Sorry I can't help with your problem but I hope it gets sorted for you!
Sist redigert av Halinka Dinka Moo Moo; 4. mar @ 11:02am
Morkonan 4. mar @ 11:08am 
Note: This just in:

"...Half-T pose of all characters (or other strange animation bugs (despite correct FNIS generation). Sometimes the Skyrim cache is messed up for unknown reason. Run the Steam VerifyCache: Steam Client -> The Elder Scrolls V: Skyrim -> "Right mouse button" -> Properties -> Local Files -> Verify integrity ......."

Might be a good idea. (From the Posts section of the mod, from the creator - http://www.nexusmods.com/skyrim/mods/11811/ )


And, an interesting solution, according to one respondent in the Nexus forums:

http://forums.nexusmods.com/index.php?/topic/593117-fores-new-idles-in-skyrim-fnis/page-268

Evenstar072 - "...I use Mod Organizer and got the T pose, even if I installed FNIS and the mods for it in the default skyrim/steam folder and run GenerateFNISforUsers.exe. (make sure you don't get the T pose when you start the game without MO)

Here is how I fixed it:
- Extract FNIS behavior and FNIS spells to a custom folder
- Install all mods that require FNIS into that folder
- run GenerateFNISforUsers.exe (fix the warnings but obviously ignore the one about the wrong path)
- Zip the folder and then install it normally with Mod Organizer..."

That "fix" sounds like a reference issue with the Generator, not sure if that would work for you or not. BUT, MO uses a virtual directory to lie to Skyrim's exe about where everything is located. It's different in that respect, so that could be one critical difference between running it in MO and using NMM or another launcher.

Lastly - Are you running MO from a UAC directory in Windows? (User Access Control, ie: Programs directory) And, if so, are you "Running it as Administrator?" If not, it may not have the necessary permissions to prepare what the game needs in order for everything to run smoothly.
Sist redigert av Morkonan; 4. mar @ 11:20am
Viser 1-13 av 13 kommentarer
< >
Per side: 15 30 50
Dato lagt ut: 3. mar @ 10:52am
Innlegg: 13